Hubitat and Broadlink RM Pro + WIFI + IR + RF Remote Controller

Please, where I have to paste the URL?, I dont understand..

Do you have everything working using @rob121 's web interface? For example, can you learn commands and execute them and get the expected effect?

Once it works in the web configuration utility, you can install the http get switch example into your Hubitat drivers. Then install a new virtual device instance of that driver for each command or macro and add the URI in that device's settings sections.

@Rob121
Hi Rob, thx for creating this, however I can't discover my device, not even in manual mode :frowning:
Ran the exe of the latest version (1.07) as admin, opened up local firewall and then set the correct IP and Mac for my device in your interface. Tried all the RM variants that were listed and it's just not finding anything :thinking:
Any ideas as to what might be happening??

Looks like it's not using the IP I've set and also looks like it selects a port at random every time I try with a different device

Let’s start w/ basics

What broadlink device model?
What device is the software running on?
Is the broad link pingable from the device that hosts the software?
What method are you using to get the ip/mac of broadlink device?

Name shows up in my router as follows: Broadlink_RMPROSUB-99-ed-ce
Bought it here:
https://www.amazon.com.au/gp/product/B079NDS2B1/ref=ppx_yo_dt_b_asin_title_o00_s00?ie=UTF8&psc=1
They claim it's a differentiated version for the Australian market:
NOTE
about the version, we have checked seriously with the factory and we explain: This product of European regulations and American regulations are indeed a differentiated version, RM PRO+ and RM PRO. But the Australian version is not divided, so it means that, in AU, RM PRO+ is what we say RM PRO, and we can be sure that the item you received are the latest version, this information can also be found on the official website. any more question, contact us without hesitation

Your exe is running on a Win 10 Pro instance (non-virtualised)

Haven't tried to ping it yet.

IP/Mac comes from the information I get from my router.
IP for the RM pro has been made static in the router.

Ok, let me know his ping goes, I’ll do some research but it might be an issue with it not being compatible due to market issues.

Sorry Rob, haven't had a chance to retest yet but I think I know where it went wrong.
I have multiple SSID's at home and the laptop where I was running your exe from may have switched over to a different SSID to the one the Broadlink was on... D'oh.
Let me confirm that tonight :wink:

All good Rob, that's exactly what it was.
Didn't even have to do manual discovery, found my device fine as an RM2 Pro V2 in auto discovery.
Was able to learn commands too without any issue via your interface.

Also installed the HTTP Switch driver in hubitat, now if only I would have a clue as to how to use it :slight_smile:

hi
i read comments but its not clear to me. i have done so far is this
image
and added drivers code of HTTP get switch. What im i doing after? Can you please advise me step by step how to get this with HE.
please help
thanks

1 Like

Thanks for this! It works great!

Is it possible to add support for RF devices? I have some shades with RF remotes that I want to add to this.

Just curious, what would be the current blocks for getting an App to directly handle the communicating with Broadlink devices locally (without another server/android app)? We have LIFX local scanning, so is there are technical reason why someone couldn't code a HE app/driver to do that? @rob121 Why must you have another http server? Great work by the way.

I started on a simple driver to handle my RM Mini with basically on/off IR for my old TV but the main problem as I recall it was that Crypto API isn't exposed inside drivers code which makes it impossible!

Any others that are having problems to learn RF codes on broadlink pro+? Normal ir controlls no problems.

Yes I am as well. IR works great but RF not at all. It stays on 'Waiting for remote presses....' (red LED turns on on Broadlink) until I get the message 'Error: error while calling learn: learning timeout'
I have held the remote button continuously (I believe it continually tansmits during this time as it has a transmit indicator and has long press functionality), pulsed it and pressed it before the button on the web interface.

I tried with another 433MHz remote as well.

In both cases, I had no issues learning RF commands using the Broadlink app IHC.

My device model is RM pro+. 'Broadlink Manager' another program I tried to use also won't capture RF and my device is identified as 'RM2 Pro Plus3' in that software.

me too, won't accept the hex codes for RF remotes. The IR remote for TV works fine, but not RF remotes

Hi @rob121,
Is this something that you can look at in the program.?
Have Broadlink changed what they do on the newer devices?
Thank you for the great program by the way. I have it running on my windows 10 home theater pc controlling my IR devices with Hubitat. It would be great to be able to control my 433MHz blinds as well.

I feel I'm so close to getting this running; I have started the server and can control a Broadlink pro through the BroadLink Control App.... But I cannot get a Hubitat device running the "http GET switch" driver to control it..... I'm really not sure the format of the URI to use.
I am trying this:
http://192.168.1.145:80/send?deviceMac=34:ea:34:42:fa:a9&Codeid=01
But it is giving me this in the log:

2019-11-13 12:23:27.582 am warnCall to on failed: Connect to 192.168.1.145:80 [/192.168.1.145] failed: Connection refused (Connection refused)

--- Live Log Started, waiting for events ---

I took a guess at the CodeID - how can I find out what this should be?

If anyone could help it would be gratefully received

I used the BroadlinkGo broadlinkgo/README.md at master · rob121/broadlinkgo · GitHub to first record the command which saves it into a file. In the example below called 'tv_on_off'
Then using the HTTP get switch I use the command 'http://192.168.0.6:8000/cmd/tv_on_off'

Excellent thank you...
I will have a go when I get back from work.

Shame - That didn't work.. Still getting this error in the LOG:

Call to on failed: Connect to 192.168.1.146:8000 [/192.168.1.146] failed: Connection refused (Connection refused)

They are both on the same router.... do I have to set something else?