How to write rules to target the double-tap button press of the GE Z-Wave Plus Switch?

I have a GE Z-Wave Plus Switch, and I am wanting to see if there is a way to trigger a rule when the switch is double tapped? The switch can target other devices with a single or double-press/tap, and I was wanting to be able to double-tap my porch light to trigger a rule to do other things, but the only things I can really do that I know of is trigger rules when the switch is turned on/off digitally or physically, not capture whether it is was a single or double-tap. There probably is not a way to do what I'm hoping to do, but I thought it never hurts to ask in case someone else has figured out how to do this. :slight_smile:

If you use @JasonJoel's driver it exposes the double-tap. That's what I do.

1 Like

Ah, I got excited until I saw it didn't work with the 14xxx models, as I have the 14291, so unfortunately I guess this driver does not work with my model. Currently I'm using the custom driver from Matt Lebaugh (@mlebaugh) for this switch, but I don't think he implemented the double and triple press buttons, so is there another driver for this model that does that?

I think you are looking for this driver from @JasonJoel

[RELEASE] GE/Jasco Z-Wave Plus Switch Driver

1 Like

Correct, that one works with the 14xxx series, and exposes double tap.

I do not do triple tap like Matt Lebaugh's driver does as it is a kludgy software hack (not something supported natively in the hardware).

Feel free to add it back in to the driver if you want on your hub, but I won't be adding it in my driver.

So as it turns out, I was already using this driver, I just misread the driver info, so I think I'm not correctly using the double-tap right. In the device information screen, here are the instructions given:

"Devices are entered as a comma delimited list of IDs in hexadecimal format."

So what exactly am I supposed to put there, as apparently it is not the actual device network ID, and it is supposed to be in hex format, so then it should be something like "0x12345" then?

As an example, my Zooz Double Plug has the following information:

So how would I control this plug and what would I enter in the following double-tap field?

Any help would be much appreciated. :slight_smile:

Any ideas on this? I would like to do the same.

I'm confused - Have you tried entering the hex id of the device you want to associate it to, and it didn't work?

@JasonJoel I am using the GE Z-Wave Plus 14292 (not a dimmer), and working my way through this driver. I know this is a pretty old thread but wanted to provide some type of follow up to the last post which was your question.

I tried to enter a device using hex ID in Group 3 of the switch itself, and that resulted in not working when using double tap up or down. So using the group assignment in the switch itself via hex ID did not work.

I got around it by creating a rule in RM, using button as you instructed (here, or somewhere else) use button 1 and button 2 with "doubleTapped". This works fine and I removed the hex ID from the switch itself just to keep things clean. I also wanted to clarify that I used button, and not button action. So I have 2 rules, one for each, rather than one rule that has both actions in it.

Basically I wanted to confirm what the others had said. Entering the hex ID into the switch itself to try to use double tap did not work for me.

I am also wondering if button "held" is supposed to be supported. It's very weird, because I know I got it to work once. And it hasn't worked since. I am trying to program "button 1" when held to brighten the lights. I'm already using doubleTapped for something else. I created the rule, and can run it from the internet, but it will not work at the physical switch. I'm going to post about that on the other thread dedicated to the driver itself, but I have been reading and searching like crazy, and find it helpful when someone circles back or provides more information that either helps, or leads me down a different path to try to figure out. The last thing here was your question and no one ever responded so I figured I would. And please be warned...I know just enough to be dangerous and not enough to be helpful. But I am trying!

As I remember the [ZW4003 version of the] device does not return an event for HELD, so no it should not work. If I get time I'll look again, though, to confirm. Or you can confirm by turning on debug logging and trying it to see if a distince/different event comes in than the initial button press.

Also, do you have a ZW4003 or a ZW4009 model? Both are sold as "14292", but work very differently internally (the ZW4009 model does report things like HELD, the ZW4003 does not). I think you have to look on the device body to tell. Actually might be able to tell from the deviceId on the device details page too.

@JasonJoel I just attempted the switch held and it looks like it's only registering as an "on". I'm not seeing anything other than the on. As for which version of the switch I have, unfortunately I don't know. Back when I set my stuff up I didn't see the importance of keeping boxes or generic instructions (DOH). Or even taking pictures of the devices before installing them. Lesson learned...ALWAYS take pictures of the devices before installing, and tag with where they are.

The device network ID pulled in as 0B. I really regret not taking pictures...

WAIT a minute...I wasn't looking down far enough. * deviceId: 12343 So this might not be a 14xxx switch at all?? I'm certain this device said Z-Wave Plus on the back of it before I installed it, because I remembered I took OUT a non Z-Wave plus.

Not the device NETWORK id, the device Id. If it is more than 6 months old it is certainly the older ZW4003 version, though.

EDIT: I saw your adder above. All of mine are 12342, not 12343 - but that is likely just a small difference. So that would be an older model. All the new ones are larger numbers like 128xx.

Sorry, the device ID is below.

  • deviceId: 12343
  • deviceType: 18770
  • manufacturer: 99

Ok, that's an older one. So no HELD events.

Still don't know about the associations. I looked after the last report, and the associations are getting set on mine when I try to set them. Hard to fix something I can't reproduce. Could be differences in firmware or something else I can't identify though.

@JasonJoel I really appreciate your responsiveness.

If being able to use held and possibly triple taps is important, then I need to replace this switch with a 14xxx ("Enbrighten") series, correct? I might be willing to do that.

I can't believe how much more functional my switches are (and reliable) in Hubitat with reading/researching here and asking some questions, then I ever got with SmartThings.

I just saw your question...I thought I was brilliant figuring out to put a 0x in front of the number to enter as hex. How do I enter it as integer?

ETA: I just realized something else that could be important/pertinent. I'm using Switch Bindings on this switch already. It has to communicate with a dimmer switch.

I was wrong on the integer question. I looked, and the code is expecting hex. So never mind that.

Correct. I should look closer to verify that I exposed the held events, though. :slight_smile: Think I did though.

EDIT: My Enbrighten driver exposes these events IF sent by the device. I would have to go see if the device actually sends HELD events before I would guarantee that those work on the Enbrighten devices:

// Single Tap Up
// Single Tap Down
// Released Up
// Released Down
// Held Up
// Held Down
// Double Tap Up
// Double Tap Down
// Triple Tap Up
// Triple Tap Down

I can confirm that held does indeed work. I forgot the newest switch I installed in the living room is a 14xxx (and not a dimmer). So double tap, triple tap and held all work.

I just tested. Held is interesting as you do get it, but it turns on the load too... Nothing I can do about that, that's what the device does. I guess if there were no load on the switch it may still be useful - or if you were mirroring this device with another I suppose.

The point is that held is not independent from the local load. So people need to factor that in in their use cases.

So my intended use for it was only to increase the lights to 100% if they turn on at a lower level. So it would work for my case in the "up" (but not the held down, which ideally would dim but in use would turn off entirely).

I am using switch binding between a smart wall switch, and a smart dimmer. Turn wall switch on, the hidden lamp dimmer module turns on. Double press up on the switch, and another thing altogether turns on (and off with double down). I'm find with the light defaulting to the last state as I have modes in play to have them turn on and off and the level I need. But if I want to quickly increase the lighting, I just wanted a press and hold up. Probably don't need it often, but middle of the night comes to mind...if I'm getting up and needing to turn lights on in the middle of the night, I want them blasting because something happened to wake me up. But they would default to dimmed at that time frame.

Far more then I'm sure you wanted to know, but I do thank you so much for your time and responsiveness and these drivers!!