HousePanel Dashboard App for Hubitat

[RELEASE] V2.100

Details provided in the crosslinked post on the ST forum:

If you need some beta testing for HA let me know.... so long as I don't have to use docker LOL

I don’t have a HA integration implemented yet but if you want to use the Hubitat or SmartThings version, go for it. All you need to know is documented over at There are tons of features that need battle testing so creative and aggressive users are welcome. Here is a list of some of the more unique features that you will not likely find on any other dashboard product:

  • fully customizable look using either industry standard CSS editing or a full featured integrated GUI

  • multi user support with each user having their own look and feel

  • macros to string multiple commands together assigned to a user defined field on any tile

  • external function calls using POST or GET or PUT

  • API mode to control your home from other web applications

  • three pre-defined skins and unlimited options for defining user specific skins

  • custom tile creation supporting user text fields and the mixing and matching of fields from any other tile

  • music device support with active song art displayed based on public web search results

  • ability to place icons anywhere on screen using drag and drop

  • simple automation support - when motion or door sensors are linked to lights their actions will turn light on and off accordingly

  • ability to assign a password to any specific tile

As you can see from this list, HousePanel is filled with many features. I’m an army of one so some of these features have not been deeply tested under all conditions so I welcome new users and testers.


I'll have a go at this next week--or maybe this weekend and let you know the progress I get.

1 Like

Version 2.103 was released today. This version includes improved Album Art handling when you have the push app installed. This version also includes updates to handle water sensors with icons now provided.

Ok, I'm banging my head against the wall here. I stood up a new Ubuntu sever VM on my Hyper-V server.... Installed apache2, PHP7, mysql, node.js and npm. Went through all of the Housepanel installation instructions (several times now just to make sure that I could reproduce my error) and successfully installed the software on my server.

I can pull up and I can walk through the steps of adding in my Hubitat hub, OAUTH, the whole thing. My problem is that no matter what I put as the Username and Password, I cannot login to the web portal after I authorize all of my Hubitat devices. I've torn it down, deleted everything and tried several times, with several different usernames and passwords (including just a username and leaving the password blank).

What am I missing? Why can't I login here?

Log into your server and check to see if your username and. Are stored in the hmoptions.cfg file

It might not have permissions to store.

You can edit this file manually and remove the password so you can log in without a password as a backup.

Also, try creating your login info first and then hit Done button on bottom. Then go back to auth and add things after hitting Auth Hub #0

Hey I just saw this error in my logs... Might be a fluke...

2019-08-24 10:07:52.315 [error]java.lang.IllegalArgumentException: Command 'wet' is not supported by device. on line 1334 (doAction)

I have a bunch of water leak sensors spread around.... The error points back to the HousePanel app...

Some leak sensors support this some don’t. I need to do a bug fix to check for supported command. Should be harmless until fixed. Thanks for flagging this

This issue resolved with a minor patch that I just posted this morning - Version 2.105
Only update required is to download the updated HousePanel.groovy file into your hub. Please also update the housepanel.php app to keep the Version number updated, but strictly speaking nothing functional was updated in that file other than the version tag.

Thank you sir!

Cross-posting HP V2.107 Release

Hi guys, I asked the master personally too but I dont know how often he is around here.

I'm a total noob when it comes to programming but I somehow managed to set up housepanel on my rpi.

The only thing I've been trying to do for hours now is to install the pushnode.js to make tiles update immediately.

I'm simply stuck at the step on his homepage saying:

"Next, you will configure the app called housepanel-push.js The main GitHub repository contains a version of housepanel-push.js in the housepanel-push sub-folder. To use this you must first configure it using the npm package manager to load all of the required dependencies. Navigate to the housepanel-push subfolder and enter:

npm install"

How do I navigate to this subfolder?

thank you!

Edit: also do you know how many skins there are? I only know three skinnames....

Hi there ... thanks for using HP. Hopefully I can answer your questions and get you unstuck.

First, to install the push app you have to log into your rPi using ssh or perhaps you have samba set up. Once logged in, you navigate to the folder using standard Linux commands, But first you need to be in your html folder. Most people have that in var/www/housepanel

so do this:

cd /var/www/housepanel
cd housepanel-push
npm install

Regarding skins, there are only two good ones provided with the base app: skin-housepanel and skin-modern. One day I would love to see a community developed library of these.

1 Like

Thanks for your response! I used your and I believe it installed the housepanel-push.js.

However I'm still having problems getting it to work. So I can see the housepanel-push.service ( so I guess installing worked?) but the tiles don't do anything when refresh rate is set to 0 and I externally switch off/on my lights.

Also I'm having an issue with accessing my housepanel that I have created with the default directory. I just can't login. First I thought I got the password wrong but after installing it again and again ( even formatting the sd and reinstalling rasbian) and giving new passwords it still didnt work. Only installing housepanel in a new custom directory seems to create a dashboard that I can access.

Thanks for your awesome dashboard! I hope I can use it to its full extend soon!

(Btw: is using your enough or am I missing out on some crucial parts?)

Best regards!

(Edit: sorry I first posted it as a private message) should get you everything although before you run you will need your make sure you have Node.js installed. The install script doesn’t do that for you.

Sometimes you need to reload the push app by doing this:

sudo systemctl restart housepanel-push

On the password, your folder needs to be set for write capability otherwise it never gets saved.

1 Like

Hello and thanks for your answer.

I really don't know what I am doing wrong. I just can't login to my panel.

I did the "sudo chmod 777 /var/www/html/housepanel" part....and it still doesnt work.

I get to the authorization page and after authorizing the hub and trying to log in it does nothing....weirdly enough it used to work a couple of times in the past. Now it doesnt anymore. I don't know what I did differently then though....

Also: can I get back to the authorization page once it it is gone? Or do I have to do a full reinstall to get there again?

Thank you!

First, repeat the sudo command but make it:

sudo chmod -R 777 /var...

Then try loading your panel with this code:


then enter a new username and password and hit "Done Authorizing" button
This should take you to a login screen where you enter that same info.

If that still doesn't work, log into your pi and edit your hmoptions.cfg file using nano:

cd /var/www/housepanel
nano hmoptions.cfg

search for "pword"
and look to see if your username is there. It should look something like this:


This example is modeled after my pword section which shows that I have three logins. The master and kenw logins use the skin-housepanel skin and have their own passwords. The guest login uses the modern skin. Your section will probably only have one password. If you don't have this section then something is going wrong. If you make the password blank as "" then you will be able to login with the name and without a password.

Just installed everything from the doesn't work. I tried everything you said. I can see the file hmoptions.cfg, I accessed it with nano, deleted the password, and tried to login without a password. Nothing. It just won't now I know the code lines for installing it by heart hahahaha.....