HousePanel Dashboard App for Hubitat


#670

Hey Ken,

Is there a simple way to re-order fields in the Tile Customizer? I created a tile for my UPS and want to add some custom titles above the values... Each one I add drops to the bottom and I can't figure out how to move them around,


#671

Unfortunately there is no way to reorder them using the user interface. You can reorder them by editing your hmoptions.cfg file. Doing this requires extreme care to avoid missing any commas and brackets. All custom fields are displayed in the order listed in the hmoptions.cfg file. Also, all custom fields show below the built in fields so that order can’t be changed. However you can make any field position type absolute in the tile editor. Doing this will move them to the top. You can then slide them down by increasing the top padding. Play around with it to see what is possible.

Another option is to make a new custom tile that adds your custom fields first and then adds in your UPS fields using the LINK feature in the customizer. With a little creativity you can make any tile look however you want.

And finally you can always manually edit the customtiles.css file to style any specific tile and it’s fields however you like.


#672

By the way, I considered adding a field reorder feature to the GUI but dropped the idea because I couldn’t tell if anyone other than me was using the Tile Customizer besides me. Perhaps I will add this back to my list.


#673

Cool... I'l play around with it... Thanks for the suggestions and thanks again for all your hard work!


#674

HousePanel V 2.073 released tonight. Dramatic speed up of Tile Customizer and other bug fixes. Details documented in the ST forum.


#675

Hi folks. Today I posted a flurry of updates over on the ST forum that apply equally well to Hubitat. I removed the http requirement for URL links so Android app intents can be launched from the dashboard. A user on ST is doing this so take a look at the thread over there to see how.

The latest update also fixes bugs in the housepanel-push Node app that caused dupe and failures. Finally individual tiles can now have passwords.

Check it out - Version 2.078


#676

Hey @pdupper I forgot to mention that I added this in the latest release noted above too. Hope it works for you.


#677

cool! thank you sir :):grin:


#678

This was a bug that I found and fixed this morning in V2.078.


#679

Hey I'm noticing something strange... Now "admin" always shows up in the username box and clicking it allows anyone to authorize that as a new user... I don't use that as my admin account name... In any event, I can add a password to it, but don't think its very good security to have that username always populate the username field... That might lead to bad things... Is there a way to remove it from pre-populating? Or disable the admin account altogether?

EDIT; I've added a password to it for the time being... I'm cool if it needs to stay, but I'd like to hide it from auto showing...

EDIT 2: Protecting admin with a password doesn't help as you can enter anything into the username field and hit enter. That will take you to the authorization page where you can create a new user... No password, nothing else needed and you get access to everything...


#680

Let me look into it. Most people don't use the PW feature so I set it up so that admin doesn't have a PW as the default to get it, but once you set it you should be protected. If it isn't working that way then that is an implementation error. Let me investigate.

The new password scheme uses stronger hashing than before. It used to just use a stupid MD5 hash which any rookie hacker can crack. I certainly don't want to make it worse with a wide open hole so thanks for flagging this.

[EDIT]
I just tested it, and when you add a password to the admin user on the auth page, you are forced to enter that same password to get into the app with the admin user. I tried bypassing it using a blank password and it failed as it should have. Not sure what the issue is. Can you elaborate? Try going to the auth page, set a PW for the admin user and click "Done Authorizing" then try to login with anything else and it shouldn't let you in. Then type in the right password, go back to the auth page and enter the username you want to use regularly. Set that password too, but to something different. Then login with that username and password. Then enjoy HP. What am I missing?


#681

Four known bugs in the current version - thought I would post this before somebody else noticed:

  • Color circles are messed up sometimes. They show black and don't update when edited outside HP
  • custom, frames, video, blank, images tile count randomly gets set to zero - not sure why
  • if you replace a native field and then delete it in tile customizer, page reload needed for it to reappear on screen
  • POST, GET, and PUT not working properly in customizer

#682

Ok, lets say I want the main user to be "user1". I setup that account and all is good... Before the latest updates, the login screen was always blank... I could enter "user1" and my password and all was good... If I got the password wrong, then it wouldn't log in...

Now, it always defaults to "admin"...

Ok, I added a password so if someone was messing around and landed on it, they couldn't log in with admin...

Got me thinking and I started trying other things...

I enter a random user name and although it doesn't log me in, it does take me to the authorization page... I can then click through the options and add that user... So in a sense, if you try an actual user name with the wrong password, it will halt you... If you try a non-existent username, it will allow you to go through the process and create that user...

That seems like a major issue, especially since HP can control the HSM status and open doors, etc...

The minor annoyance was now it seems to default to the "admin" account upon each load. (I routinely delete my cache on devices for security.) I was hoping we could configure it to just be blank..

Another thing is I thought I'd just use admin and be done with it... I can't figure out how to remove accounts... I deleted the hm_user file with no issues... But the username I want to delete is still in the hmoptions file...

I tried to delete that username there and it messed everything up... :frowning:

I had to put back the original hmoptions file to get everything back...


#683

Thanks for the explanation. Helps a lot. Will look into closing this hole.

There is no easy way to delete an existing user other than editing your hmoptions.cfg file. That should work if you are careful to not leave any dangling commas or brackets.


#684

Thanks to @pdupper I was inspired to implement Version 2.081 that was just posted. This locks down the security to avoid bogus users without passwords plus a few other hole patches.

Version 2.081 with security updates:

Security lock down - no longer accept blanks to make new bogus user

  • reauth request via api if not logged in will return to login page
  • default user name not set to admin rather set to blank now
  • reauth page still available if options file is missing

#685

Thank you sir!


#686

Minor bug fix V2.082 available. Involves updating your housepanel.php and housepanel.js files only.


#687

As a preface, I will say that I have zero experience with housepanel and not much more with Linux.

That being said I installed housepanel on my Pi today and got everything configured, my hubitat authorized, housepanel saw my devices. However after that initial setup, I tried to login to the page to see the dashboard and it won't authorize. I tried blank/blank, admin/blank, a user/combo that I created when I dumped things and started over..... Nothing works. The FIRST time I visit, I can see the initial config page, but after that I only have the authorization screen that I can't get past no matter what.

Anyone know of anything dumb I might be overlooking?

Thanks


#688

The Login security has been updated to prevent ad hoc logins but I may have overdone it. Try logging into your rPI via SSH and deleting the hmoptions.cfg file and reload the web page. This should take you back to the auth page. Here be sure to enter a username and a password and remember what you entered. Then select done near the bottom. This should bring up the login screen where you enter the username and pw you gave. Then go back to auth and authorize your hubs.


#689

Cookies enabled?

Hmoptions.cfg set to writeable?

These are most common mistakes that cause auth failures. If all else fails I can show you how to manually set up a user with a blank password. Let me know.