HousePanel Dashboard App for Hubitat


#566

no biggie... enjoy your vacation... :slightly_smiling_face:


#567

Does anyone know why my custom names are not sticking in Modern UI? They are saving and when I go into edit, they are in the box... Just not displaying on the tile when in normal operation. The tiles override to the default device name... In that Material UI, this feature worked fine... Could it have something to do with setting up the tiles there? I set up everything using that UI until I realized it is not supported and depreciated... Spending some time now re-doing everything in Modern... Looks good and I even created custom icons, but the custom names is bothering me...


#568

There are two names displayed on a tile - a title header and a tile name. The modern skin uses the “tile name” field which always mirrors the native name of the tile. The custom name replaces only the title header which is hidden in the modern skin. To fix this you need to hide the tile name field for all tiles and unhide the title header field for all tiles. This can be done in the editor or by editing the skin file directly. You then need to style the title header to look the way you want it to. Again, that can be done in the editor or via CSS editing. I don’t know why I did it this way - just seemed to offer maximum flexibility to have both names around. I probably should update the modern skin to do this by default.

To style using CSS you will want to modify:

div.thingname

Hope that helps.

Ken


#569

Thanks Ken,

I'll play around with it... On another note, the hub does not always seem to be in sync with the HP. I'm using a Raspberry Pi to run my page... I have the IP of my Pi in the settings and using the port 19234 as recommended... I read a post from someone else about the ports and saw your responses... I'm assuming I have that setup correctly... I am interested in the pistons part, but from the reading I've done so far, WebCore is not recommended for Hubitat?

I'm an IRIS user and just getting up to speed on this platform. Sorry for all the questions. I really do appreciate all that you and others have done here...


#570

Yes, I would avoid WebCore on the Hubitat platform.

Do you have the Node.js program set up and running? You will need that for the instant updater to work. It is a bit finicky to set up but once set up it works great.


#571

I think I do... I installed everything via your script. I believe that was part of it.


#572

Type this in a rPI ssh session:

ps aux | grep housepanel

sudo journalctl -n 30 | grep node

The first command will tell you if housepanel-push is running or not

The second one will show you the last 30 log records of the push app if it is running.


#573

I'm guessing not... Here is a screenshot... No response after the second command..


#574

the node app is running but it isn't capturing any events - hence the journal is empty. Not sure why this would happen unless perhaps you have a firewall blocking your hub from sending packets to Node. This is done in the groovy file with the HubAction call. It could also happen if you have the wrong IP address for Host IP. Make sure that is set to the IP of your rPI - not your Hubitat Hub.

I'm finally home so I can do some troubleshooting on my end tonight to confirm I didn't break anything in the Hubitat version while I was updating HP on the road. When I'm on the road I can only test the ST side.


#575

Its set to the RPi IP... But how do I set the Port?

Coolio :slight_smile:


#576

Its just below the IP setting. Make sure it is the same as in your auth page in HP.

Should look like this:


#577

Yup, all of that matches... There should not be a firewall unless there is something native to the RPi OS I don't know...

On the subject of the tile header, I played around with the built in editor but can't figure it out. I've looked at the css files and not sure what to do there either... Is it in the customtiles.css file? Within the Modern skin folder?


#578

The css file you want to edit is in

skin-modern/housepanel.css

As for the editor, it is point and click. Edit using the green dot, then click on a header element then click unhide. Then change the background and font alignment then hide the name field. The CSS dire file edit is far easier for changes like this.

I might change the code to use the edited name. Stay tuned. Then you won’t have to do anything.


#579

I posted a minor update that fixes this issue in code so you can just update your housepanel.php file and reload your browser and all the custom names should now show up.

If anyone was counting on having the original names intact in the name field this update will break that. With this update all original names are lost when any user custom name is given.


#580

Okay - I did some troubleshooting on my Hubitat server tonight and found out a few things. First, I found that the Node server can get confused if it connects multiple times to the same server, and that sometimes happens. I don't have a clean fix for this but you can just restart your service and you should be fine. Second, I found a straggling old housepanel-push.js file in the main folder that needed to be removed. This could have been run by mistake. In the latest push I removed this file. On your server log into your main housepanel folder and enter:

sudo rm housepanel-push.js

Then navigate down to the housepanel-push subfolder and make sure everything is there. It should look like this:

If it isn't, upload the files from the main repo and then from your rPI shell while in this folder enter":

sudo npm install
sudo systemctl restart housepanel-push

This will load all the dependencies and then restart the service

Then go back to your HP web page and reload and refresh the page. Then open a new browser and navigate to:

http://192.168.xx.xx:19234

but using your real IP of course. This should return a status of your Node server and look something like this:

In the above example I have three clients attached.

If you see this you should be all set. If not, something is still wrong.


#581

You are my hero! Hopefully it was something everyone else wanted. :slight_smile:


#582

The more I thought about it the more I realized that it was stupid to not have the names match.


#583

Ok, just noticed a glitch with the new php file...

At first launch it does bring in the custom names... however, a few seconds later, it switches back to the real names on its own... a simple reload of the page brings custom names back but a few seconds later it does it again.

I tried restarting the RPi and clearing out the browser cache but it still happens... Any idea? I'm including a sample to show how they switch between the easier common name and the more complex naming convention I use to better manage devices from the hub...


#584

I was able to see the clients connected on the push page after removing the extra file and completing the commands you gave... tried to run the sudo journalctl -n 30 | grep node command after but it still returns nothing...


#585

I missed making the change in another place. Will fix it tonight.