HousePanel Dashboard App for Hubitat


#222

Really weird Chris. It looks like your Hubitat hub is reporting zero for the ID for any Hue light which confuses HousePanel. Let me look into it. My Hue bulbs return valid numbers so it isn't replicated on my end unfortunately.


#223

it does seem strange to me as well. I do have one version of the hmoptions file that works properly I am using it now.

It is strange that sometimes the error will pop up and other times not...


#224

Looks like id are right - but it reports 0 for the tile number on all of them.

So I deauthorized and reauthorized these devices. It seems like they may be playing nicely again for the moment.

Did the timing changes for the lock make it into the master branch? Seems I am seeing the icon glitch again.


#225

This is very useful debugging information. Thanks. Hopefully I will find where the ID numbers are getting stomped on.


#226

Yes - it made it in but I decreased the delay to one second which is apparently too small. Three second delay was driving me nuts ... I think I will modify it back to three seconds but only for Hubitat connected locks.


#227

if you can point me to the line of code, I can just change my version. No needs of making the masses wait for an icon change :slight_smile:


#228

Just started my journey switching over to Hubitat from ST. Very Exciting!!!!

Setup an RPi3 with WebCoRE and then added HousePanel as an aliased dir (did not want to set up a new RPi3). I also set the entire directory and below to 777. The dir is located at /home/pi/HousePanel with a link to /var/www/HousePanel and an alias in the default site.

The panel comes up, looks great and I can navigate around but I am unable to make any changes. Every time I hit refresh any updates (renaming, adding etc) revert back to default. This seems like a write issue but everything is writable.

My URL is "http://[internal-ip]/HousePanel/housepanel.php". I also thought that maybe using an alias was not the way to go so set up an independent site in apache using the wifi adapter address instead. Same behavior.

Not sure what I am doing wrong, is it a link thing? Kinda mystified about this.

Update: I rebooted the RPi3 and still the same behavior. I do not have any devices installed yet so could that be an issue? As a test tried to rename the "music" room to "music1" and reverts back to the default.


#229

Lines 1412 through 1418 in housepanel.js
change 1000 to 3000

if ( thetype==="lock" || thetype==="door" || thetype==="music" ) {
    setTimeout(function() {
        updateTile(aid, pvalue);
    }, 1000);
} else {
    updateTile(aid, pvalue);
}

#230

It is a write permissions issue. Make sure the parent real directory is set to 777

cd /var/www
chmod 777 HousePanel
cd HousePanel
chmod 777 hmoptions.cfg
chmod 777 customtiles.css

#231

Yep I did that - and then "chmod -R 777 HousePanel" for giggles.

/var/www/
drwxrwxrwx 8 pi pi 4096 Sep 28 14:21 HousePanel
-rwxrwxrwx 1 www-data www-data 1625 Sep 28 15:33 HousePanel/hmoptions.cfg
-rwxrwxrwx 1 pi pi 355 Sep 28 13:15 HousePanel/customtiles.css

Thanks for responding. I know I must have messed something up but not sure where to look.


#232

Make sure to do sudo chaos 777 * -R


#233

Here's a partial list of the HomePanel dir - everything writable as far as I can see. Again I am using the WebCoRE server but that shouldn't matter should it? Maybe I didn't enable something in PHP? or an ApacheMod? I did remember to install curl etc...


#234

Okay I think I may have figured it out.. I did a "chown www-data: customtiles.css" and now it seems to work.

Correction it does NOT work after a page refresh.. :thinking:

Tried different browsers on different computers, still no go. Seems like I'm missing something simple.. sigh.


#235

Looks like there is symbolic link for hmoptions.cfg. for me this is the file that always give me trouble if not properly writable. That file is created at first run. Maybe put it in with the other files?


#236

So I found the issue.. after looking at the apache2 error logs noticed it was dying on:

PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/20151012/php_curl.dll' - /usr/lib/php/20151012/php_curl.dll: cannot open shared object file: No such file or directory in Unknown on line 0

I edited the "/etc/php/7.0/apache2/php.ini" (and also the ../cli/php.ini as well but probably not necessary) commenting out my earlier enabled extension and giving a specific path:

;extension=php_curl.dll
extension=/usr/lib/php/7.0/20151012/curl.so

Restarted Apache and everything is now working {fingers crossed}!!!!


#237

Glad you got it figured out. I haven’t us d pho7 before so I will use this to update the documentation accordingly. By the way I dont think you even need to have 777 mode normally since the owner has wrote access, but it is easier to just do this for most people.


#238

I have stared at the code and tried to replicate this error with no success. Is it still behaving properly for you?


#239

Yeah I figured - normally I like to keep things locked down a bit tighter than that but I'm sure we'll get there eventually. I'd really like to switch to SSL for the web stuff. May play around with that at some point.

Thank you again for all your time and effort on this project - including responding to schlubs like me! It looks great and I'm having a fun tinkering,


#240

The code is written to fully support SSL so all you should need is a valid certificate on your pi and you will be good to go. The code senses whether you invoke https or http and responds accordingly.


#241

Hi folks... I am experimenting with something that is pretty cool. I modified the custom tile to take an API call that can send any random text to be stored in the options file. I am testing this with Stringify and the Maker tile such that when my doors open I increment a Stringify variable and then post a HTTP api call back to HousePanel to save the variable and display it on a tile. So I can now show on my panel how many times a door opens in real time. It is reset at 5AM with a different stringify flow. Similar things can be done with WebCore if you have it installed here or with a standalong Python app. The main change is the custom tiles now respond to API calls sending data IN to HP as well as page clicks that send data OUT of HP. I haven't posted this yet but I will soon. Just doing a little pre-release advertising...