Homekit Requires Hub Reboot

This has probably been covered, but wading thru the thousands of posts was proving too much.

Anyway, my friends system which I maintain is using the HOmekit integration. Been working fine. He calls last night and everything is "No Response". I restarted the integration. Had him close the app on phone and restart. Had him power down the Ipod Mini. Nothing worked. the only thing that solved it was a reboot of the HUB itself. C5 hub. Very few items are used, 6 Zigbee plugs, 4 virtual switches.

Aside from the Homekit, everything was working fine.

Why would that be necessary?

Here's a strange but similar problem. I was having problem with my zigbee lights (I have a lot of different protocols) which usually sorts itself out in if I restart my hub. I installed an update and had to reboot all my homekit hubs (2 Apple TV units and an iPad). It's been rock solid ever since, but I'm still thinking about the C8 hubitat..... money(sad).

This is starting to be a regular occurence. Homekit stops working. Restarting the integration doesn't help. The only way to get it back up and running is to do a hub reboot.

2 Likes

Have you tried rebooting your home network equipment (I.e. your router and wireless access points) when this issue occurs? What about rebooting your Apple HomeKit “hub” devices? I know rebooting the Hubitat hub works, but I am curious if there might be a different underlying issue at work here. My Hubitat C8 Pro, using the built-in HomeKit integration, has been performing great for many months.

I have seen numerous reports in HomeKit specific forums where this type of issue is resolved by rebooting routers and HomeKit hubs. Just curious if rebooting the Hubitat hub is masking the real issue?

1 Like

My guess is that there is some 'quirk' in Hubitat's MDNS networking implementation that has some interaction with some routers that causes all these issues. I've never had any issues with Hubitat and HomeKit on my Unifi network.

Same here. UniFi network, with AppleTV 4K as my Apple Home Hub. Been very stable and reliable.

Wondering if this is related to the rash of people who suddenly are having the hub think it is offline and cannot reach the cloud? Could that be making the HomeKit stop working as well, even though it does not rely on the cloud connection?

Sorry for the late response, busy weekend.

I have not tried on my friend's system to reboot his router/modem. He has ATT internet/TV and they supplied the unit. I think it might have been replaced some months back by ATT but not sure. He is about 3 hours from me so I haven't seen it in a while.

He did reboot the Homepod which didn't seem to help.

I had the same issue on my system some time back where I had to reboot the hub to get Homekit back up and running. After the fact I noticed that my router had done a reboot a few hours earlier. I have it set to automatically reboot once a week. But I had to reboot the hub to get things back working.

Not sure how HE ties into the Apple system and networking stuff, but kinda wondering if there is some issue with it all. On my friends system I don't believe he has backup power on the router. He does on the HE hub tho. So wondering if a power blib could cause that kind of issue.

Next time it happens I'll have him reboot the router and see what happens.

1 Like

Scenario that happened today.
This morning at 3 am my router did it's weekly reboot.
4 am, I had to get up to let out the 4 legged fur ball. (He's getting old and can't hold it).
Told Siri to turn off alarm. She told me she couldn't reach HE. (Or something like that)
Used keypad to turn off alarm.
Siri responded on POD via Airplay Integration that alarm was off. So Airplay was working.
5:30 am I got up for good. Checked phone and Homekit had no response.
Closed phone app, waited a little bit, re-opened app. Still no response.
I have a second hub with a second Homekit instance. So switched to that on my phone and it was working.
Switched back to my main hub instance in phone app and then it came back up.

Does any of this help anyone to give me some idea what might be going on?

Do you have only the one WiFi Access Point built into your router?
What device(s) are you using as your "Apple Home Hub"?

I am wondering is rebooting your router is the root cause of what started the issue? If you're using an Apple HomePod (WiFi only) or an AppleTV connected via WiFi, I wonder if yanking the WiFi AP out from underneath that device is what starts the issue? Just a hypothesis.

Or, if your Hubitat Hub is directly connected to your router's LAN port... Perhaps rebooting the router is what caused start of the issue?

In my home network setup, I am using UniFi hardware. Thus, if I reboot my UDM-SE (router), it does not cause this type of issue. However, my WiFi APs stay up and running, as well as my network switches. Thus, all devices on ,y LAN can still communicate with each other even if I reboot my router... Perhaps this is a difference that might explain why I don't see this type of issue? Again, just a hypothesis. I have no data to back this up.

Perhaps you could either remove the weekly reboot of your router? Or maybe run a test where you reboot it every day, to see if the Apple HomeKit connectivity issue correlates to router reboots?

I only have the one WIFI Access with both 2g and 5g.

I have several Homepod Mini's and 1 Apple TV

Yes

Gonna try this. The problem doesn't happen every week, or every time the router reboots.

On my friends system I don't know if his router/modem is rebooting for any reason. Maybe a power blib or it is automatically updating, etc. Not being there and he not being tech minded makes it a little hard to figure out.

Anyway, Just throwing out something I observed this morning in trying to narrow down what might be causing it.

EDIT: I wish there was someway to detect if the Homekit integration was down. So if his went down I could get a notification and try to take care of it before he might even notice.

1 Like

I'm having the same experience where devices appear offline in Homekit even though the Hubitat is online. Only way to solve this is restarting Hubitat. All my Apple and Hubitat devices are completely up to date, my routers are current, etc. etc. There is something in the App code it appears that is losing the connection to Apple Home.
I'm relying on Hubitat to handle home security devices now, until couple months ago this was rock solid. Any solutions?

Having the same issue. HomeKit is offline and requires a hub reboot.

We need to raise this as a concern to the team.