Homekit integration drops out of mdns?

I'm using Homekit and it has been 80% reliable, when I don't get any "No response" it is perfect but every now and then I get a "No response", I'm only using Lutron devices and 4 virtual switches to control my blinds.

After taking a closer look I noticed that Hubitat was dropping from mdns, "_hap._tcp". I can test and curl the homekit port for homekit but the device just vanishes from hap unless I do a hubitat reboot.

I'm using an Amplifi HD (upgraded to latest). What's a recommended wifi router out there? Odd that this only happens with hubitat, none of the other hubitat devices ever drop from it.

I haven’t seen any issues on my Eero 6 Pro mesh routers.

When the issue occurs, are you still able to connect to the Hubitat hub?

Yeah, Hubitat is responding and also the port that it uses for Homekit is also responding.

$ curl -v | jq -r .
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0*   Trying
* Connected to ( port 21063 (#0)
> GET /accessories HTTP/1.1
> Host:
> User-Agent: curl/7.87.0
> Accept: */*
* Mark bundle as not supporting multiuse
< HTTP/1.1 200 OK
< Content-Type: application/hap+json
< Content-Length: 4164
< Connection: keep-alive

That’s odd… I’m not a networking expert, so not sure what it means that Hubitat is dropping from men’s “_hap._tcp” - might be related? Can you elaborate on what this means?

Yeah. The way apple connects or discovers devices is through mdns/bonjour, basically dns discovery. An accessory (say Lutron or Hubitat) register themselves to “hap” and then that’s how Apple HomeKit is able to discover or connect to devices, if Hubitat drops from it then HomePod won’t be able to find it which is what is happening.

This is only happening with Hubitat, not with other Apple accessories I’ve. I’m not sure how often a device/accessory need to keep its healthcheck to stay discoverable.


Interesting, thanks! Tagging @gopher.ny in case he might be able to assist.

I believe I'm facing the same issue. A couple hours after booting my hubitat, all devices exported by hubitat show "No response" in HomeKit. This does not get resolved until I reboot hubitat.

I ran into the same issue about a month ago. I found that my Apple TV, which is my HomeKit hub, had dropped its DHCP reservation from my network. Once I gave its reservation back and rebooted both my devices, I have not since had an issue. I’m not saying this is necessary the issue, but it worked for me.

1 Like

Thank you for that recommendation. I also gave DHCP reservations to my hubitat c8 and Apple TV, and now I do not run into this issue. It's a workaround and not a fix, but it's a good workaround.