Help Disassociating Wink Sensors, ugh!

I haven't added the MyQ device yet and I'm not sure how to add it. The MyQ hub is plugged into the wifi router and doesn't say zigby or z-wave on it. And the github readme doesn't really explain.

It is not either Zigbee or Zwave. For lack of a more technical explanation, this Hubitat app emulates the MyQ app. In other words, we are faking out MyQ to think we are using their app.

You need to go to that Github, and copy/paste the Raw link (click the Raw button), and copy the URL at the top of your browser.

Go to app code, new app, import, and paste that URL into the box. It should import a bunch of code. Save and exit.

Repeat with the driver, using the driver code tab. I think with the driver you have to choose sensor, or no sensor.

You will go to Apps tab, install a user app, and choose MyQ.

From there, enter your MyQ login credentials, and it should walk you through a couple steps.

If that works, we can go from there.

Thank you....BUT that's where I'm at. I did the login credentials and then nothing happened. I clicked Done and I'm at where I'm at now.

So if you go to the Devices tab, did you get a device called MyQ, Garage Door, or something like that?

You also should see this with your email account that is used for your MyQ, in the MyQ app:

Device tab, look for the place where I blacked out, it should have an ID code there. If you have that, you are most of the way there. The Hubitat MyQ app worked.

Mine looks like your except it says no MyQ devices connected.

On another note, I just powered off my Wink Hubs and am full Hubitat at this point:)

Only things left are MyQ garage opener, nest smoke/fire detectors and Rink Doorbell Cam which I have separate apps for anyhow but would love to integrate into Hubitat

In the app, or device page? I am assuming app?

If it is blank in the app, what happens if you click on "Tap to Modify Account"? Mine gives me an option to choose a device, then sensor, then creates a device. I think if you aren't logged in, it asks for your login credentials instead. Does that work?

And just because I am assuming a bunch of stuff, you are using the credentials you log into your MyQ phone app, right?

This is what I see in the app screen

I think you are missing a driver. Look just above the "release notes" grey bar in both of our screen shots.

Did you install an app code, and a driver code?

I sorta indiscrimantly grabbed the drivers that sounded like what I needed but I did not grab them all. However now I'm not sure I'm in the right place on github.

Can you steer me to the right github link?

Did you use this repository?

This should be the Raw links.

You should consider something else that might be easier for you. Hubitat package manager. It can install the drivers and app code for you. Once you install Package Manager, run it, and you can select this garage door to install. It takes care of all the behind the scenes stuff. You then would just go to the Hubitat app page, install the MyQ app without all the raw code and so on.

1 Like

Thank you, that is exactly what I'm looking for...to start over from scratch.

However I was able to delete the Dashboard button, the App, the AppCode but received this error when trying to delete the driver...any ideas?

Hubitat error when deleting MyQ driver

It looks like you still have a device in the Devices tab, did you get rid of that too?

Ok got it working and dashboard buttons for open and close added!!:slight_smile:

Do you know how to configure a button for the status...ie closing, opening. It states that when you're in the device on the right under "Current States" but couldn't figure out how to see that one the dashboard, nor do they discuss it in the forum link you shared. I tried adding a button with Device set as "Garage Door Opener" and Template as "Door Status" but that didn't show any info on what was happening

Use Garage (control) as the device in Dashboard, and that part should show your current state.

Glad you finally got this far! It will only get easier from here. The first few things are tough. Wink spoiled us a bit, but it is worth the bit of aggravation to have things just work for a change.

Ok will give that a try and...I'm sure you're right regarding acclimating to Hubitat. And it's nice to have such a supportive forum community which didn't exist for Wink, at least that they hosted and monitored

1 Like

Did you see my earlier post?

1 Like

Sorry my heads been spinning with transitioning a zillion sensors to Hubitat with multiple little challenges in different areas so missed that comment, BUT THANK YOU.

For now I'm content with just using the Ring the app but at some point may investigate into the Alexa option you pointed out.

1 Like

Ah! Yes! That was it. Sorry, I could not find it anywhere when I looked again.

Sorry I was not more help.

Download the Hubitat app