Groups and Scenes making me crazy

I'm having to redo tons of my automations because I had to change a Wi-Fi SSID. This messed tons of things up. Not sure if this is related .

I set every color up and every dimmer and every switch the way I want it. Capture scene. All good. (Red)

Change the lights around to different colors. Go to the capture device (Red) and click on. 1/2 the room is red, half is purple. What is going on here.

They're all Hue products integrated via Hue Integration except for 2 Wiz bulbs. When in the apps menu it shows BLUE and RED being "on" at the same time. When I click RED to adjust the child app I now get an error however the device will still respond to commands.

Is there a better app I should be using? I just need to capture a scene and have it as a device for an ActionTiles dashboard.




As a baseline, I highly recommend the CoCoHue: Hue Bridge Integration as the best driver for those bulbs.

Secondly, I'd urge you to review your Hue (Philips) user account to make sure no other integrations are linked via the API. Simplicity is key here, and the goal is to eliminate as many variables as possible from the equation.

Lastly, if you have your Hue bulbs directly integrated with Alexa, I'd suggest undoing that, then including them under HE's own Amazon Alexa app, so the locus of control is thoroughly aboard Hubitat. (Don't forget to "Run Discovery" on Alexa to finalize.)

I know this isn't directly addressing your OP concerns, but a lot of the above steps became necessary for me during a long, drawn-out quest to make Hue Bulbs behave more reliably under Room Lighting app.

RECOMMENDED READING
Hue Bulbs status lag, its effect on RL, and suggested cures

5 Likes

If both the hue bridge and Hubitat are both on the same subnet, likely what happened is because of the change the Hue ip changed. I would reinitialize the hue bridge app on hubitat then set reservations on your router for both HE and HUE. Since the devices are still the same coming from the Hue bridge, nothing in HE should change and you should not have to redo any rules.

2 Likes

Appreciate your replies.

This all started as I needed a dedicated 2.4ghz network name for some wiz integration.

I simply added xxxxxx2.4ghz to the end of the ssid but that obviously booted everything off.

Before I did anything, I deleted all the equipment from Alexa, the Alexa integration, Google and it's integration and all of the action tiles devices.

I deleted my Wiz and my Hue account. Deleted both apps from my hub. Deleted all pertaining devices. Made new Wiz and Hue accounts and started fresh. I figured this would be the best way.

I feel like the hue integration didn't go the same way it went before. It didn't ask me to hold the button and it just picked it up as if it had seen it before. Also, rather than using the old Wiz driver and setting the IP addresses manually, I used the Wiz app. So something in here is messed up.

I'm going to delete the Wiz app and go back to just using the driver and manually entering the IP address. Strangely enough the Wiz lights haven't been as bad as the Hue.

If the lights are currently red and I'm trying to make a blue scene after setting all the colors for the bulbs, switches and dimmers to blue and capturing the scene, everything seems fine. I also make a capture device. When I go to click the device for "blue" half the lights will go blue and half will remain red. Then going back into the lighting app it shows a blue rectangle and red rectangle next to the device as if somehow the capture got messed up.

When I first ventured down the road of home automation, this scene app didn't seem that solid to me. I may just try another app for scene lighting as suggested.

Again, appreciate your time.

Sounds like you nuked a lot of things. Really you didn't need to. I would start first with making sure your hue bridge is fully functional on it's own. Once you do that use Cocohue for your integration. Bring alexa and what have you back. Also remember that everything has to be on the same subnet for hubitat to see it properly.

2 Likes

All that shouldn’t have been necessary if all you did was change the name of your WiFi SSID.

The hue bridge connects to your LAN with Ethernet, so it’s IP address wouldn’t change. Hubitat connects to the hue bridge over the LAN, and the connection between hue bridge and bulbs is zigbee.

Wiz bulbs do connect directly over WiFi, but for most routers I would think an SSID change doesn’t do anything to IP address assignments unless the devices changed from the 5GHz to 2.4GHz access points.

Perhaps it’s a different underlying issue that explains the behavior you’re seeing.

Which router are you using?

3 Likes

I'm using a FiOS router.

The Wiz bulbs need 2.4 to connect and set up. Setting them up via my pixel 7 I was not able to choose the 2.4ghz band on my router as it had the same name and password as the 5ghz band.

I changed the 2.4 band in the router to xxxxxx2.4ghz so I could connect my phone to it and complete the Wiz setup via the Wiz app. I also had an Emporia Vue that also would only connect to 2.4. I didn't see another way.

I swear my old pixel allowed me to select the band but this phone does not.

Right now so many things are broken in hubitat that Im honestly considering just starting over. I knew wifi devices would give me headaches in the long run but the low cost got me. Until this point everything was playing together nicely and I had wall tablets with camera feeds, garage and gate controls. Now those tablets are filled with question marks.

I think if I start over I'm going to run two HE. One just for lighting and the other for everything else. Unfortunately there's some devices that have to be wifi right now but I'll figure a way to get them local.

Edit; FiOS router to switch to Hubitat
FiOS router to Fios Extender via coax
FiOS extender to Poe switch to cameras etc

How do I find subnet settings?

Not clear to me from what you’ve shared so far whether starting over will save you time or is just another unnecessary step. And whether splitting devices between two hubs will avoid what’s causing your problems now.

That would be in your Fios router’s admin pages. Been a while since I logged into a Fios router but it should be something covered on Verizon’s support website.

On your pc simply go to the command prompt and type ipconfig and look on the ipv4 line. Your "subnet" in simple terms for your internal default network is going to be x.x.x.x/255.255.255.0 (the second half determines subnet but we won't go into that now) You're concerned with the first x's (aka octets) It will likely be 192.168.1.xxx or maybe 10.1.1.xxx or 10.0.0.xxx. Regardless all your devices should be on the same subnet. Now you should also reserve the ip's of all your wifi/lan iot devices. You will use the mac address mated with an ip address of your choosing. This is so every time they boot they get the same ip address and you don't have to fiddle around with things later.

1 Like

Download the Hubitat app