Google Minis - TTS options?

I've searched the forums and cannot find a recent or conclusive fix/position on the built-in Chromecast integration using GH Minis for TTS only.

I have a few GH Minis, Nest Mini and a Nest Hub on the way.
I don't use these anymore and am building a Sonos system for music, but I would love to get the minis working for TTS only (mic off - no assistant will be used on these devices, except maybe the odd broadcast, so some Google integration would be nice). The devices I have tried are adding as HE devices okay.

I have tried re-discovering, un-/re-linking with Google account, stopping, initialising etc and all the commonly mentioned suggestions, but the runQ error persists whenever I try to send text through the device or RM.

The best I can get is a tone when I manually change the volume in the device, and sometimes a tone when I initialise. So I'm definitely getting some communication with the minis from HE.

Is there anything else I can try to get these to work or shall I just refocus my efforts on getting Sonos everywhere for TTS, and get rid of the minis? If so, seems overkill to me. I know people are out there having luck with these.

Something is up lately, I've seen multiple other users report same issues. My mini still work with HM and did in fact tonight, but they've been hooked up for many months now. It seems people trying to connect/reconnect are having issues.
Sorry I don't have a reso

1 Like

Are you running the Chromecast Helper Hubitat app? It may help keep your GH devices connected.

I just installed this now. It appears to just automate the initialise function. When I initialise manually, I still cannot get TTS to work.
If it was intermittent, this may help. I'm keeping it installed anyway, as it may come in handy. Thanks :slight_smile:

That's a shame. Hopefully an easy fix

I just noticed, you have a nest mini. Mine are both the older GH mini, and I wonder if you just ran the mini alone, what would happen.
Can you get the mini to speak by typing into the device page some text?

I inconsistently get a chime play through the Nest, but both minis do no speaking through the speak button - this is how I've been testing it thus far.

Here are the uriQs:

@Rxich Also, for what it's worth, I just tried setting up my Nest Hub too, and get a chime followed by this looping/attempting to play until I hit 'stop':


I just tried using my Google Home, and it has stopped working also.
I am using it via the Chromecast Audio built in interface, and I get the following errors:

So, this will require some investigation to figure out why it stopped working...
(I also tried to run discovery again, etc...)

1 Like

Same here. My nest mini used to work flawlessly for TTS up until a few weeks ago. Now I keep seeing those time out errors in the log

The nest mini has a static IP assigned, and also using the Chromecast Helper, but still facing issues

@jtmpush18 Does this require investigation by the devs?

1 Like

I got rid of my Amazon Echo software (dlna players, media renderer, etc.), and Presto - it started working again. Hmmm....

1 Like

I've just ordered an Echo Dot. Although nice and cheap/free, the Google minis have often had issues for me. Perhaps Alexa is a more friendly ecosystem for my needs.

My issues started when I integrated Sonos into Hubitat. Can't these speakers co-reside peacefully within Hubitat? O_O

1 Like

Download the Hubitat app