Google home support


#61

It is actually. Look up Google Home Mini vs Echo Dot and you'll see the comparison. I did a lot of research before choosing one over the other and the GH mini wins everyone's test for sound quality hands down. I guess the new Echo Dot 3 sounds a lot closer to the GH Mini.


#62

Either way for $20-$25 you can't go wrong.


#63

This all seems extremely involved. I may wait to see what happens with the official integration.


#64

Okay. But the official integration in ST doesn't allow you to control the volume of your GH devices or use it for notifications. It only allows control of your ST devices from Google Assistant. You think the integration with Hubitat is going to be more involved? I wouldn't hold my breath on that. It's actually pretty easy to get up and running and there are detailed instructions. But it's up to you. Just wanted to throw it out there that you can do this right now, no need to wait.


#65

I'll hang onto it as an option, thank you. I know @mike.maxwell has mentioned on this forum there is a beta Chromecast driver that can handle Chromecast Audio groups that's not quite ready yet. So that'd be the most direct solution.


#66

The cast integration we're doing, once we get back to it, deals with the cast devices directly via lan, it has nothing to do with how Google wires it up to their other apps.
It will work with audio, video and audio groups, we're still tbd on what the release functions will include, the goal would be to have them present like other speakers, push video to them? Can't say right now.


#67

True, I have 3 minis and 2 Insignia, but now with the new GH app you can use the equalizer on the Insignia ( EQ was available only in Google devices in the old app) and you can get better sound from it.

The Insignia big brother is on sale too:

https://www.bestbuy.com/site/insignia-voice-smart-portable-bluetooth-speaker-and-alarm-clock-with-google-assistant-gray-black/5865906.p?skuId=5865906


#68

I wasn't aware they'd added that. Thanks for the tip!


#69

Calling and using two in stereo also works now with the Insignia.


#70

RATS! BB Canada doesn't sell these. Between Lowe's and BB, you guys are getting some sweet deals lately.


#71

I just tried. Sale is over. The speakers are full priced again at my store.


#72

Wow that sale did not last.


#73

Um, yes, please! I run the cast-web-api project to get this functionality in SmartThings today but it's horribly unstable right now. It's error log is vast and it's crash reports mighty. I can TTS to a single device or group, stream media, control volume, pause/forward/stop control, etc. It's fantastic when it works. I would LOVE all of this natively in HE for Google Home devices.


#74

The insignia speakers are on sale again


#75

Sweet thanks.
Just got one for 10 bucks after my $15 BB Rewards.
Was always interested in trying a Google Assistant device but couldn't justify the cost (I'm heavily invested in Alexa). But for $10 out of pocket? Had to pick one up.


#76

MM indeed they are. After consulting the CFO(wife) I have been informed I have exceeded my iot budget for this month :frowning:


#77

As a bargaining chip...there are open box ones (Excellent condition) for $18.


#78

I would double check the site...I grabbed an open box/excellent for only $14.99. At that price, I HAD to buy it.


#79

Not sure if this was announced or mentioned elsewhere, but I noticed Google Home integration is now available! I was able to link my Hubitat account in Google Home and things seem to be working as expected.


Sell me on Google Home
#80

Yup! Awesome! So happy :smiley: I've just added over 50 devices to Google Home via the "Hubitat-intent" service and it's all working! It's auto-added the "Google Home" app in the hub and I can control which devices are available via that.

Although:
I am seeing an error in the HE logs from the Google Home app each time I turn a light on or off:

app:552    2018-11-01 08:47:01.339:error reportStateResponse Error: {
  "error": {
    "code": 400,
    "message": "Request contains an invalid argument.",
    "status": "INVALID_ARGUMENT"
  }
}

EDIT: It's not all the lights, just some of them. I think it may be an issue with the drivers I'm using for the Qubino Flush 1 Relay and Qubino Flush 1 Dimmer. It's not happening with other switches.

@bravenel @mike.maxwell Is there a way to get more log info describing the request that's being sent so I can try and fix my drivers? Or is this an error you guys have seen before and could advise on? Thanks