Google home support


#182

If you edit one of the Google Assistant routines, there's an "adjust scenes" option that lists any Hubitat modes you've enabled through the Google Home Hubitat app. This is what I'm using to switch my system to Night mode.


#183

Also, the change to night mode is successful, but the Google home reports that there was an error. I imagine that Hubitat is simply not handling the transaction correctly.


#184

Hence why I said use the virtual switch.


#185

Work arounds are all well and good, but the bug should still be fixed. I'd rather use the native mode change and avoid the extra virtual device if possible.


#186

Well, yeah...but you're assuming that HE isn't responding to what assistant is sending. I wouldn't assume that. Now, HE will most likely have to fix it to get it to work but I wouldn't assume that's where the root cause is.

But you also wanted to know how to get it to work without an error. You can Don Quixote it and keep yelling at those windmills if you want. Me, I just like stuff to work.


#187

Oddly I'm getting that error for just about any call to Google right now with hubitat. I get a long pause and then "Hubitat's not responding" followed by it actually changing the switch. So I wonder if the error you are getting is not specific to modes.


#188

Perhaps, although I don't get errors for any other interaction.


#189

This is google, they were down for a bit, everyone had issues.


#190

Ok, so this is everyone....good to know. I also see errors from them in my HE log.

Stuff like this:

[app:400](http://192.168.13.46/logs/past#app400)2018-11-12 07:52:07.806 error reportStateResponse Error: { "error": { "code": 404, "message": "Requested entity was not found.", "status": "NOT_FOUND" } } , giving up for now.

[app:400](http://192.168.13.46/logs/past#app400)2018-11-12 07:19:13.779 error syncResponse Error: { "error": { "code": 400, "message": "Precondition check failed.", "status": "FAILED_PRECONDITION" } } , giving up for now

Otherwise it's still working fine. I just refreshed my list of devices and made sure they were all "valid" so it should be a good list.


#191

Have you turned off the polling in the app in HE? That might be what's causing your errors. It was causing a bunch for me.


#192

Hi @mike.maxwell, have you had a chance to look at the info I posted regarding the Google Home error I'm seeing? Any advice on what I could look at to try and fix?

Thanks


#193

try commenting the temperature measurement capability out in the driver, then open GH and then done...


#194

You sir, are a dude. That sorted it. Thank you.


#195

It apparently seems to think it's a thermostat, which it isn't obviously...
Next time I'm working in that app I'll see if we can be a little smarter about this distinction.


#196

Google Home isn't able to change the temperature of my thermostat. It can read the current ambient temperature reading, report on the current heating and cooling setpoints, and I can change modes from cooling to heating and vice versa. The only missing thing is being able to actually change the temperature - which I am sorely missing now that it is cold out and I need to get out of bed to change the thermostat. I don't see any activity in the logs to suggest Google is communicating to the thermostat when I try to change the temperature. I am using the Generic Zwave Thermostat driver with a GoControl GC-TBZ48L thermostat. I also tried the generic zwave driver with a Trane TZEMT400BB3NX thermostat with the same results. When I open up the thermostat device page in Hubitat, I can change all the settings including temperature from there so the driver is able to control the thermostat and change the temperature from the device page.


#197

There’s a standard experiment you can try if you’d like.

Create a Virtual Switch and set it to auto off in 500ms. In other words, a momentary push button.

Create a Rule that when the button is pressed, the action is: set a specific temp, or temp up one degree.

Verify it works, then add it to Google Home and verify that it can “push the button “


#198

Virtual switch that sets a specific temperature via a rule is a work around so yes that works and I have used that. However I would like to just wake up in the middle of the night and ask Google what the current thermostat temperature is and then just say an arbitrary value to set the thermostat temp to. I got used to that with with my old VeraEdge which had Alexa support that worked with thermostats. I am getting spoiled with all this home automation stuff haha. Also I would love to be able to use the Google Home app on my phone and move the circular slider they have to set the temp that way also. I just noticed Sharptools.io has no problems setting the temp on my thermostat so I can use that as my phone app for now.


#199

I have a CT50 WiFi/USNAP z-wave module thermostat that couldn't get Google Home to control since I had set it up and now even after the latest firmware upgrade it still wouldn't work (heat only control).

Well, I was manually setting the thermostatsetpoint and trying a few things (removed Google Home/Hubitat connection...). I then changed the device setting from "Generic Z-Wave Thermostat" to "Virtual Thermostat" and nothing happened that I could see. However, to my surprise when I changed the CT50 device back to "Generic Z-Wave Thermostat" it finally controls the thermostat heat when I tell my Google Home to "set thermostat to 70" or "set heat to 70".

I'm using "Thermostat for Windows" program and finally can see that within ~17 seconds that the thermostat is controlled by the Hubitat using my Google Home (same as my now removed SmartThings hub). Please note that once Google Home acknowledges my voice command it sets the thermostat right away to the new temp.

Log when setting heat to 72° (currently/after Google Home is working):

  • dev:652018-11-24 05:18:06.371 pm infoThermostat (CT30 RTZW-01) thermostatSetpoint is 73°F
  • dev:652018-11-24 05:18:03.318 pm infoThermostat (CT30 RTZW-01) thermostatOperatingState is heating
  • dev:652018-11-24 05:18:01.318 pm infoThermostat (CT30 RTZW-01) thermostatMode is heat
  • --- Live Log Started, waiting for events ---

Note: My echo's are pretty much useless for my thermostat, lights, switches and only are working to control my Convert Z-Wave Plus Door Lock (but I have more alexa setup to look into it further). Google Home won't control my door lock or I may not know the right voice command to use...still looking into this though.


#200

Anyone having issues with issuing thermostat commands with the Google Home integration? I'm fairness Homebridge is having the same issue but Sharptools.io works and the device page works. Unfortunately I can't use the native dashboard for thermostat control...


#201