Google home support


#202

Ok thanks!
Anyone reach out to support? I don't want to pile on it, but if they don't know...


#203

I'm getting "Account linking failed" error when trying to add hubitat to GH via the local app. Tried resetting my portal password but that doesn't seem to have any effect. I'm running 2.0.1.114.

Nothing appears in the logs.

Did I miss a step somewhere?


#204

How do we get GH to recognize Z-Wave Fans as Fans and not Dimmers?


#205

If you use a switch to turn on the fan, delete the device from google HE app, in GH say "synchronize devices", change the name of the device to have "fan" in the name, like "living room fan", add it to google HE app, synchronize devices in GH, it will be added as a switch, now, if you have the Hampton Bay module or other fan module, not sure, maybe adding the fan in the name works.


#206

@vjv if I use that method will it only have on/off in HE or will it allow for changing speed?

GH supports a bunch of device types Smart Home Device Types  |  Actions on Google  |  Google Developers so it would be nice to see more Hubitat device types supported in GH.


#207

It should let you change the velocity but saying the percent needed, like hey google, change the living room fan to 50 percent, I believe HE see the fan switch as a dimmer, from 1 to 100 percent, so the command will be the same as a bulb but you will get an switch icon instead a bulb icon in GH.


#208

That is exactly how our setup is. The switch is seen as a fan controller but takes commands like a dimmer would. On/Off/%. "Hey Google, turn East Wing fan on to 10%" works like you would expect.


#209

Virtual buttons are not supported? Haven't tried other virtuals yet.


#210

I'm getting these when trying to "sync devices" and Google says hubitat isn't available (but I see logs)

app:4002018-12-09 08:38:57.636 am errorsyncResponse Error: { "error": { "code": 400, "message": "Precondition check failed.", "status": "FAILED_PRECONDITION" } } , giving up for now

and

app:4002018-12-09 08:55:47.645 am errorsyncResponse Error: { "error": { "code": 429, "message": "Resource has been exhausted (e.g. check quota).", "status": "RESOURCE_EXHAUSTED" } } , giving up for now

Thouhgts?

I went through and eliminated everything but lights associated with rooms. No thermostats, groups, etc.


#211

Well this sure worked for me, so THANK YOU! Two new virtual switches with 500ms set called "Heat Up" and "Heat Down". Each attached to a respective trigger for +1 degree and -1 degree. "Hey Google, turn on Heat Up" Works quite nicely!


#212

Centralite Pearl, Generic Zigbee Thermostat Driver for me as well. I created a couple of virtual switches to UP and DOWN the heating setpoint through GH as a workaround. But...If you ask google to just "Raise the Temp" she says OK...but nothing changes on HE or the TStat. No biggie...just thought you might want to add it your 'List O' Stuff'.


#213

Not sure I understand what's going on here. I just linked my Hue account. I only have 8 Hue bulbs, but it's showing 56 for some reason?


#214

Hue creates default scenes for each light. Like "Concentrate" . These all get added in addition to the lights at least they do in Alexa, I've not setup a Google account yet.


#215

I see, thanks. I guess LIFX does something similar, as I only have 9 bulbs and it shows 12.


#216

You can delete the default "scenes" (except for colorloop) that are created by each room in the hue app (assuming you never use them). You can also prevent them from being created in the first place by unselecting "create default scenes" during the "room" creation.


#217

To follow up on my own question.. had to contact support to re-register my device. Once I did that I was able to link.


#218

Hi All,

My Google Home integration is working fine, but I just noticed this error in the logs every 5 min:

errorjava.lang.NullPointerException: Cannot get property 'lastActivityTime' on null object (pokeDevices)

Does anyone have this or know what's causing it?


#219

Probably you deleted a device that was linked to google home, opening GH app on HE and clicking save will refresh devices.


#220

Under Options within the HE Google Home app, do you have polling set to 5 minutes? It should be disabled.


#221

Hi Guys, just to follow up, tried refreshing the devices as suggested by @vjv but the error kept showing, I indeed had the polling set to 5 min though, not sure why as I remember not using that, must have done it by mistake...

Disabled it and the error has not happened in the last hour, Thank you!