Google Home linked, doesn’t see device

Hi.. new at this. Have a new hub with an Aeotec ZW100-a. Have it connected, appears in the dashboard. I run the google app and it appears and I select it. Then I go to google home and add a device. I click on the hub and it says google home is linked and returns to the google home screen. I cannot see the sensor there and there is no option to select it. When I return to the google home app in the hub, the sensor is deselected. What am I doing wrong? Ali contacted aeotec to ask if it had to be google home compatible and they told me it’s not their issue, google home decides what data to transmit.


I not Ali. Typo

Google doesn't support sensors with the current integration available to Hubitat. Once they're done with whatever they are doing over there at Google, then the Hubitat team with have something to work with.

Thermostats, bulbs, dimmers and switches are compatible at present. When an unsupported device is selected under the current integration with Google Home, it doesn't show up in Google Assistant/Google Home, but the supported devices will.

1 Like

Thanks. So I guess I just check whenever there’s a google home update. I can stop banging my head against the wall :slight_smile:

There are some community solutions if you're trying to get control over Google Home compatible devices (e.g. Devices not directly supported by Hubitat), albeit a little involved to get the initial setup in place. But once the online configuration is done, it's a snap to use from Hubitat Elevation.

What was it you were trying to do by getting the Multsensor in Google Home?

I want to monitor the temperature in my workshop. My thought was to ask GH what the temp is and then tell it to turn on the switch that controls the heater. The second part works fine for now on wifi. I was hoping at some point to automate it via the hub, using zwave. For now, I made a rule that tells me when the temp gets below a certain point. However today I look at the rule machine and I can’t see it. I understand there are 3p integrations but honestly I am concerned about going down the hole of learning to program and debug that kind of thing. The objective was more time in the workshop, I was really hoping this was P&P and I wouldn’t have to tinker.

PS the rule worked overnight

Reinstalled the rule. It may have been the tinkering

Well, the Google Home control from Hubitat is a totally different thing. It uses an official google assistant function called Google Assistant Relay. I've been using version 1.0 of it for years. No maintenance required. Worth checking out if you're interested.

For what you want to accomplish, it can actually be done with a new app called Thermostat Controller. I just tried it with my bathroom temp/humidity sensor (made by Xiaomi ) and it works.

The steps are pretty straight forward.

  1. Create a Virtual Thermostat on HE
  2. Name it in the device label for what you want to monitor (for example Bath).
  3. Add the Hubitat Virtual Thermostat to a new Thermostat Controller child app.
  4. Select your Aeotec Multisensor as the remote temperature sensor.
  5. It will create a device named with your Virtual Thermostat's name, and the word "Controller" appended to it.
  6. Add that device to Google Home
  7. Go into the Google Assistant app under Manage Accounts, tap on Hubitat, and then "Check for new devices".
  8. The device will show up in Google Home under "In your home"
  9. Tap the virtual thermostat device and Google will pop up a screen asking if you have any of the listed Nest devices. Even if you do, just click no. It will say "Creating Network" and then you will be able to access the Virtual Thermostat and move it to a room.

When you ask the temperature in that room, it will tell you what the reading is on your Aeotec Multi-Sensor. If you setup a very simple Rule Machine rule that uses the condition of the virtual controller device's custom attribute thermostatOperatingState , then you can have it turn your heater ON when the Virtual Thermostat Controller value = "heating" and turn if OFF when the value = "idle".

1 Like

Thanks so much. I’ll try it

Oops, wrong attribute listed. Should be thermostatOperatingState. Corrected post above.

no joy. it didn't add the word controller. when i go into the GH app on the hub it's there. When i go to GH and try all i get is Hubitat account is linked and then the GH screen with no additional device. The device never appears in check for new devices on GH under hubitat. when I go back to the GH account on the hub it's all unchecked.

1 Like

Did you install the Thermostat Controller app on HE?

I tried. the device doesn't appear in the pulldown

in your step 4 that is

You first pick the virtual thermostat

Then you pick your Aeotec Multisensor as you remote temperature sensor

nothing there

Show me the device details of the virtual thermostat you created.
It should look like this...

So once you switch your virtual device to use the Virtual Thermostat driver, you will be able to add it.

When you have that part working, here's an example of how to make the RM rule. This will allow you to control your heater from a Google Home Hub, the Google Home app or Google Assistant as if you had a smart thermostat attached to it, or to ask for temperature to be set by voice.

I installed the latest version of Thermostat Controller and I was able to get it all set up linking a temperature sensor with a physical thermostat. The previous version of Thermostat Controller showed up as a Thermostat in Google Home, but for some reason, this version no longer does.

Any ideas?