Gledopto drivers not working?

Hi community
I followed these steps Hubitat/drivers/gledopto at main · mconnew/Hubitat · GitHub as well as these steps Zemismart Zigbee 1/2/3/4 gang light switches - #63 by ADDs
but I did not manage to make things happend.

Both drivers were installed. The first one with parent and children but I cannot switch on/off. When I do so the colour turns from whatever I have it to green.
I saw that there is a physical button on the controler (says reset) and when I click on it it turns as well from whatever colour I have chosen to green. Maybe it is because of that ?

Other than that I could not control the light and change its temperature and as for the colour I could change almost everything but the reds...

Is this normal ? Would it function like that with the drivers ?
Thanks so much for your help
All the best
Yiannis

Not sure if this helps but I have been using the Generic ZigBee RGBW Light driver built-in for years with no issues.

1 Like

Thanks so much for your answer.
Do you mean the first or the second driver of my msg ?
(GitHub or zelismart ?)

This is the driver I use from HE without issues.
image

1 Like

Hi @dnickel
thanks so much for your reply :pray:
I changed the driver to generic zigbee rgbw light but nothing happens. Now I can't even change the colours. Here is the screenshot of the product


maybe the driver is not the right one for this model ? Do you have the same one ?
thanks again

1 Like

Yiannis,

In my opinion, the most recent drivers for your GLEDOPTO GL-C-008P device are here:

This set of drivers does not mention the GL-C-008P model explicitly, but it is worth trying.
Follow strictly the instructions how to assign the main driver, then press F5 in the browser and you should see a child device created at the bottom of the main device page.

These GLEDOPTO controllers have 'specifics' that make them not 100% compatible with all Zigbee hubs. My feeling is that Gledopto has been patching their firmware, until it worked satisfactorily with Philips Hue hub, and they have stopped there. ... Everyone's target is to get a share of the Philips H*e market,,, :slight_smile: (A lot of OEM put the asterisk in the Hue name because of some legal concerns, most probably,,,)

1 Like

@kkossev thanks so much for your reply!!
I tried this yesterday with the two child devices but it did not work :frowning:
So I guess it doesn't work.
If so is there any zigbee rbgw led controller out there that is perfectly compatible with the HE c8 ? I don't care to send this back. As I am new to all that, I am trying to find compatible devices and go on.

Thanks again so much for all your help :pray: :pray:

Let’s give it a last try with this driver.
What exactly was not working? Give some more details here.

This is the official list of Hubitat compatible devices:

@kkossev I just tried again.
So I followed the instructions, assigned the main driver (clicked save device then configure then on then off then f5) and I could see the 2 children devices.

No on and off works on the main device

no color changes work on the other two devices

So it doesn't work at all in my case :frowning:

Did you hit Configure after the driver change?

yes of course :slight_smile:

I have almost the same device but the "P" is missing.

  • endpointId: 0B
  • application: 01
  • manufacturer: GLEDOPTO
  • model: GL-C-008
  • softwareBuild: 2.0.2

@dnickel
So I guess it has to be another behavior by my model ?

(post deleted by author)