Generic zigbee temp humidity incorrect humid reporting

Using the generic driver it seems to be truncating.

Yes, this is a Tuya device, they are hit or miss whether will work with the generic drivers or not.

Tried your driver didnt get any humidity reports.

I think that another user had success with this device, it was added recently... Make sure you have the latest dev. branch version. Try pairing it again while this driver is manually assigned. If still doesn't work, will look at it tomorrow.

Thanks get you to latest version

It is in the second post on the Tuya thread - this one

Ya thats the version i have installed

I am getting humidity now but too low still. Could the sensor just be faulty?

The other 2 sensors for comparison are showing 60 and 65% but temp seems spot on

Thevhex conversion or 237 is 567

Im is 56.7 not 5.67 and is only reporting 1 decimal not 2

How can we test thus hypothesis

Right in your code it says humidity with .1 precision but then you divide by 100 that is the bug if .1 precision you need to divide by 10?


For this manufacturer ID _TZ3000_itnrsufe the raw humidity reading should be divided by 10.
The humidity events sent by a driver should always be integer numbers, no decimal parts.

In the generic zigbee T/H driver log screenshot above the humidity is reported by the device as 0x0237 which is 567 decimal, divided by 10 and truncated to the nearest integer should be sent in the humidity event as 56 % RH. Most probably this is not done in the inbuilt driver, as this is a new device.

Can you switch back to the custom "Tuya Temperature Humidity Illuminance LCD Display with a Clock" driver and post some debug logs ? Click on Initialize button at the same time when the sensor is awake (change rapidly the humidity for example).

Press F5 in the browser, if this sensor is recognized successfully you should see in the the "State variables" section modelGroup : TS0201_TH

Yes, it is a bit messy code, I will clean it up in the next update. The humidity value in the events should be simply rounded to the nearest integer.

No, the sensor is just OK. Your logs screenshot is from the inbuilt generic zigbee driver.

Seems to be working now. I fully deleted the device and re-paired it. Thanks for this driver. Now getting one of their inexpensive remotes to replace my minimotes. I also wish they would make a larger temp sensor like the older st814 with 2 aa batteries so that the batteries would last at leasy 6 months when in a fridge.

1 Like

What is your "Minimum time between humidity reports" setting?
This is intended to prevent chatty sensors from overloading the hub with too frequent humidity (or temperature) events. If the new humidity report was received from the device faster than this protection timer value, the event is delayed until the timer expires. If multiple events wee received during this period, only the last one is sent. By default, the minimum time between reports should be 10 seconds.

Not sure it really does much as to helping as the hub still has to receive and process the report.

What the device really needs is this setting direct in the device so no messages whatsoever are sent out. This is usually set via config parameters.

Yes, I know but most of the Tuya devices do not honour the reporting configuration commands. This varies from device to device.

1 Like

If they dont honor it than how is maximum going to work?

Will not. Here my idea was to start a timer/schedule which will forcibly send the last received humidity or temperature value as an event with isStateChange set to true (and eventType set to 'digital'). This is useful only for graphs, where there will be no missing points if the measured value did not change.

Hmm.ok.. i wish it honored or had firmware level.settings that is one way to save battery especially when in a cold environment.

Does it at least honor the temp and humid change parameters.

I don’t know at the moment, will have to search for information in GitHub if someone has already tested this particular device.