GE Switch - Paired but does not log physical switch events but will digitally turn on and off

I have repaired the GE Switch and it works in devices to turn and off. But when I physically turn it on and off the switch habitat doesn't see a log of the event. I'm trying to create a rule but can't do it when Hubitat doesn't register the event. Is there anything I can do besides replacing the switch? Let me know if I can run a report? Thanks.

If it's a pretty old ge switch (300 series?) then it won't report back to the hub. I have a few of these left relegated to places where I never touch the switch.

You could also use the polling app built into HE but that will consume resources, though probably not a problem with polling only one switch.

I've been replacing the switches when I get around it

1 Like

If you have not tried already I would re-pair the device. I've seen other devices have weird reporting problems until they were re-paired, getting whatever kind of hug they needed.

I did that today. I re pair the device this afternoon and it unpaired and re pair with no issues but still no action on the log when physically hitting the button. I have an enbrighten switch that I'm going to replace tomorrow and give up unless someone has an idea. Thanks.

It is an old switch and I'm going to replace it tomorrow.

1 Like

What driver are you using?
Try a different one and press configure.?

Then it's most likely one of the GE switches that won't report. When they were made there was a patent issue, or something like that, and GE couldn't make them report back. The new switch will communicate a lot faster than these old switches too.


If you're installing one of the newer Z-Wave Plus Enbrighten switches or dimmers, I recommend these community drivers.


1 Like

The Enbrighten switch I have is

Enbrighten Z-Wave In-Wall Smart Light Switch with QuickFit and SimpleWire, Works with Google Assistant, Alexa, & SmartThings, Z-Wave Hub Required, Smart Home, 700 Series, 58433

I'm assuming that I still need that driver or do you know?

Did you try the driver : Generic z-wave switch < driver ?
You can try to change driver .. goto : devices / ge-switch / pick the driver. / click configure.
Then test it ? < make sure logs are on so you can see whats up >

Yes, the driver I recommended will work with that switch. But you don't need to use the drivers I posted. You can use the built-in drivers and they will work just fine.