Freezing hub - C7

My C-7 hub is freezing randomly (after a few minutes or a few hours). I don't see anything in the logs that would lead me to the root cause of It. The diagnostic tool is not accessible but the led is still green. Frozen means no automation is working and the interface is not accessible. I have removed as many used application as possible. Here is what I have in the logs :

Any idea how to find what is the issue ?

Do you have any device on your network that uses jumbo frames?


Just to rule out a corrupt database, restore yesterday's backup.

I would turn off all that debugging and trace logging unless you actually need it for something.

Is the hub set for DHCP or Static?

Is the hub network speed set for Auto or Fixed 100?

As @aaiyar asked. Do you have anything running jumbo frames?

Thanks for your support @ aaiyar @ rlithgow1 : hub is using a static IP address. Fixed 100. Not sure about jumbo frame : most of the devices are zwave or zigbee (except Ecobee thermostat, Tasmota 11 temp and switch, Sonos, Alexa and Google home devices, a smart oven connected through the cloud, a sum pump monitor).

I have a daily back-up. What is really strange is that I have a daily back-up even If the hub is supposed to be frozen :

This is a classic sign of the network interface going down, but the hub is still operational. Does the hub's LED remain green when it is frozen?

Jumbo frames would be used by some device on your LAN. Jumbo frames on the LAN have been known to freeze the hub very similarly to what you've seen.

My steps for looking at this are always:

  1. Make sure hub is not overheating. Don't set it on top of other hot devices, for instance.

  2. Make sure jumbo frames are disabled on your network. Multiple people have seen their hubs lock up when connected to switches or networks that have jumbo frames enabled.

  3. Check the logs and make sure no app or driver is generating a lot of messages, or a lot of errors.

  4. Check the hub statistics and make sure no app or driver is using an excessive amount of CPU / loading.

1 Like

I'm in the same boat and trying to figure out why; green LED, hub locked, clean logs, no automations, no access, not even pingable. I've addressed/confirmed all the items listed here except the Auto vs. Fixed 100. Has this been known to cause a similar issue and is fixed 100 recommended?

That depends. There were some Netgear devices that caused trouble with the hub in the past and setting 100 fixed was a work around. I have had good luck with using switches from TP-Link and Linksys to connect my hubs with them set to auto negotiate. I believe auto negotiate is the only way to get full duplex, but I think it needs to be set to auto on the switch as well (but I only know enough about these intricacies to be dangerous).

I will check tonight for the jumbo frame. My router is an ISP router (Bell home hub 4000). I only have an unmanaged switch.

Change to DHCP and set a reservation in the router instead.

Change speed to auto, not fixed. Some switches don't like it and it can cause communication problems.

1 Like

When I try to restore I get :

I am going backward, I am trying to find the latest not corrupted backup.

1 Like

I was able to restore from backup stored on the hub. Surprisingly all my external back-up were showing as corrupted (I have tried to restore backward the daily back up until 10th of October 2022).

I have changed the network settings DHCP and speed to auto. I had no time to check for jumbo frame but I will try tomorrow morning.

1 Like

You might consider getting Hub Protect. Aside from the local and onboard backups you would get cloud backups and backup of your z-wave radio.

Do you what is the difference between :

and this :

When I look at the size of the file there is a big difference. I was able to retrieve the back up from the hub but all my daily back-up from my NAS were showing as corrupted.

For the first time in two weeks It is working overnight. I'm crossing my fingers.

1 Like

That certainly is strange. Are you doing a curl to get the backup to your nas? What about if you do a manual backup (click download)?

To back-up, I am doing It on my Synology NAS following this method : Automatic Hubitat Backup to Synology Nas without PC - #4 by dcaton1220

That should've worked. If it keeps generating those tiny files, try it without the --backups=7

Unfortunately, the issue came back. Not sure how to test the MTU, I did those tests :

Capture d’écran, le 2023-01-04 à 18.25.20

Can we conclude that It is not an MTU issue ? @aaiyar

Is there any device on your LAN for which you enabled jumbo frames? If there isn't, then the issue lies elsewhere.


  1. A new ethernet cable.
  2. A different port on your network switch (or a different switch entirely).

There is no device for which I enabled jumbo frames. I have no new hardware connected : same modem-router, same raspberry pi, same unmanaged switch. The only new thing I have is a Zigbee Sinope thermostat.

I don't see anything obvious in the logs, no app or driver is using an excessive amount of CPU JasonJoel.

The hub is not overheating. In the basement at the same place for 2 years.

Not sure where to look, wecoyote5 have you been able to find something on your side ?