Fortrezz MIMO2+ Driver

Is the inside/outside the intended label? If the purpose is to select NC/NO maybe keep the purpose/label the same so it's known it's to toggle NC/NO?

Trying to follow the terminology in the tech docs...

Cool... following what's in the docs is always best... then you can tell us all to RTFM! :slight_smile:

Glad to see you all doing the coding. I have zero programming skills. And kind of got the early code running. Looking forward to the new driver. Willing blind monkey tester. :banana::banana::banana:

Hi Mike.

I agree. The sig voltage and meter pulse counter could probably be utilized in some oddball applications (like for curtains and roller blind control), but for the most part I think those features are probably more for the pocket protector and stainless ruler crowd.

Here is a typical use case: I have a long-range Dakota Alert driveway monitor. When someone starts up the driveway and breaks a laser beam, a signal is sent to the Dakota Alert base station. The base station then sends a bit of voltage to Sig 1 Input, which in turns triggers Sig 1 NO to close for 3 seconds. When Sig 1 NO closes, I fire off various triggers to turn on the driveway lights, back yard lights, ring a chime, etc. Sig 2 input and NO could be used to monitor a second driveway or a gate switch.

I think the setup you are describing would be flexible enough to accomodate most situations.



Does anybody know if the Fortrezz MIMO2+ Hubitat driver supports readout of the pulse counter? I was thinking to monitor a water meter that has pulsed output and this is the closest thing I have found to an approach to integrate it. Thanks if any ideas.

1 Like

not working for me.. Missing Activation and multi second delay turning off or on 3 feet from the hub.. Guess ill send back to amazon and go back to the non + version i already have.. any suggestions.

did a repair on it and its trying to use 2 repeaters when it literally is 2 feet from the hub.. something wrong with this device.

weird excluded and repaired and working fine.. it was s0 before that could have had something to do with it.. now it is s2..

I was pondering this as a possible improvement over the Zooz Multirelay.

However, all this "trigger between" and "trigger outside" stuff related to the lower-low, lower-high, upper-low, upper-high is great for some complex things.

And, while it supposedly can (apparently) handle 16V on the signal, it can only effectively "read" up to about 6v.

It's also so complex I don't see how to make it work for a simple case!

I simply want the signal to trigger as "On" when I apply about 9V and off when there's no voltage.

But, the way it appears to work the "voltage ranges", the sensor shows the same state for "low" (below the threshold) as "high" (above the threshhold) voltages. Thus, 0 and 9 would both result in the same signal state (either on or off).

Unless I can, somehow, get those thresholds set to like "1" and "16V" (so that 0V is "outside" the range--while 9V is "inside" the range), I don't think the signal state will work as I need it to.


I'm partially looking at this because I'm suspicious of Zooz devices wonking out my mesh. With no specific reason to think that.

these are the option.s there are no options for voltage that i can see.

just nc and no for the sensors

It seems the inputs and outputs can be entirely unrelated. I would like to have four nameable child devices. Rule maker allows for selection and use of each but the signal and the command are forced to share a name. Would it be feasible to have four independent child devices?

1 Like

The current Device handler for the MIMO2+ does have the inputs and outputs unrelated if you set the main device relay operation to manual. But it still only creates two devices.

The problem is the handler works the relays just fine but when the state changes in either of the sensor/inputs it does not register in Hubitat. I have asked Hubitat to look into it and it has been a black hole. I encourage you to try it and see if it works for you. Then you can let me know what I am doing wrong LOL. Within each child device there is a contact and a switch field. I can get the switch (relay) to work but when I cause the sensor (input) to register on the MIMO2+, the contact does not open/close in Hubitat.

Here is one of my prior posts. I think I have another as well:

The good news, and I highly recommend it, is the Zooz Zen16 multi relay with contacts just came out. It works exactly like the FortrezZ MIMO2+ but even has more features such as in the event of a power outage being able to have the relays go back to the last state they were in. Good for a water valve application in a house up in snow country when the power goes out!

Take a look. It is brand new and is being supported, unlike the FortrezZ which I think the company was sold and it is a fairly old part in the Zwave world. Close to the same form factor as well, which is nice if you have limited room and need to swap it out in a prior application. I have bench tested it last week and it works great with the built in device handler. Also has a cool feature of the relays being timed as well. (timed on OR timed off) very cool. But Hubitat forgot to make them configurable with the initial Device Handler. Though they were going to get that working too

I have three working cases of inputs to MIMO2+ doing control of other Z wave switches (not the MIMO relays). The inputs are connected to discreet contacts (not analog inputs). They are used by rules and appear in logs and dashboards. I have one MIMO Lite that uses input to direct relay. These all worked with default configuration so I can offer no advice, Have you tested the inputs by direct shorting with a jumper?
Thanks for the tip about the Zen17 ... checking that out next.

@lebartholomew3 Not sure how I missed the fact you had a working MIMO2+ and just wanted to know if 4 child devices could be created instead of 2 that share the input & relay.
Very frustrating that I am also using contacts to send an input signal to the MIMO2+ but that Hubitat is not seeing it. What Device Handler are you using? I am using the built in one. Anything you can enlighten me on as to the possibility of why Hubitat does not see the changes to the inputs of my device? I have tried just a simple contact sensor (shorting the two leads of the input) I have tried applying 12v to the input as well. Neither work.

Parent is using Fortrezz MIMO2+ while children use Generic Component Contact/Switch
Hub firmware is current.
Perhaps try input to relay mapping to verify MIMO recognizes input changes?

Good suggestion. I will try that out. I am not at the house with the device so it will take me a few weeks. A second thought as well. I have the C7 so I cannot include this S0 security device without security. Wondering if you have included it with security as well? I know some devices dont act correctly when included with security.

Your question compelled me to confront my negligence on the topic of security. Indeed both MIMOs using inputs are on a C5 and without security enabled. I had very recently upgraded the C4 to a C7 that hosts a third MIMO for which I was only using the relays. That MIMO indicates " zwaveSecurePairingComplete: true " which i am interpreting as confirmation of "included with security". I hooked up a SPST switch to Sig1 for a test. The test passed in that the child device page contact field changed state from open to closed each time I toggled the switch. This test probably rules out the security issue.

I appreciate your curiosity in testing the MIMO2+ with security on your C7 :slight_smile:

It is beyond frustrating for me that my device is not behaving how it should. When I get up to that house I will:

  1. Reset the device to factory settings and re-pair to the system in case a parameter or two got out of whack (could have sworn I already did that but will do it again)

  2. I will then use your advice and see if I can control the relays via the sig inputs just to see if they are talking to the hub.

  3. Keep my fingers crossed and see if the sig inputs can then be used independently as contacts

  4. Throw the thing away and use the Zooz Zen 17 when all else fails