Firmware Updates for Aeon Multisensor 6 via Z-wave Stick joined to Hubitat

Hey all,

My new hub is on the way, and I’m excited to join this community after suffering through a lot of the problems ST had when @bravenel first developed RM. :slight_smile:

I have a quick question that relates to something I saw here on the forums. It looks like someone had a Z-wave stick that they joined to the Hubitat hub. It led me to think about the pain that I’ve always had updating firmware on the Aeon Multisensor 6’s (I use them exclusively). I’ve usually had to remove them from the ST network, join them to a Z-wave stick plugged into my windows laptop and run the update, then add them back to the ST network, with all of the associated steps/challenges.

Has anyone tried doing a Multisensor 6 firmware update from a Z-stick attached to the Hubitat Z-wave network? It certainly would make keeping firmware updates easier.


I’m the one that tried that path, joining the Hubitat USB stick to my existing Zwave network. Unfortunately I’m an all Apple house and Aeon develops OTA only for PC. Meaning I can’t try it. I have, in the past, built a Virtual PC expressly to try it but the Virtual PC was never able to see the USB stick. (The stick is plugged into OSX and is “virtually available” to the PC… or not.)

In the past couple of days I did get Zensys Tools to work on the Virtual PC (Win7) and see the Aeon Z-Stick… and this thread has got me wondering…

It will take me a while to gather the pieces… but I’ll try it out, and report back.


I got the code from Aeon's site and unzipped it into my Virtual PC then ran it. It found the Aeon ZStick. It also loaded up the full list of devices. Another way of saying, OK, that worked.

The instructions say to include the target device, because it presumes it's on a completely unique and different Home Network #. In my case, it isn't.. but I did the include anyway and, no surprise it found the existing.

So everything is good to this point. Next instruction is to use the Firmware page to transfer the code. And that fails.

I'll send a message to Chris at Aeon Labs and see if he has advice about running it this way.

UPDATE: Aeon Labs Support Ticket created.



It would be awesome if this became supported, as it would mean the ability to keep the sensors up-to-date more easily as new firmware came out.

Appreciate you giving this a try. Hopefully, when I get my hub, I’ll also be able to help debug this.

Chris responded with suggestions, the first was part of the original instructions, so I believe I tried that already, but will repeat. The second has to do with a Secure Include. If the Devices to be upgraded are included securely, the upgrade tool needs to be given the secure key. I don’t remember doing a secure include for my Multisensor under test, but again, I’ll repeat trying this suggestion.

When I have some time…

1 Like

One thing to note - I noticed you are using the Z-wave stick from the Hubitat to join your existing Z-wave network.

It may not make a big difference, but my plan was to move my Multisensor 6’s from ST to Hubitat as part of my proof of concept, then plug my existing Z-wave stick into my Windows laptop, put the Hubitat into inclusion mode and join my Window’s machine via that Z-wave stick to the Hubitat Z-wave network and try this.

I haven’t received my Hubitat though, so I won’t be able to try this until I get that.

I think you’re suggesting the same end result. I have 3 USB “sticks” with Z-Wave radios… 2 from Aeon, and the one from Nortek that came with the Hubitat. The Nortek Z-Stick has been in the Hubitat all it’s life except for day one, when I got OZWCP working (on a virtual Linux Debian instance.) One of the Aeon Z-Sticks has been permanently connected to it’s machine “since birth” too. :slight_smile: I have also “promoted” Hubitat to Primary and SUC (+SIS) I believe. (I have not spent anytime investigating what that’s done to SmartThings, but I believe it was Primary (+SUC/SIS) previously. )

I had the 2nd Aeon Z-Stick just sitting there for a year and because of OZWCP and Zensys Tools experiments, got added to the single ZWave network.

End result will be the same for both of us, I believe. One Hubitat plus one Aeon Z-Stick in a different computer. The Aeon upgrades will be attempted from the Aeon Z-Stick while the Hubitat (hopefully) ignores it all. :smiley:

1 Like

Not sure if you are referring to using the Hubitat Z-Wave stick (The Nortek) on a Windows machine/Virtual Environment to update the Aeon Multisensor 6. If this is accurate then yes, I have used another Nortek I had lying around to update the half a dozen Multisensor 6 devices I have, to the latest firmware.

Haven’t specifically used the stick (supposedly the same) that came with the Hubitat though. The GUI tool provided by Aeon (as shown in @csteele’s post) is what I used.

I think so - we are talking about basically having another Z-wave stick join the existing Z-wave network that the Hubitat has formed and then pushing firmware updates to the sensors while they are still part of the Hubitat Z-wave network.

Previously, I had to remove the sensors from the ST Z-wave network, join them ‘point-to-point’ with the stick in a Windows laptop and push the firmware that way, then, exclude them from the Windows machine stick, re-add them to ST and re-initialize all the automations that used them.

As you can imagine, not something I wanted to do on a regular basis, hence, my firmware was generally only updated for new sensor installs or when I had to replace one. :slight_smile:

1 Like

Understood it perfectly now. Had missed the overall point earlier.
I agree, this would save a major hassle in updating those sensors.

Aeon says it can be done BUT my attempts have not fully succeeded.. yet

I remain optimistic :slight_smile:

UPDATE. I guess I didn't wait long enough after clicking the Node Information step. I came back about 3 hours after clicking and failing at uploading the image, and clicked Start again.. it started the upload and completed:


That’s great!

I guess the real question is do you have to map the ID listed for the sensor to which one it physically is as represented in Hubitat?

In other words, you usually have to click the action button in the sensor to wake it up enough for the firmware update to initiate, and you can only do one firmware update at a time (at least in my experience), so, I can imagine a scenario where you basically start with the lowest ID or easiest location to get to, kick off the update, verify it, then move on.

But, I still think this is fantastic news for those of us who have these sensors - not having to disrupt the sensor on the production Z-wave network but being able to push updates will be very helpful. :slight_smile:

The PC program Aeon supplies is: single target. I didn’t try running multiple instances, but I’d doubt the Z-Stick would allow multiple serial conversations.

No, I did not have to touch the devices physically. Perhaps if I did, I would have found it worked before I walked away for 3 hours.

However, after, I do think it needs a physical (reboot) and therefore, I’d suggest planning to have the physical access.

As to correlating the ID in the Aeon upgrade tool with Hubitat’s ID… If I understand your question, yes it is simpler.

The Aeon Tool simply shows “Sensor Multilevel” and if 100% of those entries in the list are Aeon MultiSensor6’s, just scroll through the list and update each as they occur. If not, well then, a detective hat is needed :slight_smile:

1 Like

Ok, now I have a fundamental problem I wasn't anticipating...

I plug my Aeon stick into my PC and bring up the Aeon OTA client, but then when I try to have the Hubitat discover the stick, nothing happens. Am I missing something completely obvious?


When I updated the firmware in all of mine (about a month ago), I didn't include the Aeon stick to the Hubitat. Instead I excluded my Multi 6's from hubitat, then incuded them to the Aeon stick plugged into my pc. Did the firmware update, then excluded, factory reset, then re-enrolled in Hubitat. After that I re-assigned the motions to the rules they were included in before.

It took less than an hour to complete this on six multisensor6's.

Right, that's how I normally do them as well - this thread was trying to find a way to do this without removing them from the Hubitat, which causes issues when they are highly integrated with rules and other automations.

I think @csteele had a trick to do this by including the stick into the Hubitat Z-wave network and then proceeding from there. I have more than 20 of these sensors, so doing them 'in place' within Hubitat would be highly preferred. :slight_smile:

1 Like

I have 3 ZWave USB "sticks" here... two are the Aeon Z-Stick Gen5

of course the 3rd one is the Nortek from Hubitat.

All three are joined to a single ZWave network. Each have different Node ID's of course. Each has received the full update of the paired devices.

Node ID 1; & Node ID 92 (5C); Aeon
Node ID 81 (51); Hubitat

I used the Aeon at Node ID 92 (5C) to do the Aeon OTA firmware upgrades.

[ The hubitat / Nortek USB Stick is keeping warm sitting on top of my Mac Mini. Someday, I may decide to use Zigbee, and then it will be worth the time and effort to get it moved to Node ID 1. ]

All three are seen successfully in Hubitat, although obviously the one at Node ID 1 (primary) is the one that works the best in Hubitat.

Ok, so I can see the issue now, but unsure how to fix it.

Both the Hubitat's stick and the Aeon stick in my PC are coming up as Node 1... I presume that's why when I click 'discover devices' from the Hubitat UI that it's not working.

@csteele - how did you change the Zwave ID's on your sticks?


Aha! Success.... at least to join.... put the Hubitat in inclusion mode, in the Aeon OTA client, click on learning mode icon (lightning bolt) and you get the stick joined as a secondary controller, and it changes the, on to try and run the firmware update... wish me luck... :slight_smile:


Two node 1's sounds like they are on different Networks. The first node of any freshly created network is node 1, and then every new pairing gets the next available Node ID, as allocated by Note 1. Thus I can't see how you can have two ZSticks on one network, both at Node 1.