Fibaro FGK-10x driver w/temp

@jeremy.akers - as I said, I’ve got a couple of those devices working as expected using either driver.
Now they're reporting correctly with either driver....

1. JJ's Fibaro FGK-10x ZW5 Handler
2. The Fibaro Door/Window Sensor 2 driver is now also working

I’ve seen them reporting Opening/Closing and Temps whilst I’m overseas and could give you more detail when I get back to Sydney on Friday.

@jeremy.akers I've just checked the drivers I'm using for those devices and I'm using the inbuilt Fibaro Door/Window Sensor 2 driver and temps are reporting perfectly

That's interesting. I spent two days trying to make that driver work, and had no success.

However: I went back to my SmartThings config and realized I had to install a customer driver (They call them "Handlers") on my ST to get it working there. That particular "Handler" was developed by SmartThings themselves. I copied that code from my ST hub into Hubitat and it worked great.

Not sure why my FGK-10x won't work with the Hubitat built in driver, but it worked fine with the one I ported over from ST.

That driver / handler, if anyone is interested, is available on the SmartThings public GitHub: SmartThingsPublic/fibaro-door-window-sensor.groovy at master · SmartThingsCommunity/SmartThingsPublic · GitHub


You've quoted me out of context of the thread.

If you read the thread, you'll see that I was responding to @njanda who says that the built in Hubitat driver is working fine with his FGK-10x device.

So if you want to quote me in context a more accurate quote would be "Not sure why it doesn't work for me if it's working for you".

Perhaps you could answer that particular question?

@jeremy.akers I am new to Hubitat and moving from Vera. I have a FGK-01x that I have tried with several drivers, also the one you point to form ST, but still I can't get Temperature to work.

I notice in the driver that I may need to un-comment 2 lines for temperature to display in tiles, but not sure if it also should be that way for Hubitat. What changes did you do to the driver yourself ?

I cannot see any responses from the FGK in the log, other than open/closed if I introduce a magnet, but that is not the main purpose of the device (for me) as I only use it for temperature.

Any ideas are welcome as I am struggling with this.

I did uncomment those lines, but only because I had done so for my SmartThings integrations and I wanted the temperature to show up in the "tiles" within the ST app.

Hubitat doesn't use the tiles so uncommenting those lines should have no effect. However there is an additional line at the top that does need to be uncommented:

capability "Temperature Measurement" //UNCOMMENT ME IF TEMP INSTALLED

This line sets up the driver itself to be able to report temperatures to the hub.

That said: I ended up ditching the Fibaro's because I was tired of replacing batteries. The Konnected alarm panel system supports connecting any number of DS18B20 sensors to the same "zone" input on the Konnected board which can run off of a standard 12v wall wart power supply. So instead of having three different Fibaro's each connected to their own DS18B20 and each needing regular battery replacements: I set up a true one-wire network with all of my DS18B20 sensors and connected them to one zone of m Konnected alarm panel which now runs on AC power with a 12v battery backup.

Just figured I'd mention that if you're considering alternatives to the Fibaro.


1 Like

After some tinkering around I found out that I had some issue with my Fibaro. It just blinks and behaves erratically, so I am putting that in the drawer for now.

I do use a similar thing on my Vera which is the Fibaro Universal Binary Sensor where I can have up to 4 DS18B20s connected, so I hope that I can port that one over. I see a driver for it so I guess it is possible.

Has anyone had much experience with Fibaro FGK-10x contact sensors ??
I had three of them, on access doors, but they just seemed to cause me to loose faith in them for a variety of reasons and all but one were replaced with Iris door sensors which have been faultless.
Now I've got another weird thing going on with my last remaining Fibaro FGK-10x contact sensor.

It is no longer reporting Open / Closed but IS reporting battery and temps.

Has anyone got any info on such behavior with these sensors- in particular ones that seem to have "locked up" reporting the contact state change ?

I've removed it from the door and even in close proximity to the Hub it''s not updating the contact "state".
Can I exclude it in this state as it "seems" to still be reporting ?

I have 10 of these all work perfectly open/close and temp with the Native Fibaro Door/Window Sensor 2 driver.

1 Like

Hi all. I've got a couple of these sensors I used with a Vera that died a while back. I'm trying to hook them up to my HE and struggling. I've tried excluding through HE, resetting them (from instructions I downloaded and including (after the reset) and nothing. The inclusion process in the instructions for a Fibaro controller is a short press of the TMP button on the back. I do that and the sensor flashes for about 10 seconds then stops but no inclusion on HE. Can someone please help? Some bullet points would be mighty useful. It's killing my Sunday!

To include those you should be pressing the TMP button on the back 3 times. One time just forces the device to wake up. 3 times and the led should pulse until it is included. FYI the same 3 times press for excluding them.

They will pair as a "device" but if you change the driver to the fibaro door window sensor 2 click save then click configure they will work fine.

Just tried the three quick presses of the TMP button. Still doesn't work. Can't exclude or include. The blue LED flashes for about 7 seconds then stops.

Do you still have your Vera? Sometimes when I have problems getting the Hubitat to exclude zwave I'll use my old Vera to exclude them, then do the inclusion to HE.

I would also reboot the hubitat then try it.

If you still aren't able to get it I would factory reset the sensor.

@bigrizz, That's what I had to do to a few of mine - Factory reset them. Took far longer and was way more trouble than I think it should have been but I got the blighters into line eventually.
Check this video out.

Thanks Wayne. Tried that. I think it's reset. What do you think it means when it says, "Make sure the TMP button is intact". It sounds like Chinese English for depressed? In any case, I've done both with TMP pressed and not pressed. The outcome is the same. Still no luck. I fished out the old Vera. It was playing up the last time I used it, so it's not been used in a while. I've set up a new network and lo and behold, it fired up and seems to be working. It looks like I unpaired the Fibaros as they are not in the devices list on the Vera. So they should be ok.

TL:DR it's still not working.

It's referring to the button being functional. Because they are first installed with a double sided tape directly over the top of the tamper button and occasionally the temp button will stay pressed in when you remove it from the door because of the tape holding it in.

So my takeaway there is don't have it pressed in while attempting the factory reset? I'm going to put them back in the drawer for now lest I do something drastic and throw them over the fence. I've tried about every combination I can think of. Today is not the day, sadly. I still get the blinking for 7 seconds then it stops but no discovery. @njanda suspects that it is in a fault condition if it's doing that. I'm clueless. I'm all ears if anyone else comes along with more stuff to try. Thanks again, Wayne and @njanda .

I was so close to binning one of mine for exactly that scenario. I'd already struggled with another 2 that I'd bought 2nd hand. I bought new batteries and in the end just had to try, try and try again to get the darn things to reset and report correctly.
One of them went into my HA draw for several months because I could not get it to play ball.
About 6 months ago, I took it out, installed a battery and the darn thing paired up - sweet. it;s been working fine since then !

I do know now, that with one of my FGK-10's, when installed, I had a range issue which I resolved by installing a repeater.

Have you tried joining right next to the hub? Other than that the only other suggestion I would have is a hub shutdown (not reboot) and pull the power for 30 seconds power cycling the zwave radio. I usually have to do this to get a strong enough signal from the hub to reach my locks.

After that I'm out of ideas.

I tried standing one foot from the hub and triple-pressing to put it in discovery. Waited the 7 seconds then tried again and again. Nada. I rebooted the HE but not the shutdown. I would have thought standing one foot from the z-wave dongle would have done it. Dead strange. But hey, thanks again for throwing out the suggestions. Appreciate it.