Enphase Solar monitoring

Hey all

BLUF - I am not a developer :slight_smile:

I am trying to port over a ST DTH for my Enphase Solar system. Was able to update all the physicalgraph to hubitat and got past that error. Now I have an error


that appears to be related to this section of code

htmlTile(name:"graphHTML",

action: "getGraphHTML",
refreshInterval: 1,
width: 6,
height: 4,
whitelist: ["www.gstatic.com"])

Anyone interested in helping me with this?
Here is the link to the full code

Thanks in advance
Rick

1 Like

So while trying to fall asleep last night, I got to thinking, should this code be an App rather than a device? This morning I tried to save it as a new App and get this error

I tried entering my Enphase IP address everywhere on line 22 with no luck

My guess is all the parameters will need some input so IOW, the IP Address is just the first of the errors

Rick

Anyone with Enphase Micro Inverters looking to monitor their systems?

Rick

I have it working some. Need to fix the graphs. Likely later this week.

That is so awesome, can't wait to see it again :slight_smile:

Rick

Did you get this working? I have an Enphase solar system and wouldn't mind getting this set up.

I have this working, including graphs.

I need another few days to test. Send me a private message if you would like to help test.

Here is the repo if more folks want to try it out.

Instructions

  • install the device driver code, and create device & configure it for your Enlighten System

    • importUrl: https://raw.githubusercontent.com/imnotbob/EnvoyHE/master/device/enlighten-envoy-local.groovy

    • Steps:

      • From the HE main page, select Devices, then select Add Virtual Device
      • Give the new device a name, I used Solar
      • From the Device Type selection, scroll to the very bottom and select Enlighten Enphase (local), select Save Device (you should now have a new device)
      • From the device list, select it to open it up and enter the following info
        • Envoy Local IP Address
        • Enter the number of Inverters/Panels
        • Rated max power for each inverter
        • Panel size
        • Select Save Preferences
  • install the application code, and create application and configure it to get data / create graphs from the device

    • importUrl: https://raw.githubusercontent.com/imnotbob/EnvoyHE/master/app/solarGraphs.groovy

    • Steps

      • From the HE main dashboard, select Apps, select Add User App
      • Select the Solar Graph app you installed earlier, select Close
      • From the main HE dashboard, scroll down to the bottom and open the new Solar Graph app you just installed
      • Select Envoy Device at the top and select the Device you created a few mins ago, select Done

The solarGraphs app may need some time (2 days) to gather data (during solar working hours)

  • Now the real hard part........... wait for a day or 2
  • Then open the Solar Graphs app, and select the Graph URL, it should work
2 Likes

Thanks @nh.schottfam (Eric) for putting this together, great job :grin:

Here is what mine looks like

Once installed, open the Solar app and then select the Graph URL link

Thanks again
Rick

graph website:
{"message": "Internal server error"}

app log:
java.lang.NullPointerException: Cannot get property 'value' on null object on line 701 (renderDeviceTiles)

device log:
unable to find installation date on page

otherwise device showing data, graphs are not

are you running the latest code?

Did you just recently install?

Let me know if you are still seeing it today. If you are send me logs as a private message.

no change today

found problem
hub lost connection to the cloud.
A reboot of the hub reconnect it.

working good.

I am in the process of switching from Smartthings to Hubitat. I used the Local Envoy code under smartthings so I am familiar with how it worked. I need to enter the IP address of the envoy and other bits of info about my array. When I add the user app solar Graphs there is a "Envoy Device?*" "Click to set" however there is no way to actually enter anything. It looks like a small text box tries to appear with an "Update" button however you cant actually enter anything from the keyboard.

Trust you have the Device and App code installed and a new Solar device created
Here is what my new device preference section looks like

Rick

Thanks, I missed a step.

I had the device and app code saved but had not created a virtual device for the Envoy. Once I did that Its appears to be pulling data.

Solar app has been updated to include local URLs to version 0.2

1 Like

Hi! New Hubitat user this week, so apologies for any noob questions.
Got this up and running with my envoy - no problems.

How are people embedding this graph into dashboards as a tile or similar? It looks perfectly rendered for a mobile device, but wasnt sure if there was an easy way to make it an element in a bigger dashboard. Thanks!

Just getting into home automation and have Enphase 15KW array on my roof. DEFINITELY want to get this info into Hubitat instead of opening web pages to monitor and also wondering at the possibilities to use the information.

One (rather unique perhaps) thing I'm looking at is that my solar system overproduces when we don't run our pool heat pump. FPL does not allow us to have more than 15% overage or they can require us to remove panels (stupid, but that's Florida). So given we have sometimes 30KWH extra production or more on a sunny day when we are not running our heat pump I am starting to mine cryptocurrency with the extra "free" electricity to make sure I use it all. However if we have low production and high usage for the month then I'd ideally like a smart plug that I would shut down so as to cancel the mining for a period of time until we are back even again.

that may be too much to ask, but it's an idea I have.

Anyway - looking forward to learning more about how to integrate Enphase solar with my soon to arrive Hubitat!

Howdy,

Sorry to hear about FPL is. Here in San Diego we are not there yet. we overproduce many months, some by a lot and other months we are behind. Averaged out of the year, it's a no brainer. First year we paid SDGE a total of $12.00, year 2 $36.00, year 3 $21.00

The app works great to see visually what's going on, however i haven't used it to automate anything

Good luck and enjoy
Rick