Ecolink Tilt Sensor Exclusion & c-7 zen16 problems

Two part question..

Currently in the process of migrating devices over to a new C-7, I’ve completed everything except a ecolink z-wave plus tilt sensor in my detached garage. Both the manual and the hubitat wiki say I should just have to remove the battery and put it back in to get it excluded, but try as I might, I can’t get it to exclude. Anyone have any thoughts or experiences with the devices? Do I have to be close to my hub to get it excluded? The thing is basically cemented in place with it’s adhesives, so that may be difficult (the device should be connecting via a repeater)...

Second question, I know there have been a couple of threads about some zwave difficulties with the new hub, but curious if anyone has moved over a zooz zen16 yet? Using it to trigger my garage door and it was previously humming right along. But after joining it to the new hub (with S2 unauthenticated), it seems to not have a stable connection. Eventually shows up as a failed device on the z-wave details page. Power cycling it seems to temporarily allow it to connect again, but it soon after falls into that failed state again.

While not a great answer, I have a 100 foot ethernet cable which only need when excluding or including Z-wave in my Garage. After the devices are set up i don't have any mesh issues. But i could never get them to pair or unpair in the garage. I shut down the hub, plug in the cable and move it to the garage. My garage is attached. You may need a longer cable.

Tried and failed. Several times. I set the device aside to continue progress on the rest of the network. I am pretty sure it will work in non secure mode, but I need it enrolled securely as it is being used to control an entrance door.


One valuable tool I had in this migration was my aeotec zstick. It has a battery in it so you can take it around the house to each device and put it in exclude mode and then exclude the device. I had devices that wouldnt exclude on the hub for some reason but the zstick made it instant. Well worth having.

I have done it successfully. However, once I got the pairing stuff all sorted out the zen16 added easily.

@gavincampbell did you join the zen16 with S2 enabled or did you join it unsecure?

S2 involves 3 'components' -- S2 in the Hub, which the C-7 has, S2 in the device, and S2 in the device driver.

I thought all the built-in drivers got S2 added but I'd be surprised if many of the Community ones got there yet.

Pretty much all my devices are joined without security. I think only the locks have security because its required.

The Zen16 is with no security because I haven't updated my drivers yet for it.

I'm not aware of any community drivers for the zen16, I'm just using the drivers that ship with the hub. The device is opening a garage door, so I'd prefer for it to be S2 joined (the device does support S2 unauthenticated, which is how I originally joined the device). I suspect whatever my issues are, it's likely connected to whatever other issues people are having with some S2 enabled devices.

Not a big deal, I kind of expected to have some issues, but was too excited to unbox and switch over from the C-5. I'll just have to accept my garage door being dumb for a while...


I think you are probably right, but I couldn't be sure you weren't using a Community driver. :slight_smile:

1 Like

@mike.maxwell sorry to be a bother, but just wondering if Hubitat’s Zooz Zen16 driver has been updated to support S2?

Which driver were you using?

Zooz MultiRelay

This driver had all the updated security bits added in platform 2.2.2


Just paired mine successfully as a test for you (Zen16 Multirelay).

It did require shutting down and running discover from zwave details.

1 Like

Ok, thanks for testing, did it appear to react to commands issued to it? Will have to play the exclude/include dance a couple more times to see if I can get it to cooperate.

I was able to pair mine a few times. Each time it would work once with the first relay I tried. Subsequent relay attempts all failed.

1 Like

Was about to go change wires to each relay (Zen 16) as I have it wired to a single garage door, but remembered the relay makes a click noise when triggered. I went to each child on the relay and tested each on/off and heard the expected click. Went through them each a second time and they worked as expected.

1 Like

That's awesome. If you don't mind, could you post what is shown in the State and Data section for your Zen16? Thanks!

1 Like

1 Like

Thanks for that. It looks like your Zen16 is paired insecurely. When paired securely, the data section should have these additional entries:

  • zwaveSecurePairingComplete
  • secureInClusters
  • S2

I didn't save a snapshot of mine. When I next pair it I will capture the data and post it.