Ecobee login issues

I am having issues with ecobee and my new hub. Ecoobee recently rebranded and started offering two factor auth. I have enabled that for security. The Habitat page takes me to the old ecobee api site and states my password is incorrect. I try resetting it via the api link then my password doesn’t work for the api or any ecobee site or app.

I’ve disabled two factor auth and I am still having the same problem. I’ve emailed Hubitat support and have not gotten a response. Is there a fix for this issue?

Based on posts on r/ecobee, this seems to be an issue with other ecobee integrations as well. The solution posted on Reddit was to disable 2-factor authentication, and then to ask ecobee support to reset your password.

1 Like

@Falcon_effect

Please also see this post by @dman2306

FYI I didn't need anyone to reset a password, didn't even need to reset it myself, it just worked as soon as I disabled 2FA

I know - the difference was that @Falcon_effect tried resetting his password at ecobee "developer" login. That has been broken for at least two years. The only solution is to call them and ask them to reset it.

1 Like

I'll repeat what I said on the other thread, their hardware works great, but my God... do they hire developers who work for minimum wage or something? 2 years??? I don't know how anyone will trust their security system....

1 Like

Ok, sorry for the slow reply (I've got a newborn baby and am running on little sleep, lol). I called Ecobee and reset my password. I tried adding the app and was presented with the authorization agreement from Ecobee, then it took me to the main ecobee page for some reason. I have tried multiple times to install the app and am having issues still. Occasionally, I will get the incorrect password issue like before, other times I'll get the auth agreement. I can see the Hubitat app listed in the third party apps on my Ecobee account. So I am at a loss for what to do next.

1 Like

As am I. The issue is at the ecobee end ..... not sure what you can do to get around that.

Have had the same problem. Spoke to Ecobee support, provided them screenshots and the link that creates the bad password problem, Said they would escalate the matter, that was two months ago. Grrrrr

Have you checked the third party integrations on you Ecobee account? I see Hubitat there. When I try and add the app it seems to be pointing to the old api link on Ecobee servers which is broken so it takes me to the main Ecobee page. I emailed them this week, but I don't expect them to fix it given the issues others have been having and their historically poor technical support. I guess I'll just have to use IFTTT or my old smarthings link. Grr.

I had the same issue... (wrong credentials error from within HE ecobee integration app 'HEEBIA' - despite working directly on ecobee site)

I found a work-around that finally worked for my instance (note I tried many things, so some of this may or may not have attributed to the eventual success):

EDIT: Start at Method 2 (Step 9) - this appears to be the solution to the password sync issue.

Method 1 (I don't think this is what actually worked, but I did these steps first):

  1. Disable 2FA from ecobee app (not sure if this is necessary)
  2. Log into ecobee from another browser tab (not from within HE ecobee integrator app), click 'remember me' on ecobee login dialog
  3. Now launch HE ecobee integrator app again, this time should not get the log-in dialog, and goes straight to eco-bee webite (mobile view)
  4. From drop down menu on ecobee site you will likely see not logged in > click log-in
  5. enter credentials and log-in.
  6. Browse to your thermostat (top right drop down menu)
  7. check to see what integrations are linked
  8. Close window - hope that HE ecobee integration app proceeds to next step

Method 2:
Continuing from Method 1:
9. Ensure log-out from ecobee website (to force HE ecobee integration app to require log-in)
10. Launch HE ecobee integration app
11. attempt login - if fails, this time request reset password
12. Following ecobee pw reset process - enter the SAME existing password that you use for the site.
13. re-attempt login from HE ecobee integration app (this is where the password finally was synchronized and worked for me)
14. Continue set-up...

I am unable to reproduce the mis-sync'd passwords issue, hope this helps someone however...

3 Likes

Wow, that worked for me! Thanks!!!

That's great!

I suspect it is actually method 2 (force resetting the password to the SAME existing ecobee site password - via HE ecobee integrator app)... that does the trick.

Did you also do all the steps, or find anything that would narrow down which of these steps actually allowed it to work? Just curious.

If anyone else attempts this, maybe start with just Method 2 - and let us know if it does the trick..

Anyway, glad it worked!

Success here also!!!

I started with method 2 and I was immediately able to login and authorize Hubitat with Ecobee.

Thanks

Nice! :ok_hand:

That will simplify the process - thanks for letting us know

@cpbradley @Falcon_effect
I'm running into this right now...just installed my ecobee. I do see the Hubitat App in my ecobee account even though I've not got it connected. Should I remove it from there first? Or just start with method 2?

I removed it before I went to method 2. I also made sure to log out after removing the instance.

1 Like

I removed Hubitat from my Ecobee account and started with method 1.

1 Like

Thanks for the help. Method 2 got it working for me!