Ecobee login issues

Same story for me. Tried method 1 and 2 and neither worked for me.

  1. Made sure that I removed the Hubitat Elevation from ecobee My Apps page.
  2. Logged out of ecobee.
  3. HE ecobee app - prompted to Authorize App. Logging on with my known good credentials failed.
  4. Clicked on If you have forgotten your password, then please click here.
  5. Got auth.ecobee.com message Check Your Email for instructions to reset your password.
  6. Opened new ecobee email and clicked on secure password reset link.
  7. Entered my same password for the ecobee Change Your Password New Password and Re-enter new password boxes.
  8. ecobee goes to it's Home page.
  9. HE ecobee app tried logging on again.
  10. New ecobee message to Decline or Accept to Authorize Hubitat Elevation. I clicked Accept.
  11. Authorized App with the reset password credentials which was the same as before. Got message the user name or password you provided was incorrect.
  12. Went to Google Chrome new page and logged onto ecobee. From ecobee My Apps, I can see that Hubitat Elevation was re-added as one of my apps. I had removed the HE app from ecobee on step 1 so it was added back in I'm guessing in step 10 when prompted to authorize HE and I clicked Accept.
  13. Logged out of ecobee from Google Chrome page, closed out all browsers and shutdown PC.
  14. Restarted PC
  15. HE ecobee app - prompted to Authorize App again. Logging on with my known good credentials failed.
  16. Back to same as before step 4. Clicked on If you have forgotten your password, then please click here.
  17. Repeated steps 5-9 with same outcome.
  18. HE ecobee app - prompted to Authorize App again. Logging on with my known good credentials failed.
    At that point, I gave up. I guess at some time I'll have to contact ecobee tech support and see if I have some success.

Something it’s going on with ecobee for sure

Unfortunately it looks like they changed the Password reset option on this page as it now takes you to the standard login option where you can select forgot password. It then emails you a link like the standard way.

I have tried multiple ways to make this work and keep striking out. Hopefully ecobee support will be able to help out.

Anyone else still having issues that found a solution?

I too am having this issue and the solution of resetting the password has not worked.

I am trying to set up a new hub (which was an ordeal to get started because it came without the platform installed and would not update) and the first thing I tried to set up was Ecobee, and of course, I see that feature is broken.

This has been a problem for over three months now and all I'm seeing is a collective shrug. Is there any way to get this working that actually works? You'll note the latest janky dance of resetting passwords (but not actually resetting them) doesn't work. The grant is made, but then you are immediately logged out of the Ecobee site and the callback telling HE the auth_token appears to never be picked up by HE.

I don't really want to hear a bunch of buck-passing between Ecobee and Hubitat - OAuth is a simple protocol and Hubitat is responsible, in my eyes, for making it work. Is there any way to get an official response on if this is even on the radar at Hubitat?

I talked to ecobee devs and they said hubitats apikey needs whItelisted on ecobee’s side. I posted about it in the ecobee suite manager app and that dev said he’d look into it.

Hubitat is the consumer. When Ecobee is basically admitting 2fa broke it and there are bugs... not sure why Hubitat is responsible?

2 Likes

I'm also having issues logging in via the Ecobee Integration App in HE. I've tried all of the suggestions of resetting my password, removing/adding the app, different browsers, etc.

I'm able to login to the Ecobee.com website with my username/password, no problem...

Works fine with with Ecobee Suite manager....

1 Like

I didn't know about Ecobee Suite Manager. I just installed that today and it works great. No authentication issues like the built-in Ecobee app....

I have had the Hubitat Ecobee integration working for about 11 months without any issues. Today, I noticed that the integration stopped working. I tried all of the suggestions in this thread to no avail. I ultimately ended up disabling two factor authentication on my Ecobee account via the Ecobee mobile phone app. Afterwards, I was able to login without any issues.

The Ecobee 2FA is not currently supported :frowning:

1 Like

So, my guess is that when I originally enabled the Ecobee integration, 2FA was not even a thing at Ecobee. So I had no issues. Then, I seem to recall Ecobee encouraging users to enable 2FA, so I did - but that was many months ago. I guess something expired and thus the problem started for me yesterday. Glad I was able to get it running again.

Since this has obviously been an issue for many months, does Hubitat have any idea when they are going to support Ecobee 2FA?

1 Like

Download the Hubitat app