Eaton (Cooper) RF9540 Z-Wave Dimmer

these switches are no longer working with the stock device type generic zwave dimmer.

they update level and dimming based on chagnes digitally from the apps or control panel but the buttons on the actual switch do nothing.. I got it working with a port of my device handler from smartthings here

I also have the 9540. That one works fine as a Generic Z Wave Smart Dimmer. I was able to connect the 9542(which operates the same lights as the 9540) to the hubitat but it doesn't work as a Generic Z Wave Smart Dimmer. The physical switch itself also no longer turns on the same light. I've only had the hubitat for a month or so, so I'm not the most advanced at this. Does anyone have a suggestion to get the 9542 functional again?

This sounds like the issue I was having with the newer z-wave plus version (9640) I am still looking for a proper driver for that device, I had to take it out of service for now.

Have you tried my driver it should work

1 Like

I just tried it out and it's working now, thanks!

Also looks like my post including the model 9640 is now showing up in searches so hopefully others can find this solution as well :grinning:

1 Like

Okay seems some interest here. I have 8 for sale, 4 brand new, 4 barely used. 100.00 for the lot of them

Hi @willshieh. Welcome to Hubitat!

I use the RF9640/RF9642 (Z-wave plus) switches. One of the great features of most Z-wave devices is direct association. I direct associate my RF9642 accessory dimmers to the master dimmer (RF9640). The RF9600 series of devices (dimmers and switches) have separate association groups for (01) lifeline, (02) on/off, and (03) dimming. I did a quick look at the RF9540 dimmer and noticed it only has the (01) lifeline group, but it allows five devices to be associated in that group. The hub is always included in group 01, and in new devices (e.g., the RF9600 series devices) only one device (the hub) can be in 01.

With the association complete, I only have to include the master device (load controlling) in any other automation logic I desire. I do not have to create any rules in Rule Manager nor Simple Automation Rules to coordinate the accessory dimmers. This has the added benefit of having the devices continue to function if I have my hub down for some reason (relocating, updating, etc.)

You can either use the Generic Z-wave Association Handler, or get wild and crazy like I did and just send the hex command via the Send Command functionality in the device edit page. the Send Command function is hidden until you click on the work "Advanced".

This is probably more than you wanted to know, but it is an alternative that I think is not mentioned often enough. It works for me. Just remember YMMV. :sunglasses:

1 Like

do you have a link for the association handler thanks.

Here you go.

Once you have installed this device handler on your hub:

  1. Go to the edit page of the master dimmer you want to control. Look up the Device Network ID.
  2. Go to the edit page of the accessory dimmer you want to control that master.
  3. Change the driver ("Type" in the picture above) to The Generic Z-wave Association handler.
  4. Once the screen refreshes you should see this:
  5. Type 01 in the Number field, and the Device Network ID of master you want to control.
  6. Click on the Associate Group button to make the association.

If you want the master to update the accessory dimmer status, do the same from the master dimmer. This should set you up with a three-way situation.

If you have a four or five-way situation, it is similar. You just have to take into account each device will have to be associated to all of the other devices in the switching group. Let me know if you need more details.

Let me know if you want more information about the other method too. It isn't that difficult either.

1 Like

thanks not working for me with the eaton switches


Thanks. Will give it a try.

Hi - I tried this driver with the Eaton RF9640. It successfully fully turn off the switch which is great (so far this is the only driver that does this)...
But using this driver means that I lose the z-wave + feedbacks to the hub when the switch is pressed physically (the hub does not detect and update any physical interaction).
Have you found a solution that allows z-wave+ feedbacks to the hub?


I have 16 of the RF9640 devices. I use the Generic Z-Wave Smart Dimmer driver. They faithfully report their state. Is there something more specific you are looking for it to report?

Remember that Z-Wave devices (that do not implement scene control) do not send a report if the switch is already in the state you are manually choosing (i.e., if it is ON, manually pressing the ON button will not cause it to send an additional (Basic nor Multilevel Switch) report.

Thanks for your answer. You are correct, the reporting is working correctly...

My issue is that when the switch is turned off from this hub / driver, there is still a residual current that keeps the light on at a very dimmed level (the switch does not turn off completely even when its state is changed to off in the app). This does not happen when is turned off physically : in this case, the switch completely turn off and there no residual current going through (and the state in the app is also changed to off). For this I think this driver is not fully compatible.

The only driver I found that is capable to fully turn off the switch is the one posted by kahn-hubitat in Sep '20 (above) ; Link here. But this driver does not support the reporting of the device state...

I am looking for a solution that allow both : full OFF (no residual current) from the hub command and state reporting... Hopefully there is one somewhere...

It sounds to me like it has been configured with a minimum dimming level other than zero.

-Choose one of your particularly troublesome dimmers and change the device driver to "Basic Z-Wave Tool". Here is the link to the code if you don't have it already.

Basic Z-Wave Tool device driver

-Now get the parameter report for parameter 11. This is the minimum dimming level. Normally this should be set to zero, unless you bulbs do weird things with it set to zero.

-If it something other than zero, set parameter 11 to zero (0).

-Change the driver back to the Generic Z-Wave Smart Dimmer.

Let me know if this helps.

Thank you for this... You are right, parameter 11 is set to 1... But it cannot be set to zero... I tried the Basic Z-Wave tool and I can change its value to any number but when trying to change to 0, nothing happens. I verified in the doc of the switch and it says the value of parameter 11 must have value between 1 to 99 (see picture of the doc below). The minimum nber I can set is 1...

Could you verify that your switches have parameter 11 set to 0? The only thing I can think about it the firmware version of the switch... Mine has the Firmware version 1.0. Could you check yours?

Thanks for your help on this investigation!

My apologies. I should have said 1. Mine are one too.

Two questions:

  1. What bulb wattage(s) are in the fixture? Actual wattage, not equivalent.

  2. Using the "Generic Z-Wave Smart Dimmer" driver, turn on the "Enable debug logging" and Enable description Text logging" parameters.

Save the parameters.

Press the "Configure" command button.

Open the Logs in a separate window.

Make sure the dimmer is off (manually).

Press the "On" command.

Press the "Off" command.

Post a screen capture of the logs entries for that dimmer to this thread. Here is what mine looked like.

Hopefully this will help us find the culprit. :male_detective:

No problem... Here are the answers to your question :
1- The switch is connected to 2 leds wall lights that each has a wattage of 10.1W (so total is 20.2W)
2- Here is the screen shot

I can't find anything that would dictate the peculiar operation you are experiencing.

I know some other dimmers have separate minimum dimming settings for manual vs digital actuation. This one does not have that function programmed AFAIK.

As I said earlier, I have 16 of these (over 40 Eaton RF96XX devices of all types) and none of them have exhibited this behavior. At this point I would exclude the dimmer, perform a factory rest on it, then include it again.

I know. Not the easy answer you or I were hoping for. If the issue is within the dimmer, this is likely the only way to fix it. Let me know if this helps.

BTW, the differences you see between our logs is likely due to your device being connected to your C-7 hub with S2 security. I have a C-5, so I can't connect them that way. In the end, the actuator command is the same Basic Set (20 03) in both logs. It is in the 6c01 (Supervision Command) payload on yours.

EATON RF9640-NDW : Problem fixed!...

First... @wayne.pirtle : Thanks for your help digging into the switch settings and configuration... I really thought you would get it through your detailed investigation... And that I would be able to use the generic driver... It seems to be a pretty common problem (I was just looking at some Amazon review on the RF9640 dimmer...So many complains on not fully switching off...). So it is amazing that you do not have this issue... Maybe linked with being with a C-5 hub... (?)

The good news... I found a solution to make it work properly by making a very small modification of a custom device driver... I am using a modified version of the "Any Z-Wave Dimmer Driver v1.1.8" written by @jvm33 found here : Link to Driver

The modification I made to the code is just on one line... I replaced line 1102 from the original :

else sendSupervised(zwave.switchMultilevelV1.switchMultilevelSet(value: newValue), params.ep)


else sendSupervised(zwave.switchMultilevelV4.switchMultilevelSet(value: newValue, dimmingDuration:1), params.ep)

Forcing the "dimmingDuration" to 1sec in that command is making this driver works properly for the EATON RF9640 on my C-7 hub (correctly removing the residual current and fully / properly turning OFF the switch).

Check-out this driver... Pretty complete... Impressive work by @jvm33 (Thanks!) !!!

(PS: And yes, I tried to play with the Dimmer ramp time parameter of the switch but no chance with that as well...)