[DRIVER] Zooz ZEN54 10V Dimmer Advanced

Zooz Modules Advanced Drivers HPM Package also includes:
[Zooz ZEN53 DC Motor Controller] [Zooz ZEN55 DC Signal Sensor]

Zooz ZEN54 0-10V Dimmer driver with the goal of exposing all advanced features and settings.

If you are using this driver PLEASE like :heart: this post
:handshake: Support my work by clicking the Info & Purchase affiliate link below to buy!

Current Version: v1.1.4

:white_check_mark: Supported Products:


:ballot_box_with_check: Features List:

  • Specifically tuned to this device
  • Events include digital/physical type and avoids duplicate info logging
  • All device parameter settings are exposed
  • Brightness Correction: Check HERE for Details from another thread

:lady_beetle: Reporting Issues :beetle:
Please use GitHub to report any issues so each one can have its own conversation and tracking. Please provide as much info as you can including model, firmware and the "configVals" data string. Issues ยท jtp10181/Hubitat ยท GitHub


Must PRESS CONFIGURE BUTTON and check all your parameters after changing to this driver.

:eight_spoked_asterisk: Find on Hubitat Package Manager (HPM):
Package Name: :small_blue_diamond: Zooz Modules Advanced Drivers :small_blue_diamond:
HPM Install Docs: HPM Documentation

:eight_spoked_asterisk: OR Manual Download from GitHub
Direct Import URL: [zooz-zen54-10v-dimmer.groovy]
Full Repository Link: https://github.com/jtp10181/Hubitat/tree/main/Drivers/zooz/

:beer: :coffee: Donations: ---->>>> PayPal.Me <<<<---- :money_with_wings: Never required, always appreciated!
:handshake: Support me by purchasing at TheSmartestHouse.com through my affiliate link!

5 Likes

UPDATE

New ramp rate settings added for firmware 1.21, and parameter 14 is fixed and enabled.
Moved some code around to get the commonly unchanged functions to the bottom.

[1.0.0] - 2023-04-23

  • Added support for FW 1.21 new parameters
  • Code refactoring
1 Like

Hello Jeff!
I don't know if this is the place to post this, but.......

I installed the zen54 into my whole house fan VFD using the 0-10 VDC control, and it works great!
I am having some problems with your driver though.
I did update the FW in the '54 to version 1.30 from Zooz's website and that worked fine.
I created a button controller to raise/lower the '54 output to control the VFD, and get errors in the log.
First, my button controller setup:

Then the log using your driver while pressing and holding button 1 on the remote switch (a ZEN34):

(I tried it twice)

I changed to driver over to the Quibono mini driver:

and it did work.
I created a vertical slider in a dashboard to set the speed on the '54 and that works fine...
only the button control has the error and does not change the '54 output.
I would like to use your driver as there are more options AND I want to support your work!

1 Like

Yeah I think I see the problem in the code, I will get a fix published in the next couple of days here. Thanks for the report.

1 Like

Thank you Jeff!
I am glad I was able to help. You are welcome.
I appreciate your help!

UPDATE

Just posted an update. I was able to re-create your BC rules thanks to the info provided, verify the issue and confirm it was fixed. Was a simple variable type mismatch error I accidentally introduced in the last version with some recycled library code that I had updated.

Here is changelog since the last time I posted it:

[1.1.4] - 2023-07-09

  • Fixed MissingMethodException (var type) issue with startLevelChange

[1.1.2] - 2023-05-28

  • Updated to current library code
  • Flash command now remembers last rate for default

[1.1.0] - 2023-05-08

  • Update to use library code

Thank you so much for getting this out!
YES! It works great so far.
I just need to give it a few more tests, but I am confident that it works now.

UPDATE ZEN54

I posted a minor update to GitHub to fix issues with the fingerprint, so now the driver should properly match to supported devices when they are paired. Did not increase the version since it mostly benefits new installs but if you want to update anyway just run a repair in HPM.

I am bench testing a ZEN54 (firmware 1.20) with a ZAC99 switch. Parameter 12 is "1" (momentary switch, i.e., the ZAC99). I am using a 0-10V LED floodlight as the "test vehicle". The level is set at 83%. Parameter 3 is set at "5".

A few things...

The ZEN54 doc shows that parameter 3 is the "dimming speed" when the light is turned on/off. The driver preference panel shows it as "dimming speed when switch is held", i.e., it looks like the parameter is mislabeled. The attached log shows that it is indeed changing parameter 3 when a change on the panel is requested.

The doc shows that parameter 3 can be set to "0" for instant on/off. The pulldown for parameter 3 doesn't show "0 seconds", and choosing "No selection" results in it being set to the default value of "5".

Also, the attached log shows the light being turned on then off using from the Hubitat device page, followed by the light being turned on then off using the ZAC99. It looks like everything works as expected. Should I be concerned about the unhandled z-wave event that occurs every time?

Any plans on supporting parameters 13 thru 18? Edit: Looking at the drive code, it looks like these parameters are only supported when firmware is 1.21 or newer, and I'm at 1.20.

Thanks,
Ira

First, if you want access to those new parameters you need to update the firmware, I believe the official release is 1.30 from Zooz. You need to register with Zooz to get access to this page: Login - Zooz Support Center

For Parameter 3, I think that possibly changed with the new firmware and Zooz forgot to update it in the doc. I would have to look through my emails with Zooz. I think on your firmware it is the global dimming speed but on the new firmware it only applies to holding the switch; the other new parameters control the other speed / ramp rates. I could have my driver adjust the name and options of the setting only for the newer firmware, I think I had decided to just switch it figuring most people would get the new firmware.

I will try and investigate this a little further, but if you update your firmware it should all work as designed. Sometimes it is hard to accommodate old firmware when they make major parameter changes.

I'm in the software business (30+ years), so I know how much of a pain it can be to keep software "backward compatible" while adding new features.

I will let you know what I see when I get the ZEN54 firmware updated.

Thanks,
Ira

I got the firmware updated to 1.30 using the Zooz USB stick. All of my comments in my Aug 12 post can be disregarded. The device is working as expected with the updated firmware.

The only thing I noticed is that parameter 13 ("Association Reports", according to the Zooz doc) doesn't show up on the device edit screen. To be honest, I so new at this stuff that I don't know what the parameter is actually used for. Looks like it is defaulting to "1".

I have it hidden and forced to 1, it determines how the device reports events to the hub. There is no reason for a user to change that setting. I could have forced it to 0 to make distinguishing the physical and digital events easier, do not remember why I kept it at 1.

I missed your inclusion of updated drivers using HPM. Thanks once again Jeff ( @jtp10181 ) for doing this. Awesome :slight_smile:

Updated the Zen 54 0-10V controller to the latest driver in the package and all is well.

1 Like

:edit: Disregard, this is apparently a documentation issue on Zooz's end. I see now in the firmware changelog parms 15-18 were added from 1.20->1,30) :edit:

According to the Zooz documentation the Zen54 zwave ramp rates (for example) are included as of firmware v1.10, but I do not see these on the driver parameter page.

Side note, units from TheSmartestHouse shipped with v1.20, as of last week anyway.

Usage shot for fun:

Nice.

Did you get your firmware updated and now can see all the ramp rate settings? The driver is setup to dynamically adjust the settings based on the firmware version.

Yep I'm doing them now as I type; tested one and the parameters page updated as expected. No dice using any of the Hubitat OTA methods, even with no S2 but not a big deal, I see others have had this issue also. I need to also do the other four that are presently installed.

On 1.20 the zwave ramp rate can be overrode when commanding so not sure why the new zwave parameters. That was my main motivation for updating (so I'll save updating the other four installed in ceiling later).

Probably for other platforms that dont have my fancy drivers which utilize the full ability of the zwave commands.

That makes sense. Thanks for your work on the driver, it's folks like yourself that make it easy for everyone else.

Have you tested the direct association groups at all?

No I usually do not test the associations, I feel like it is a very limited use case when you have a hub that can do so much with rules. It makes sense to do it with rules most of the time. The one exception is I think you can smoother dimming with the association if you are trying to sync two dimmers together and use the press and hold to dim on a slave switch, sending it to the main with an association.