Device State in error on dashboard and at device tab

New Hubitat user here. Long time HA user (Vera/Ezlo).

Just set up my C-8 Pro hub the past few days and it is mostly working. Approximately 30 devices enrolled, 25 are Zooz dimmers (ZEN77) or Zooz switches (ZEN71/ZEN52). All devices can be controlled from the hub and locally by the paddles.

I have written a few “rules” in both rule machine and simple automation rules. Both seem to work fine. They are basic at this point, turn on lights at sunset off at fixed time, turn all on, turn all off, turn off a light after being on x minutes, …

So all of that works and works well.

My problem is my dashboard is in error. Some of the devices do not update to their current state. They show a past state that is other than what the light state currently is. It is the same 3-4 devices. They are all ZEN77 dimmers, but since I have 17 ZEN77 dimmers there are more working properly than not. I then checked the device tab and saw the device tab also showed the incorrect state. If I clicked the refresh button for the rogue ZEN77 then the state would correct both at the device tab and at the dashboard.

So why are these few devices no getting refreshed like all the other devices on the ZWave network. I compared the configuration tabs of known good vs known rogue and could see no differences.

Any ideas how to sort this out?

Welcome aboard.....

I can't offer too much more than a welcome and confirming what I suspect you already worked out, that your issue seems to be the device status more generally with the hub, rather than some issue with the dashboard display specifically. The dashboard will simply display the current device status, as long as it has appropriate connectivity to the hub to get this info. Based on your checks of the Device Details pages for the affected devices, it sounds like they are not being maintained accurately, which would impact the state you see on your dashboard, not:

Can you post a screenshot of your Z-Wave settings page? It will likely provide details that assist in debugging this problem.



Welcome to the community!

Nothing icky jumps out at me in your ZW table, but I'm not a ZW guru so hopefully someone with better eyes can ID if there actually is something amiss in there.

Are your Zooz switches/dimmers all updated with latest firmwares?

What driver are you using for the Zooz switches/dimmers?

If you're not already using it, I highly recommend @jtp10181's excellent driver here. It can be installed and managed from Hubitat Package Manager (an awesome way to install & manage a wide variety of community-developed apps and drivers).

Jeff has drivers for most of Zooz's devices - they are all great, and he is very diligent about keeping all of them current to match Zooz firmware updates.

ETA -- I see you have at least one Leviton device... They have firmware updates for some of their stuff -- more info here.


Thanks for that. We must be thinking alike. I just loaded that driver a bit earlier to one of the rogue ZEN77s. Its a nice upgrade in that it exposes the many configuration parameters with nice pull down selection menus. Wish I knew about it earlier but I will cycle through all my ZEN77s and cut them over.

Unfortunately the driver did nothing to repair the false state problem.

So I have five devices that I call rogue ZEN77s out of a total of 16 ZEN77s. They all respond to on/off/dim from the device tab and they faithfully respond to commands from my few rules. That makes me think this isn't a ZWave problem in that the RF link would seem solid. It seems the switch or Hubitat is not getting/processing the return codes that would refresh the device state.

As further insight, I included all of these devices in situ. That is they were wired in place (in wall devices) and talking to another brand hub. So I factory reset them in place and included them into Hubitat. So some devices were a good distance from Hubitat. I wonder if a distant inclusion could be a factor in that maybe part of the switch configuration got botched? I have pressed the refresh and config button on the device tab but it didn't improve anything.

So the mystery continues.

I think I might remove one of the rogue devices, factory reset it, then re include it with Hubitat just a couple feet away. I really don't want to do 5 devices over again but if it fixes my problem I guess the effort is worth it. I'll try 1 first.

I was about to remove one of the devices but Hubitat warned me to remove it from all of my rules first! Is that really necessary? I mean if I nuke the device won't it just disappear in the rules it is used? Then I can manually re-add the replacement named device afterwards.

Any other ideas appreciated.

The one & only time I've ever had an issue excluding/including at the desired location (even at the farthest points of my mesh) ended up being a defective device. So if I can't pair in-place, I'm leery. But as with all things, YMMV.

The Swap Apps Device feature is a nice way to help with swapping devices -- it doesn't work with child devices, but for most things, it's real a lifesaver... I usually just create a (temporary) corresponding Virtual device, and use that in Swap Apps while I get the "real" device squared away. Then just swap them again and delete the virtual device. Maybe overkill with the approach, but that way I know for certain nothing is getting dropped anywhere.

If you just remove a device, that can make a real mess of your rules (ask me how I know :sweat_smile:), depending on how intricate the various tie-ins all are.

Other folks have had success using the z-wave "Replace" feature, but I've never tried it myself.


Which nodes are the problematic ones? Give me node numbers or device names.

Usually, sometimes there can be other consequences though.
Using swap apps with a virtual device is one work around.

Thanks for the inputs thus far. I am going to try the virtual switch, temp swap to it, then delete original ZEN77 and repair it with Hubitat very close. Not sure it will help but worth a shot.

The problem nodes I have are (all ZEN77 devices):

Fireplace Ceiling 13
Foyer 09
Kitchen Ceiling 0B
Kitchen Island 0C
Walkway 24

Make sure you exclude it - otherwise you'll be left with a ghost.

I think a hard reset will fix the issue. My suspicion is that your previous controller has set some z-wave parameters that are interfering with the switches reporting a status change back to the hub.

Can I suggest you try TWO Zen77 devices? Replace them both with virtual devices. After a hard reset, pair one of them in place and the other close to the hub. My guess is that they will both work.

In case you don't have the instructions readily available, here are the hard reset instructions:


Running a configure with my driver will check the lifeline association and set it back to the hub if not set correctly. All other associations should get checked, and all settings would be set as shown on the driver. So in theory that should set everything up to work.

But I agree in trying an exclude, factory reset, then include is the next step. There is no reason to move the device or hub, just do it where they belong.

1 Like

OK some joy here!

The virtual device swap then swap back was brilliant. Worked like a charm.

I set up a virtual dummy dimmer and one by one swapped the rogue ZEN77s to it, then deleted the rogue ZEN77, factory reset the ZEN77, added it again through a fresh include, then swapped back the virtual switch to the new device (I gave it a slightly different name Kitchen Ceiling 2 just to not confuse with the original one). Then I loaded the special driver (I believe jtp10181 was the author) for ZEN77. I did move Hubitat to inches away from the rogue device during this exclude include cycle, just to limit things that could go wrong. I will return Hub to proper position and reheal the ZWave network.

Now the dashboard faithfully lights up when device is on and goes dark when off.

One slight difference, not sure if it is a bug or a design choice.

With the native ZEN77 driver when you turn off a dimmer the slider returns to 0 position in addition to turning dark. With the new advanced driver the dimmer tile turns dark but the slider remains in the last set position. I guess like the old push on off dimmer in days gone by turning on returns to prior dim level. So the slide shouldn't mean what level the light is rather what it will be if just turned on.

Anyway trying to wrap my head around if I like it this way or not. Is there a config field such that slider behaves as does in the native driver?


No, but I could add something to do that. I think when I originally did it that way, that was how the old drivers for something like the ZEN27 would have worked.

Looking at my code, I think I can add a toggle for that easily without breaking anything. I will see if I can get a test version for you shortly, to try out.


Try this out: ZEN Dimmer 2.0.3 TEST Version · GitHub

I added a new setting at the bottom, to enable the level to be set to 0 when off.

I had some other pending updates in there as well but probably not anything you will even notice.


Works great! I tend to prefer the slider going to zero when switched off.

Nice job!

Now to add it to every device....

p.s. I edited the file to show rev in driver name so I wouldn't have two drivers with the same name,

1 Like

Oh, you could have just replaced the other one with this one. I will push the update out to HPM within the next couple of weeks.