[Deprecated] Wake Me Up

@danabw

Something else that may be important to know is that i don't see one of the options you show in your screen shots. I see an option to turn "Enable Debug logging". I do not see an option to use Short or Long logs. I used "Hubitat Package Manager" to load the application. Is that an old version.

My current version showing up when loaded that way is version 1.1.2

I actually expierenced the same problem a while ago and just gave up on getting it to work off a virtual switch. If I have time this weekend, I will set it back up and capture some logs.

@bptworld

So i have kind of found a solution for the switch not working, but i suspect it will break other things. So after reviewing the program and thinking about it i think i found where the break down was. Simply put the line 372 were the "magicHappendsHandler" is defined it doesn't specify a parameter value for the event. It is just (). I updated mine to have (evt) just to test and it appears that it allowed the switch to work. I don't think that is a complete solution though as some of the event subscriptions in the early part of the app don't seem to need to pass a event value to the program routine.

I would suggest a quick change to add simple program routine that is used when the event is called for the event driven subscriptions to simply call the "magicHappendsHandler" routine from.

That's just because @bptworld didn't add that option to this app. My screen shots were from his (more complex) Event Engine app.

@bptworld @gnufsh @djh_wolf

I did a little bit more to try to ensure i didn't break anything else while fixing the issue.

I have updated a fork of the repo and created a pull request for the update I made to help ondemand switches work. Hopefully once it is merged this will help those that are having the same problem.

2 Likes

New version on GitHub...

1.1.3 - 12/04/20 - Updates by @Mavrrick58

Thank you!

Hello Bryan, I have a (hopefully minor) request for this app.

The pre-defined colors in this app don't always render exactly correctly, or more likely there are quirks with drivers for some devices. My Lightify bulb for example turns on nearly lime green color when you select "Daylight - Energize" within this app. Other bulbs with that same setting appear much closer to what I would call 5000K or so, fairly close to daylight.

Could we maybe get a custom color temperature setting either in addition to or instead of, the predefined white colors?

I have never tried the predefined RGB colors in this app, so I am not sure about those, but maybe there could be a custom Hue, Saturation, Level (HSL) there too?

Thanks!

Sorry, not in the cards for this app. All colors are based on HUE bulbs.

Fair enough.

So if I modify the child app hues and saturations, starting at about line 660, would that fix this for me? Or will I break something else in the app?

Sure, that'll do it. Won't break anything at all.

Is it possible to add Modes to this? I would only want it to run when Night Mode is on. If it’s not Night, I must be up already!

1 Like

I would love a mode restriction as well.

Do you have any issue with me looking to see what would be needed to add color temp. The preset colors don't seem to work well with the Philips Wifi Bulbs so far from what i am seeing. It also seems that when not setting the color temp and just using color it seems to be a bit dimmer. The colors seems to be off a little bit as other have said. Not exactly sure how the scale is off though. Color is color unless it is a bulb calibration issue with the LED.

1 Like

None at all, feel free to modify whatever you want/need.

@bptworld

I just created a pull request for my updated code to set Color temp instead of hue.

1 Like

New version on GitHub...

1.1.3 - 12/04/20 - Updates by @Mavrrick58

Thanks

Are the device options supposed to work with a virtual switch?

I've got a child app set up to turn on my bedroom light and also hit a virtual switch that will swap the mode by using rule machine. The debug logs show that the trigger time activates the child and I see it turn on the light at the designated level, etc, but I never see anything go to activate the virtual switch.

Logs for reference -

And most of the child config to show the virtual switch that should be activated as part of it -

If this doesn't end up working, I'll just swap to a time based rule or something to change the mode in the morning anyway, I appreciate how effectively it worked when I was messing with dimming the light up which was the main goal.

So, this is marked as Depreciated.... is it depreciated in favor of something else? Do you have recommendations for alternatives for this?

Event Engine - This is the way.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.

Download the Hubitat app