[Deprecated] GE/Jasco Zwave Plus Dimmer Switch with Double Tap, Associations

community_driver

#1

This is a port of nuttytree's ST DTH below:

[UPDATE as of 3/26/18 - please see 2nd post below for details]

I modified this DTH to make it Hubitat compliant. My changes are noted in the comments at the top of the code. I have not tested the ability to associate other Zwave devices (as I have no use for this function) but the double Tap functions work perfectly.

Note: based on the thread in the ST forums, you may need certain firmware versions of this device for it to work properly. If you have part 14294 and the manual includes "association group" information, you should be good to go.

Hubitat Driver:

Thanks to nuttytree for making this great driver. Hopefully he makes the jump to Hubitat soon as well.


Compatible Devices Wiki
#2

I saw some occasional strange behavior in my automations with the above port. The lights would step down their dim level instead of turning off. Rather than spend too much time troubleshooting nutttree's code, I deviced to rebuild the driver myself using the generic zwave dimmer as a template (seems like nuttytree may have done the same because I noticed many similarities).

I have gotten it to work perfectly with all standard functions as well as supporting double taps. I do not have a need for multiple devices association and wouldn't know how to test it, so I have left that out of my driver.

I left the original above for those who have need for associations and would like to attempt to correct the dimming issue and build off that driver.

See below for my rebuild (I did pilfer the fingerprints and snippets of code from nuttytree...thanks again to Chris)


#3

Thank you @stephack. I noticed my 14-series Z-Wave Plus devices are not registering physical doubletaps. I can doubletap through the device handler button successfully, but not physically at the switch.

I'm only beginning to understand HE's button implementation, but I did notice they added a "DoubleTapableButton" capability which I don't see in this script. I wonder if that's the missing link.


#4

This was a port of the ST driver that mapped the DoubleTap of the top button to button 1 pushed and the bottom button to button 2 push. Since this isnt actually a button controller and there is no inherent benefit to making use of the doubletap capability, I chose to make it a direct port.

It should be pretty easy to change the push function to doubleTap.... but is the a particular reason you need this to be so?

Edit: I just reread my own post and realized that I said it supported doubleTaps. I did this a while back and forgot what I did with this driver. I will have to recheck my code and get back to you....off to bed for the night.


#5

Well, I use doubletap on these devices for various things. The most often used is to turn off all the extra lights in a room. I have another that turns on a LIFX bulb with doubletap. *Just read your update, gotcha.


#6

Just to be clear.. ..you just need to be able to have the the physical doubleTap generate an event that you can use to do something else...whether it's a pushed or 2xtap event does not matter...correct?


#7

Yeah in the end it shouldn't matter. It just needs to be seen when the switch is physically doubletapped.


#8

Ok I verified my setup this morning and my original statement was correct. I did NOT implement the doubleTap capability in this driver and left the original Button1 and Button2 pushed setup.

That should already be available. I'm not sure what Button Controller app you use, but your device should show in the option list for button devices. Button 1 is for the top of the paddle and Button 2 is for the bottom (this is for Pushed and not DoubleTapped). I know it's a little counter-Intuitive but anyone that used the original nutty driver over in smartthings would be accustomed to this setup...that's why I left it as is.

If your device does not show as a button device, please make sure you open the driver details and click the configure button...then click the save button. This should be done after manually selecting any driver.


#9

The changes are minor to switch this to 2xTap. I'll throw it together (probably later today) and post in this thread.


#10

We are talking about quickly pressing the button twice to achieve a "double tap", correct? I do see it show up as a button controller, and can verify that pressing the paddle up once submits button 1, and down once submits button 2. When I tried it yesterday I wasn't getting anything with a double tap (pressing it twice).

Originally I believe it was laid out like this:

Up once: On
Down once: Off
Up twice: Button #1
Down twice: Button #2

If you're looking to have it send the single taps as button presses #1 and #2, then the double tap would have to be #3 and #4 I presume.


#11

This is exactly how it should be working for you. At least that's how it works for me when I use this driver. I will investigate later. You did hit the configure button correct?


#12

Great balls of fire you're right! Configure! You've saved the day.

Man I can't wait til I get past all these silly little user errors.


#13

When I turn the switch off, either through software or physically, the status doesn't change to Off until I go into the device in HE and hit Refresh. Any idea what could be causing this?


#14

It's quite a read, but this post has most of the info and details you need.

Tldt - old zwave does not provide instant updates (lutron patent). New zwave plus switches have instant updates. Option are buy new zwave plus switch (that's what I did) or setup polling as described in the post below.


#15

Has anyone tried capturing a scene with Nuttytree's driver? I have and am not able to activate the scene. I have two dimmers in the scene. Dimmer 1 set at 45% and dimmer 2 at 20%.

I am seeing the following java exception in my log file anyone have a pointer to a fix? Thanks

dev:22018-10-31 11:35:25.775 error java.lang.NullPointerException: Cannot invoke method multiply() on null object on line 433 (setLevel)

dev:22018-10-31 11:35:25.753 debug setLevel >> value: 20, duration: null

dev:12018-10-31 11:35:25.736 error java.lang.NullPointerException: Cannot invoke method multiply() on null object on line 433 (setLevel)

dev:12018-10-31 11:35:25.709 debug setLevel >> value: 45, duration: null

dev:22018-10-31 11:35:14.005 debug Parsed SwitchMultilevelReport(value:0) to [['name':'switch', 'value':'off', 'type':'physical']]

dev:22018-10-31 11:35:14.003 debug description: zw device: 03, command: 2603, payload: 00


#16

This driver was ported a while back and I believe there are now certain standards for drivers to be compatible with Hubitat Scenes. Is there any reason you arent using the built in drivers instead of this one (I updated the title to show it is now deprecated).


#17

What about the double tap feature. Is that supported in the built in driver?


#18

I cant remeber because I no longer use the double tap. My wife kept accidentally tripping off. I'll check and let you know shortly.


#19

Nope..it's not there.

@mike.maxwell are there plans to add button functionality to these GE Dimmers? See the doubleTap Upper and Lower log output below.

I have this parsed to doubleTap events in the drivers at the beginning of this post. Hopefully this can be incorporated into the Generic Smart Driver.


#20

currently button events are supported via devices implementing the central scene class using the generic central scene drivers.