Crashing Hub

I would've posted this in the other thread, as it appears to be related, but it looks like it was closed due to derailment. So here I am.

I've waited patiently for the staff at Hubitat to find a resolution to this problem, but we're going on 2 weeks now, and still no clues. I'm reaching out to the community in a last ditch effort, to see if I can get a sense of how many people are experiencing HE freezing up daily, or there about, (usually in the early AM) and see if there is any common threads among us.

I've stripped my hub completely down. There is now nothing on my hub that isn't native. I removed all integrations, I've chased gremlins, none of which have had any affect on stopping the hub from freezing up nightly, requiring me to pull the plug to get it rebooted. It tends to operate for 12-24 hours before crashing.

None of these problems existed before the previous Firmware update. All the stuff I have now stripped out of the hub was functioning (all be it, with some performance problems for some custom apps and drivers) without crashing the hub. My personal view is that none of the things I've stripped off, not LAN requests suffocating the hub, not exceptions in the log, are involved in what is making it crash. But of course I have limited visibility due to not being able to see the entirety of available logs.

Bobby has been in touch with me daily, but I feel that we've stalled. I'm not getting any new information at this point, we just kept stripping customization away, until I have a system that doesn't do what I need it to at this point, and still crashes in the middle of the night.

Anyone else want to report a similar experience?
I'm desperate to make Hubitat work for me, but at this point it's not reliable and I have to consider that I'll be leaving the community without resolution to this issue.

1 Like

Possible not related but I do have my hub frozen if I left it on for more than 2 weeks without a reboot. I didn't noticed before because I add/remove devices weekly and usually reboot for various reasons, Zigbee mesh heal, Z-Wave not discover.. Etc. I personally think it a memory issue. I do a weekly reboot to avoid delay with my rule machine rules.
I find leaving the live logging on really lag my hub.
Yes, I should get in touch with support but not now. Little busy with other things.

1 Like

Sorry to hear about your hub crashing. I am sure that is very frustrating.

I have two Hubitat Elevation hubs and neither of them crash, hang, or slow down. I do not regularly restart them, unless I am upgrading the firmware on them. They have been very reliable for me.

I say this only because I want you to know that it is possible to have a very stable system. I use mostly native apps and drivers, however I do use quite a bit of my own code as well as some developed by the community. I have Zigbee, Z-Wave, LAN connected, and Cloud devices all working fine. Once in a while Life360 seems to get into a funk, simply requiring me to click DONE in the Life360 App to restore things back to normal.

Since it sounds like your patience is essentially worn out, have you considered a full hub/stick reset? Bobby can walk you through the process. While this would be annoying, at least you could go slowly and see if you can isolate if any specific device/app is causing the problem.


Yes. That’s the last resort. However I’m without a lot of time since I’m traveling a lot the next two months. Which further complicates the fact that the hub freezes nightly. My wife is flat out pissed as our house guests had a bitch of a time while we were gone.


I was going to suggest this as well. A bit overkill but ensures you start with a clean slate.

The only times I've had it crash I was able to narrow it down to two things.

First was the WeMo outlets. For some reason it would send of a request to poll them and hang if it didn't hear back. When I unplugged them to reboot them it would work fine. I have removed them from the mix but not sure if its still a problem.

The second time was with the last update and WebCoRE. I have since removed anything webcore from my hub and gotten into the habbit of just writing my own apps/drivers to do whatever I need. Now its easier/more powerful to work directly in groovy.

My hub has been running flawlessly since.

Maybe its a specific driver. Unfortunately it will take some time to troubleshoot.

I would try leave open the logs and when it hangs look at the last few events that occured to help narrow things down.

If that doesn't help try a full reset and start adding back devices slowly. Maybe its a specific device or driver.

You’ve tried running the hub overnight without the Ethernet connected to see if it’s locked up in the morning?

I would definitely start crawling out the rabbit hole at this point. Start with a clean slate rather than diving deeper. Get the most used automations up and running with native code only and move up from there. Otherwise you risk wasting more timing hunting down a ghost.

Just my opinion. Hope you get up and running soon...cuz I know how it is when your wife isn't happy with this stuff.

1 Like

No, but I've wiresharked it.

If you have been using telnet, that could be the problem. We have uncovered some issues with our telnet implementation that hadn't shown up before. These could explain your hub freezing. Were you running anything using telnet?

Fixes for this will be in the next build. I'd hold off on a reset if you were using telnet.


Lutron applications apply?

I had my own Envisalink integration, that you helped cuboy and me develop.
Recently I've added Lutron, which I believe is Telnet.

I mentioned to Bobby I suspected Telnet as the problem. Specifically the multiple telnet connections at the same time.

1 Like

I don't know specifically what the issue is, whether it is multiple connections or what. I've been running telnet from the very beginning, long before product launch, as my house has a Lutron system. But, I have not run multiple telnet connections. Hopefully these fixes will resolve your problem.

1 Like

We will likely get a good idea over the next couple nights, if it doesn't crash, since I've removed the telnet apps I was using. I still have Lutron, however.

Known to work reliably by itself.

Unfortunately I have same problems with my hub and I'm not using telnet I have nothing left on the hub but still needs rebooting all time

I used to suffer big issues, so much so the Zigbee would just go offline multiple times each day. Support helped me out a lot, I removed a lot of apps (including webCoRE, then reinstalled later) and things started to settle down. I do still have issues, and like you they seem to be in the early hours, which is odd as nothing is expected to trigger then. I often wake to find things haven't executed, such as my radio playing at 7am. But, if I reboot sometime in the evening, things seem to go more smoothly.

I'm down to two pistons, which are just for my Remotec scene controller, and moved everything over to RM. At some point I'll contact Support should this continue, but I'm hoping to work things through slowly and pinpoint the cause. It is working way better than it was before, if a daily reboot resolves it, I'll live with that for now.

1 Like

Early hours in the morning is when the database backup is done, I had the frozen issue too when we wake up in the morning, but my case was the ghost nodes, after fixed it, everything is normal again.

As Bruce said, next update will have many improvements.

1 Like

@vjv Ghost nodes?

I hope it comes soon. I travel again in less than a week. If it crashes while I'm gone, the wife will throw it out of the house.

1 Like

Bruce will kill me...:sweat_smile: