Complete frustration :: Start over? Throw in the towel? Jump?

Did you fully follow my instructions?

The goal is to clear the codes out and then do a full configure and code fetch to hopefully find out what slot that code is in. When the full code sync is done it should find it and then save it in the correct slot, so you can remove it and add it back with the name.

I did. Explicitly checked the debug = on, before hitting Configure

Want me to walk the steps again?

One last tidbit .... the 7775 code is what still opens Apartment.

Did the configure do a full code fetch?
If not you need to press the Get Codes button as well.

You should see in the logs where the hub is asking the device for every single code slot one by one,

If it does not find the 7775 code then that is either the master code or I have no idea and you will have to factory reset the lock and pair it again. I think on the Yale the master possibly has to be 6 digits though, at least thats what I set mine to and I never use it to unlock the door.

Just tested. Yes 7775 remains the master code. Operates the lock. Locks, unlocks, goes into code setting mode.

No, not seeing activity from using the Configure button. Nothing.

Doing a factory reset ... do we first exclude the device in HE? First time I've needed to exclude a device.


If it’s the master code that might be the issue. Change the master code to something that won’t be used to unlock it. You have to change the master code on the key pad itself.

You should have a Get Codes command button, have you actually run that???

1 Like

For clarity

  1. Hit the Get Codes, nothing in the log
  2. Hit the Configure, nothing in the log
  3. Hit Set Code with the 3 required values, nothing in the log

Wondering ..... could 251 be the slot the lock usese to store the master PW? That could be why "unknown codeNumber" ?

But the same is not shown for Front Door.


Depending, some codes don't so, for instance on my Schlage's slots 1 and 2 hold permanent codes and display as ???? . That said, configure won't get your codes. Configure is simply to send the lock information from the driver so they work together.

Once the lock is paired and you are able to open and close it from the device page, wait about 20 mins before putting in a code into an open slot from the device page. Once that code is input and you see it in the table, make sure it works at the lock. Once you've established that, work with LCM


Then something is locked up and not responding. May need to shut down the hub and unplug for 30 seconds, or pull the batteries from the lock temporarily.

Configure and Get Codes should ALWAYS generate log messages if debug logging is enabled.

I can test my Yale when I am home tomorrow and see what the configure output should look like.

1 Like

Was thinking about this more. It seems to be going into Slot 251 because the hub does not know about it but sees that it unlocked the door. The master code is something you set using the keypad. If you want to use that code to unlock you should change the master code to something else, then set that code in one of the slots.

This same behavior has been observed over several reboots, inlcuding migrating to the C-8 Pro. Consistent behavior. FYI. And, happy to do it again. Small effort investment.

You confirmed my suspicion .... was quite surprised those operations did not product log entries. Seemed odd.


Not at all worried about using that code. I've already migrated to using a different code.


Ok so issue is resolved then?
Solution is not to use the master code to unlock the door?

Would be good to know if that was the issue for anyone else having the same problem in the future.

I wish.

Did a Zwave repair on the device. Now, events no longer show up in the logs; lock, unlock, etc. Seems like it is now completely offline.

Is this a good time to do a factory reset? Are there instructions available for that operation?


A repair should not do any damage. You may just need to power cycle the hub and lock to get them talking again.

If you want to reset it, you may first want to exclude the locks z-wave module. The lock and z-wave module are two separate systems that talk to each other internally.
I found this which has instructions in it for entering exclusion mode:

How to reset the lock itself:

Once it is excluded and reset you would then need to put it back into inclusion mode and add it back to the hub again.

When you set a master code, do not use a code you plan to use for unlocking.

Very helpful, @jtp10181 . Had found the 2nd reference, but had not found the first reference.

Move to within 6 feet of the HE .........

Double damn. Start the HE exclusion mode on the HE. Get this log entry.

Press on. Do the Yale exclude steps ...

  1. Master code
  2. 7, Gear
  3. 3, Gear

Did that operation on the lock work? Can't tell. The nice lady (voice) didn't confirm or mention a problem.

Since there is no mention of the lock in the log, suspect the exclude did not happen. Do the same HE and lock steps 2 more times hoping that repitiion could help assure it happened.

Let's now assume it worked. Press on ...

Factory reset the lock. It prompts to create a master code. Create a master code.

Do the Yale include steps while HE is in Inclusion mode

  1. Master code, Gear
  2. 7, Gear
  3. Full stop. What? The only option is 3 on the lock display. But, but 1 is supposed to be selected option.

Go through the HE and lock steps 2 more times. Same outcomes.

Man, o man. I see nothing in the logs about a device being included. Tried to Get Codes in the Lock device screen. This was displayed in the log.

Looks like the HE and lock are not on speaking terms. Set up 3 more codes in the lock using the lock key pad. Refresh the lock device page. Does not show the new codes.

When a code is entered, it shows up in the log.

Uggggg. Where am I?

You never excluded it so you should have stopped there. If you get a busy error just trying to start exclusion you need to shut down and unplug for 30 seconds. Radio is locked up.

You also have to put the lock into exclusion e right after you start it on the hub, not after it times out.

Feared that was the case, @jtp10181 . I'll take another pass at it doing another hub reset.

It rather begs the question "Why"? This is a brand new C-8 Pro only in service about 3 weeks. Is it a hub issue? A device issue? Is it possible to isolate the problem source?

I couldn't gather evidence, but those were the steps ...

  1. Put the hub in exclude mode
  2. Do the exclude steps for the lock before the hub timed out. As can be seen from the prior screen capture, nothing was logged during that interval.

Will get back to it later today

It didn't exclude because the logs literally told you that the z-wave radio said it was busy. As I said, if you get that you need to shut down and unplug for 30 seconds to restart the radio.