Can't see child devices with S2 pairing

I've been setting up a C-7 recently, trying to get everything on to S2. I noticed that my Fibaro plug lost its child USB device after I successfully paired it on S2, but couldn't be bothered thinking about that. I'm not sure if it was S2 that made that disappear or some other reason.

Anyway. Now I'm trying to set up a Aeotec Doorbell 6, and I can't see child devices on that either. This means I can't see what the buttons are doing and I can't configure the chimes and volume for the buttons, so they're too loud.

What might have gone wrong here?

Actually, S2 doesn't seem to be the problem. I paired again with security disabled and still no child devices.

Maybe it's an C-5 versus C-7 problem? I'm not sure how many of my devices are meant to have children, but at least one of them used to (on C-5) and the other has children mentioned in the forum and in the driver list.

Also, after pairing without security, I can't pair with security again until I reboot the hub.

Are you using the same driver for both? Did you use a community driver for the C5, and the built-in driver on the C7 or something like that? (I'm not sure if there is an alternate community driver, just thinking of what could be different between the two hubs.)

I just recently installed a Zooz Z-wave multirelay using S2 security. The device shows up with each of the relays (R1, R2, R3) as child devices. However, the device has a specific supported driver.

The issue may relate to the device you are using and the driver that it is using. I know that with the Aeotec 6 Doorbell/Siren there are several different drivers. Try selecting each of the Aeotec/Aeon Labs doorbell and siren drivers and see if one works better than another.


I haven't tried the doorbell on the C-5, yet, as it arrived after I started the migration to C-7. I believe I was using the Fibaro Wall Plug driver on C-5 when it had child devices, but when I installed it on C-7 it defaulted to a generic plug (why?) and I had to change it manually.

The manual change did not make the child appear. I see the driver for the USB component in the list of drivers, but the device itself doesn't show up.

For the doorbell, while experimenting I noticed the log contained error messages referring to the Siren and complaining about the namespace (like maybe the driver was ported from Siren, but somebody forgot to change a string?). Unfortunately I meant to post them here but looking back it seems they've already expired.

Since the device was screaming at me from under a beanbag because the tamper sensor kept triggering I decided to try the 'Siren New' driver to, at the very least, turn the volume down. There I noticed that the siren driver supports doorbells as well.

Unfortunately I couldn't get control of the lights with that driver. There's an option to turn them off, but it doesn't work and it seems to corrupt other settings when I try.

When you installed the Fibaro, did you change the device type before completing the install or only after you noticed the missing child devices. You might need to do an uninstall of the Fibaro, reset the device to factory and then reinstall it using the specific device type. Good luck.

It looks like the default device type is 'device', so I must have changed it right after set-up, because it wouldn't be much use otherwise.

I'm not sure there's any option to change the device type before completing that. I start discovery, I triple-click the device's button, I get a bunch of security checkboxes, then we exchange magic numbers, and then a thing called "Device" shows up and I'm asked to give it a name. It seems like installation is already complete at that stage, because the only way to change the type of the device at that point is to click on the blue "Device" link, and that takes me to the page where I would normally change it after discovery -- so I think that's no different from coming back to it later to change the type.

Meanwhile, with the doorbell using the siren driver, the button doesn't send events. There's a log entry about the chime starting and finishing, but I don't think I want to rely on a rule derived from the chime-playing status.

After you change the type from "Device" do you do a "Configure"? You usually have to do that if you change drivers.

See if that makes any difference...


Configure on the Fibaro plug doesn't change anything. Configure on the Doorbell also doesn't change anything regardless of which driver I use.

Thinking maybe I should do some kind of full reset on absolutely everything on this C-7 hub because I've had so much trouble. But I don't fancy doing it if it's going to be futile, because it's such a huge hassle to get everything set up again.

Has that ever worked for anyone else?

I tried pairing with my old C-5, but that also fails to register child devices on either of the available drivers.

Aeotec Doorbell 6 does actually works for some people, right? On either a C-5 or C-7?

To answer at least one of my own questions, the new Aeotec Siren/Doorbell driver does not use child devices. So in that configuration that's why I can't see them. The functionality that I could see is the complete feature set that is available at this time.

As mentioned earlier, the old driver raises a bunch of errors which make me think that maybe it was never tested (and now it's "old", so I guess that's that).

So if you found this thread while having issues with Aeotec Doorbell, use the new Siren driver and don't expect to see child devices. And there are various comments about setting up in that other thread.