Cannot update Inovelli Switch Drivers with Hubitat Package Manager

I have a C7 hub running I repeatedly tried using the Hubitat Package Manager to try to update my Inovelli drivers. I see it gets to the point of where it says it is upgrading the Fan + Light:

but then I get this error:

Anybody know what the problem is and how to fix it?

BTW, the Fan + Light is running firmware 1,36 if that helps.

Reboot the hub air gap the switch and push back in and try again. Sometimes that works. Others will chime in I'm sure with better ideas. Otherwise download the firmware from innovelli and use a z-wave stick paired to hubitat as a secondary controller to update the firmware.

I think @Stu_The_K is trying to update the local drivers in Hubitat, not the device firmware.

I'd expect if you check the Past Logs, you'll see some details of the error(s) hit during installation/upgrade.

1 Like

I am only trying to update the basic driver, not the firmware for each switch via the Hubitat Package Manager. I have given up trying to update my firmware as I don't have a Windows laptop to plug a Z-Wave stick in, only an iMac desktop and newer MacBooks with only type C USB ports (and I thought the sticks don't work with Mac OS).

Doesn't the HPM change the device driver in 1 place and all devices using it use that one driver? If so, I'm not sure what logs to look at, or how that would help.

The HPM App should generate logs, and I expect it will have printed an error for the failed upgrade

I didn't see where the HPM log should be, but I did see the HPM Repair tool, which I ran. It "reinstalled" the drivers. I put "reinstalled" in quotes as I then tried the HPM Update tool and it told me everything was up to date. So by "reinstalling" it actually got the latest version.

For future reference, under the Hubitat main menu, at the bottom is Logs - this has several tabs, including current, past, and various metrics/stats, for all Apps and Devices.

I had looked under App Stats. I didn't realize Apps were also under the logs. In any event, I went into the HPM logs and found this error:

Error upgrading driver status code: 500, reason phrase: Server Error

I have no idea what that means, or how it would have helped me, but I'm glad the reinstall technique worked.

I have seen this a few times as well. What I find resolves it is reboot the hub, and then immediately try the upgrade in package manager again. Seems like something is locked or something.

Thanks for the suggestion, but running the Repair tool in HPM fixed it.

After upgrading my Z-wave antenna, I was finally able to upgrade the firmware on all my Inovelli Red Dimmers at last, using the built-in Device Firmware Updater app (C-7 required).


Works quite well on apple running windows on a parallels session. Get the stick and download an eval copy of windows 10 or 11 and install it in parallels and it will work fine,. (make sure to list that particular usb port in as a shared resource in settings)

I have the current version of Parallels running 64 bit Windows 10 on my 27" iMac, so I can't move it around. It is fairly centrally located in my home, a rectangularly shaped 2,500 foot condo. What stick do you suggest, and do you think it will be able to do the firmware upgrade without me being able to move the computer around?

I did look to dl' the software for that once, but it seemed a bit complex to dl' and then run, I wish I could put an external antenna on my hub, and I've seen how to do so, but I cannot solder (I tried to a few times and it was a disaster). I am far, far, less knowledgeable about much of this than the average person up here.

I use the zooz 700 stick...It should be powerful enough to connect to your switches, especially if it's centrally located.

Use the guide here...It also shows firmware updates. Once it sees your devices, simply pick the device, click firmware update, it will ask the location of the firmware update file and you pick it and click update. Follow the stick firmware update instructions just pick your switch. Z-Wave Ghost Removal using a UZB-Stick - How To

I've just completed a bunch of firmware updates. For finicky devices a looooong ethernet cable to get my HE right next to the device being updated made a world of difference.

I use to do the same thing until the antenna mod. I even bought a little battery pack so I could walk around with it. Then later added a wifi dongle also. Glad I don't need to bother with all that anymore.


I thought I'd install the software needed for a Z-Wave stick in Windows 10 that I am running on my Mac via Parallels. I went to the Silicon Software site and tried to follow these instructions to install Simplicity Studio v5:

I clicked on the button for the Windows Installer. The installer in came in as an iso file. When I double clicked it, it said it could not be mounted. I was able to copy the files inside it to a folder and ran setup.exe from there. After it installed, I clicked Install like it said, but I only have the 1st 2 choices (Install by Connecting Device(s) and Install by Technology type... There is no option to Manage Installed Packages.

This is what they say it should look like:

But this is all I get:

So I'm stuck after step 1. Can someone help?

Just a note: There is a mac installer

1 Like