Cannot turn off Osram Lightify bulbs from Dashboard


#1

Don't know what's going on, but I am no longer able to turn off Osram Lightify Bulbs from the Dashboard. They turn off from the device page with no issues.

When I use the Dashboard, they simply turn back on again when I exit the bulb popup.

I'm not good at explanations so I made a video.

Cat Light is a Osram Lightify A19. Living Room is a group of 2 Osram Lightify A19s.


Issue With Color Bulb Tile
#2

Are they connected via Hue, or directly to HE?


#3

@Royski

Directly to Hubitat (they're ZHA bulbs; I'm in the US).


#4

All of my color bulbs are doing the same thing. I have all Philips. I emailed support and they are aware of issue is what they told me. I think it has to do with the tile itself..... oh I do have a few lightify light strips as well that do it as well


#5

Ah no worries man. Only reason I ask is after a recent Hue update I couldn’t control any Osram individually. It screwed them right up.


#6

Here I thought I was just going crazy! Kept trying to set the CT via the dash and it kept changing back to the previous color.


#7

Try backing out of the dashboard instead of closing it. I reported that problem a few days ago.


#8

Same problem here. As Ryan780 says, backing out of the dashboard is the only option once you have turned your lights off. There is also an additional problem that has occurred for me. Before I had read that others were having problems, I kept trying to turn a particular Hue bulb off. Even when I backed out of the dashboard it would turn off and about 5 seconds later turn back on. This occurred even when I tried turning it off directly from the Hue app. Turn it off and in 5 seconds or less the bulb came back on by itself. An hour later I decide to reboot Hubitat and problem solved. I was able to duplicate it again by trying to turn it off several times. So, if you have that issue, just reboot the hub.


#9

ive had HE for about two weeks and i spent two weeks trying to turn my osram's off. Heres the solution:

  1. add a refresh action at the end of every osram light off action turning them off

  2. make a general rule for turning them off in dashboard like: if light on changes, refresh

here is my sample rule and it works flawlessy for all 7 of my crappy osrams


#10

here are my crappy osrams...all 7 tied to a virtual refresh toggle switch i made...theres different ways to go about it but the key is to refresh those lights when off or changed.


#11

here i made a rule for you...just copy to your devices in 4.0. also, i noticed it only does it when turning off and not on. i think this will work for all of you.


#12

actually i just tested that rule and it didnt work for me when using the dashboard. in rules it works fine though or using a virtual switch. make a virtual switch for each light then add a refresh command for the light when the VS changes and it will work in the dashboard. use the VS to turn the light on or off instead of the actual light tile. a workaround until whatever kinks need to be ironed out.

image


#13

There's a bug in the color bulb tile. I already linked to the same problem I'm having above. It is not a problem with your bulbs and cannot be fixed with a rule. It is problem with the dashboard


#14

i would agree but i do have this working with that refresh rule as a workaround for now...try it it may work for them too.


#15

It's easier to just close the color change window by backing out of it rather than hitting the X. Workaround with no rule required.


#16

As @Ryan780 has pointed out, the issue is with the Dashboard tile, not Osram bulbs in general. My Lightify bulbs turn on and off as expected within Automations, or when using Voice Assistants.


#17

i had the issue with them in general...with or without the dashboard. if someone has a solution please tell me. they dont report off all the time in my case. i have the non tuneable soft white ones though. not sure if that makes a difference or not.


#18

What driver are you using with them?


#19

What zigbee repeaters do you have? How robust is the zigbee mesh?


#20

This happened to me yesterday and I thought it was user error. Glad to know I’m not going bonkers, at least regarding this issue :slight_smile: