Cannot connect to my C-7

Hi…. I have been having issues with my Hub and I finally gave it a good test and I am unable to connect to it via the app or the web nor via the assigned ip address… I see it on my router with a different ip and I also tried to connect to it via a browser that way. I pushed the button on the bottom also. I can’t seem to connect to it in any way….

Please help!

Thank you!

did you try the diagnostic menu? hub.ip.address:8081
see if you can login there. sometimes the auto negotiation gets hung up. Do you have jumbo frames enabled on your LAN? that can cause issues

1 Like

If you cannot get to it on the diag tool pull the power out and restart it.

1 Like

Also let us know if you're using Ethernet or Wi-Fi to connect to the hub. Ethernet strongly recommended.

1 Like

Yes unable to connect at all.

I tried unplugging several times and using button on bottom

I am using Ethernet

1 Like

Please read this post: ‼ READ FIRST - Before Posting in Get Help

There are a lot of things to check and questions in there.

I do not think you have said what color the LED is? If it is green then the platform is running and its there somewhere, you just have to figure out the correct IP. If it is blue then you will only be able to connect to the diagnostic port.

Have you tried using the findmyhub page>

Or you can also try the Registered hubs page from here:

1 Like

The LED is green and I have the ip address as I see it in my router and I have tried that directly in a browser as well as the find my hub on my network function…and as I have said I tried to connect to registered hub page also….

Can you connect to the diagnostic tool? Hubitat Diagnostic Tool | Hubitat Documentation

Is this issue now persistent even after rebooting the hub by unplugging it?

Cannot connect to diagnostic tool …. Have unplugged several times and issue still persists…

It is plugged in via Ethernet I assume? Does your router give you info on each port? Can you see if it is detecting a link on that port? Or, above the actual port on the router there should be a green and amber light. Usually the green light would be solid if there is a “link”.

Assuming all that is true and the hub light is green then it should be connected. If it was disconnected the led should flash red/green (unless it is very old firmware).

You could try pinging the IP from a command prompt as well just to see if the ip is up at all.

Are you sure you are on the same LAN as the hub and not some segregated network?

What is your network topology like? Hardware / LANs setup?

Plugged in via Ethernet light is green and I can see the ip on my router it’s not the one assigned to it and I have tried connecting to the ip address directly via a browser….

I am using Eero 1 gigs…. I have 4 and I have Frontier gigabit service….

Delete the IP reservation, let it just get a random IP from dhcp.

Do you have it plugged into a satellite AP or the main router? I would try connecting it to the main router as a test.

It is getting another ip see the pic

I can try plugging it into the main router directly and I will report back!!!

The first screenshot is showing the last IP it had when it connected to the cloud, which was in 2023, months ago, as indicated by the last check in. That IP will obviously not work.

Looks like your network has changed since then?

Did you try using the IP shown on the router?

Also, you should hide your hub ID in that screenshot.

I'm a long-time eero user - if eero says it's on, then that's where it is.

Once confirmed and your C7 is up & running, use eero's Settings -> Network settings -> Reservations & Port Forwarding option to secure that IP address as a DHCP Reservation for the C7.

I've never had an IP-related shenanigan for any device (HE or anything else) once I made a DHCP reservation for it.

Normally don't want to share the Hub ID publicly - probably want to redact that part of your screenshot.