C8 Migration - Hub Failed to Restore

I am trying to migrate from a C5 to a C8. When I try to restore the C8 using the free cloud backup feature, I get the message "Hub failed to restore. Internal error occurred while restoring backup."

I have been able to successfully restore the C8 from a local backup, but it was not able to control any of my zigbee devices. It seems that when I restore this way, the zigbee pan ID and channel are not copied over

Has anyone encountered this issue and figured out how to fix it?

Did you try it a second time or try just going into the hub to see if it did in fact work?

Could you please try again to load the cloud backup. If your devices aren't working after restoring the cloud backup, please send us a private message at @support_team.

I've tried backing up the C5, restoring to the C8, and rebooting the C8 multiple times. I just sent a private message to support

Did you upgrade the c5 to the latest platform first (as well as the c8)?

The C5 was updated.

The C8 seemed ready to go out of the box. I rebooted after the first restore failure. At that point it said it required a soft reset. After the soft rest, it downloaded an update. After that I tried and failed multiple times as I described above

At this point I would pm @support_team as @bobbyd suggested

Update for anyone with a similar problem: I was informed that the issue has been identified and should be fixed in the next hotfix


This specific issue is due to the the user's email address containing an underscore character.


That describes me!



1 Like

I have one email address that contains an exclamation point in the username portion. It’s amazing how many systems choke on that, considering it’s a perfectly valid character for an email address.

1 Like

I have a dot (period) in the username portion and also surprised how many systems choke on that even though its perfectly valid character for an email address.

1 Like

Now that I know there's an issue with special characters in e-mail addresses, I found that changing to a different e-mail is a workaround. Changing e-mails is not as straightforward as just updating your address.

  1. Go to https://my.hubitat.com/register and create a new account with the address you want to switch to
  2. Sign back in with your old account and then go to https://my.hubitat.com/hubs
  3. Click "Hub Details" and then enter the new e-mail address in the bottom section to replace admin. Do this for both the old and new hub
  4. Reboot both hubs just to be safe.
  5. Backup the old hub and restore to the new one
  6. If you want, you can change back to your old e-mail address by going back to https://my.hubitat.com/hubs

My email address also has "_" in it and C-8 will arrive today.
So how do I do a migration?
Shoud I wait for the hot fix?

THAT WORKED!!!! I had a successful migration and the Zigbee is working. WAF was at an all-time low last night when she got home from work. I thought that changing email addresses might be a workaround but my other email address has a "." in it so wasn't sure if that was going to be a problem too. It wasn't. I went ahead and moved my 3rd hub to new email address without an "_" since I already had 2 of the hubs there. AWESOME!!!

It's only the underscore thats an issue.

1 Like

Having this issue myself. Migrating from C7 to C8. No underscore in my email address.
My email address is very simple though:
2 chars @ 6 chars.us

1 Like

Reset to a different email address. Issue prevails :frowning:
Also, after the restore fails, the backup and restore page just hangs. Have to go into Diagnostics mode and soft reset the C8 each time :angry:

I'm having the same trouble with the restore. No special characters except that my domain is .ca

Download the Hubitat app