C8 locks up at 2am. Requires power cycle. Any help?


Howdy All,
I am Newbie to Hubitat and home automation, so hopefully this is an easy fix.
Hubitat Info:

I have searched and been reading and trying to fix this for 2 days.
It isn't my network. Network controls Hubitat Static IP via DHCP (not Hubitat Static IP setting)

You can see that my network shows it is offline a little after 2 am starting on the 23rd.

Unfortunately, I have been updating the hub to the latest firmware when it shows up, and I didn't save backups often enough:

Error Logs do NOT show any errors.
Error Log just stops getting any information (Text, Event, etc.) at 2 am +/- a few minutes depending upon what text logging and time interval were set at.

Hubitat is unreachable via IPAddress:8081 debug technique. (No screenshot available)

I have been updating ALL of my RM Apps and testing them individually by running actions.
I have removed all Required Conditions that changed any Required Conditions inside the Actions (not that this should matter, but just in case).
There are no Broken Conditions or Unused Conditions in any of my RM Apps.
All Apps function as expected.

Tonight I I will power cycle the Hubitat at 2am, and turn it back on at 2:15 am via an Amazon Plug and Alexa control. I have already added and test an RM App to reinitialize Modes, Variables, and Devices that are essential to RM Apps having the correct starting conditions. I could not find a Reboot Hubitat Condition/State/Event, etc. RM documentation to perform the Reboot in Hubitat automatically, so I had to add this brute force Alexa Reset. I would prefer not to do it this way, so any help would be appreciated.

If this doesn't work, I guess I can try the Soft Reset, but I haven't read enough to be comfortable with all that I would have to do to get my Devices/Apps back up and running. I started this journey the first part of April and have many hours invested at this point.

I appreciate any help I can get. The only experience I have in any sort of Home Automation is what I have learned so far this month.

This is a terrible idea. A sudden power interruption will corrupt the hub's database, especially if the interruption occurs during a db write operation. And your hub may be hanging at 2AM, because that is when automated backups are made, and that process may be getting stuck due to a corrupted database. A soft reset would be a very good idea now.

There is a HTTP POST endpoint to reboot the hub, which you can use via RM.


Let's cut @WardS a little slack.... You're right @aaiyar, and I would also suggest @WardS follow this advice, but let's ease them into the concept of rebooting.... The idea is not terrible, it's an understandable one that we need to encourage people away from....


There is also this great app that makes it easy to schedule. I have my c5 reboot once a week [RELEASE] Hub Rebooter App

Thank you for your comment.

Since I am new, I do not yet know how to do a HTTP POST

I will search the topics to try and learn.

1 Like

Thank you for your response.

I will search topics for adding App Code.

Thank you for your response.

I have disabled the Alexa Routine while I research some of the other comments.

I'd suggesting going the rout of installing the [RELEASE] Hubitat Package Manager (HPM) -- HubitatCommunity

once you do that, most community apps are available there including this one. And that team has done a good job documenting how to add the app code and then search. You get the added benefit of knowing when updates are available for a specific app.


Thanks for the response!

Wow. There is a lot of functionality in HPM.


Another possibility is the router is set for automatic reboot at that time, and the hub has not been assigned a static IP.
Or I could be way off…

Simpler to use the app that @SoundersDude referred to:

May I suggest using the Hub Information driver and creating a device called "Hub Information".
(Thank you @thebearmay for this and to @kahn-hubitat for the idea behind this RM app):
This splendid driver will report back the current amount of free memory, and even has a reboot feature. Th following RM 5.1 app, makes use of these features:

1 Like


Sorry I came off as officious and unfriendly - good on @sburke781 for calling me on that!

But that aside, here's what I perceive. Any computer (and that includes your Hubitat) that reads from and writes to a database is likely to corrupt that database if power is interrupted in the middle of an operation.

So it is best to do a scheduled shutdown, much as one would shutdown a Mac/Windows PC/Linux PC.

For the same reason, a corrupted database adds to the amount of work that needs to be done for backup (because multiple corrupted entries need to be removed). So a Soft Reset is desirable - start with a clean DB. And drop the idea of using a scheduled reboot via a power interruption.

Also FWIW, HTTP POST commands can be sent via RM.


Definitely worth looking into.
Thank you @jtmpush18

Thank you to @aaiyar , @sburke781 , @danabw , @jtmpush18, @SoundersDude , @tom.guelker .

My issue is solved!

I appreciate all the help!


For future people who stumble upon this thread, mind stating (if you know) what solved the issue?


Solved as in you have a safe way to reboot your C-8? Or solved as in there is no more need for nightly reboots?

Because the second is the better goal. There was a time when I had reboot my C-5 every night, but fixing z-wave issues and bad automations eliminated that need.

1 Like

@SoundersDude You are right, I should post what solved my particular issue.
Thank you for reminding me :wink:

My issue Causing the Hub lockup was due to the Hub updating at 2 am with a corrupted database.
My corruption was found in one of my first times using the Clone button in RM.
I did not correctly choose the new Device to Control.
I found this while I was going back reviewing my new vs. old RM 5.1 Apps and I noticed that a Variable was created pointing to my % device% Wrong Device.
I could not find a way to remove this variable inside of the 5.1 App that was created by performing the Clone, so I recreated the cloned App from scratch which removed the Wrong Device.
Overall, I found 2 5.1 Apps that had this issue.

I ended up using the @SoundersDude recommendation for the Hub Rebooter App to be able to Reboot my Hub. I will probably disable the Simple Rule App I made to perform the Reboot (for now), since I do not expect my hub to lock up anymore @aaiyar .

I also installed HPM as it is a very useful tool for installing User Drivers and Apps @SoundersDude

Once I am finished and certain of all my cleanup activities, I will save my settings and perform a Soft reset to have a good clean Hub before I create my next issue as I learn LOL!

Thank you again for all the support and comment!