C7 Z-Wave repair, more failed nodes than not,

Yeah although I'm not sure what I did the first time I installed SS. I think I may have had my UZB-7 attached so it just came up but can't remember. I'm hoping it's part of the Z-Wave SDK package.

1 Like

If I have some time I may try installing it on a spare laptop to see how it behaves.

You can actually install it alongside your old one - that's what I did.

1 Like

That's easier...did you install v4 or v5? That table is hard to read - makes it seem like you have to have v5 for Z-Wave.


Behold the power of the geek:

1 Like

Two instances...how wonderfully confusing. :wink:

1 Like

2 different versions one from the old install and one from SS - even better and more confusing just as it should be!!!

edit: Just wanted to show you that you could have both without impact.

1 Like

Installing SS now (no UZB stick connected) to see how things work.

1 Like

Thanks guys, I got it. I have removed the ghost node using your writeup and I just rebooted my hub and ghost is gone.

Now we will see if my devices start listing correctly. Many have been showing no routes. when I first started adding devices it looked good. Right after install a new device would show it's route. It seemed once the ghost showed up, I started getting devices that seemed to communicate ok, but they don't show their route on the z-wave details page.

Even after sitting overnight they would show nothing. Is that normal maybe because I have more devices now? How long does it take for the routes to show up.

1 Like

Very cool! The routes should just show up within a few minutes BUT some might take longer to adjust than others.

When you rebooted did you pull the power? That's the only way to clear the Z-Wave chipset.

Also have you seen this app - "Hub Mesh Details" by @tony.fleisher? It reformats the Z-Wave details page and lets you sort and filter on things. Super useful..


If you do a full shutdown, pull power, and restart, make sure you pull power from the wall plug side not from the USB connection on the hub. The USB connection on the hub can be a little fragile and repeated pulling and re-inserting it repeatedly can cause problems.


Yes I have the tool installed but it doesn't show the routes either. After removing the ghost and rebooting I had three more ghost nodes. I think that was due to a device I was trying to add today. I had to move the hub right next to a switch to get it to pair. I think my failed attempts may have caused the ghost nodes. All three nodes were able to be removed without hooking the Z-stick back up. Just refresh and remove did it. I am now back to no ghost nodes.

Out of 20 Z-wave devices 8 show no route.

Here is a partial screen shot

1 Like

Here is a screenshot from the mesh tool app you can see them all. I did a full power down and I pulled the USB plug from the wall wart. Some more have filled in so maybe it will get there.

Are the 5 devices that are not showing routing working? Can you control them? What types of Z-Wave of devices are they? Z-Wave, Z-Wave+ or Z-Wave+ with S2?

If things are working and not showing routes I would not be too concerned about it.

Otherwise I've seen devices get stuck in bad routes or ghost routes - the solution was to exclude, reset the device then include again.. which kinda sucks.

Also run a refresh/repair on a few see if they report now that you've removed your ghost..

edit: Sorry one more thing - you might check the list of devices in the PC Controller SW vs what you have in HE.. sometimes ghosts do not show up in HE at all - although this may have changed with the C-7 / new firmware dunno.

1 Like

Ok they are all back. What I found was I had to access the device before it would show a route. Just turned each device on and off with the app and then a route would appear.


Isn’t Tony Fleisher’s (@tony.fleisher’s) mesh tool a great addition to the ecosystem?


Glad you figured that out. Some of the details are not populated unless there is some z-wave traffic from the hub to the devices after they have been included.


Anyone had to do this lately? I had a Iris GDO quit working and I had to remove and re-pair. I figured it was going to leave a ghost node and it did. I tried many times just refreshing and removing as that has worked a few times since I had to do use a z-stick. This node would not go away.

So I broke out the Z-stick and fired up simplicity studio, all seemed to go well, except the Z-stick would never complete it's pairing. It would say it found the device but would never show it finished. On the last attempt it looked like the PC controller showed it connected and the ghost node was listed. So I went ahead and removed it per the procedure. and it worked. I then could not exclude the Z-stick, as it never completed pairing I guess. So I shut it all down and my original ghost node was gone but then I had a new one where the PC controller was listed. I then went through the refresh and remove a few times and HE was able to remove that node. What a PITA.

Halloween is approaching.

It is one of the great mysteries of life. Those who understand ZWave have surely reached a higher level of consciousness.