C7 Update from Z-Wave 7.14 to 7.18 to Migrate to New C-8 Pro

I'm having an issue in updating my C-7 Z-Wave Firmware from 7.14 to 7.18. I've read 3-4 strings of posts on the topic but keep failing, probably missing a step or the right sequence. Here's my sequence so far, and would greatly appreciate any help:

Entered: yourHubIP*/hub/zwaveVersion
Response: VersionReport(zWaveLibraryType:7, zWaveProtocolVersion:7, zWaveProtocolSubVersion:14, firmware0Version:7, firmware0SubVersion:14, hardwareVersion:1, firmwareTargets:1, targetVersions:[[target:1, version:7, subVersion:18]])
Entered: yourHubIP*/hub/advanced/installZipgateway718
Response: already running v7.18.3
Rebooted from the Settings Menu.
After Reboot, went to Settings, Z-Wave Details and pushed Firmware Update button
Response: A quick error window had Failed to Start, and then it was quickly replaced by Z-Wave Updater: ERROR. This firmware target is not upgradable

I’ve tried a couple of different permutations, including pushing the Firmware Update button, then a try to install the Zipgateway718, and then continuing with the firmware update but I still get the same error messages.

Stop. You are on the current version.


Thanks you for your prompt help! I thought that the VersionReport gave the current Z-Wave Firmware version but I guess not. I can proceed now with the migration to the C-8 Pro.

Thats the ZIP/SDK version, he is trying to update the z-wave firmware, which is still on 7.14, not current version.

@MikeW you are not following the instructions correctly. Looks like you missed the first step which is downgrading the zipgateway, reboot, then do Z-wave firmware. THEN update the zipgateway.

May all be irrelevant though, you should be able to just migrate it as-is.

If you are going to give away or sell the old hub though please update it first!

Here are the instructions:


@jtp10181 , thanks for finding my error! I tried the procedure on one of my C-7's and it worked fine:

VersionReport(zWaveLibraryType:7, zWaveProtocolVersion:7, zWaveProtocolSubVersion:18, firmware0Version:7, firmware0SubVersion:18, hardwareVersion:1, firmwareTargets:1, targetVersions:[[target:1, version:7, subVersion:18]])

Seeing the Z-wave Firmware Update button missing in settings confirmed that it's fully updated. I can now migrate to the C-8 Pro without any Z-Wave firmware version compatability concerns.


This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.