C5 Hub Can't be Discovered

I received my new C5 hub directly from Hubitat on Monday and have been unable to locate the hub with the portal or add it to my account. The hub has an IP address and the diagnostic tool works. The light on the unit remains blue, and has been blue for 24 hours. I have a modern ASUS AC1300 router, but I also tried plugging the hub into an old base 100 hub to see if it was a negotiation issue and that didn't help.

I think this thing is a brick after reading the forum, and I don't see how I'm able to return or replace this thing since I didn't buy it from Amazon. I received an automated message from support yesterday and haven't received a human response yet. I'm sure support is overloaded, but it's incredibly frustrating to have a device that basically doesn't boot.

I tried accessing the menu to manually set the port speed on the hub, but I get a 404 error instead of the menu mentioned in the community. I also don't see how the hub can automatically download updates if the light never turns green. Any help is appreciated!

I suspect a known issue tagging @aaiyar and @bcopeland hopefully one of them pipe in soon. This can be fixed.

1 Like

A blue LED on a C-5 means it's trying to load the Platform OS. It then switches to Green.

If Green never shows up, it's because the platform OS isn't working. A handful of Hubs left the factory with a bad format and there's a method to recovering. I've sent @jckrieger a PM with details.

For everyone else, realize this process is 2 steps... erase everything off the hub, so as to get the format back to correct. THEN the hub will go fetch the latest Platform OS. This is the same as when we do normal platform updates EXCEPT the progress messages are invisible. This practically insures that anyone doing this will think the hub is dead, doing nothing, and will try to power cycle or something equally serious. Encourage people doing this process to WAIT. It will work, if you give it at least 20 mins before 'helping' :smiley:


Thank you for piping in. Just what I suspected, but I'm not comfortable with making that call. I'll leave that up to you.

1 Like

I've performed the factory reset, but there was no progress indicator. Instead, it said the reset was complete after only one or two seconds. The light on the hub has been blue for about 20 minutes since the reset. I'll let it go another 30 minutes or so before I attempt a power cycle.

It's been several weeks since I tried the method on one of my Development hubs, and I didn't realize I needed to memorize very nuance. :slight_smile:

But after that first step, which I do remember was very quick, you DO have to power cycle. It's after THAT when it feels like it's doing nothing.

Step 2 is: Once the factory recovery is completed, please unplug the hub for 30 seconds.

It's during that power up cycle, it discovers there's no Platform OS and goes and gets one... invisibly.

1 Like

I'm running the process again now.. hopefully I document it well THIS time :slight_smile:

It starts here:

Screen Shot 2020-05-19 at 1.40.06 PM

You click the button and you get this for under a minute:

Screen Shot 2020-05-19 at 1.37.12 PM

Screen Shot 2020-05-19 at 1.37.26 PM

After which, it returns to :
Screen Shot 2020-05-19 at 1.37.50 PM

Step one is done, time for...

Step Two, power cycle - 30 seconds.

I'm at the Blue LED so far...

The Diagnostic Menu shows and it has the new option:
Screen Shot 2020-05-19 at 1.42.54 PM

After a very harrowing wait, the Green light came on and I got the Recovery Screen.

Screen Shot 2020-05-19 at 1.56.06 PM

For me, because I started with a working hub and had taken a backup seconds before starting this, I started the Restore from Backup option... For someone just receiving the Hub, this is the End of the method. Click the Get Started and you're at the exact same place you would have been if the original format error had not occurred. :smiley:

1 Like

This hub must be DOA. After the factory recovery and a reboot, I never received a green light. An hour later I tried the "download latest version". Another hour later and still no green light and the platform version is still blank.

So, after just about giving up, and being frustrated the formal email support hadn't responded, I decided to start mashing buttons. It bothered me that there wasn't a platform version shown, even though I had clicked the button to update the platform and it showed a success popup window. I had power cycled the unit and waited for hours, and it never downloaded the platform. So in frustration, I hit the download latest button a few times, then reboot, then shut down. Both the reboot and shutdown buttons yielded a 404 error, so I decided to see if the hub had a red light on it and it was green! The diagnostic screen was also showing a platform version! Success!

So, it appears my unit refused to download the platform on its own. A factory reset didn't allow the hub to download the platform automatically, and a single press of the download latest button also failed to resolve the issue. However, frustration (and repeated applications of the download latest button) finally caused the device to download the latest platform and begin functioning.

I can't explain it, but damn, this thing was a mess to setup. The pop-up success windows seem to be nonsense, as they provide no indication on whether the action was actually a success. This confuses the user since repeated applications of the same button can yield different results.

1 Like

Glad to hear that you were able to get started. We are aware that a small number of users may experience this problem when setting up a new hub, and are actively investigating the root cause. This is certainly not the first impression we would like our users to have when registering their hubs. We are very sorry for the inconvenience that this may have caused to you or your family.

Please let us know here in the community or via email at support@hubitat.com if you have any further questions or concerns. You can also send me a private message, if you run into any more problems.

1 Like

Hi, I have a similar problem. After trying a number of things I have had no success. I have a brand new hub, just arrived yesterday, can't get past the blue light. I can get to the diagnostics menu.

I tried a full factory reset, and that did something. It eventually went to a red light, and afterwards the diagnostics page shows the option to restore previous version rather than download new version. I assume that is progress.

I have tried doing a soft reset or reboot, and I get a 401 in both cases and no change in status on the device.

Is there a specific set of instructions for getting out of this situation? This is pretty frustrating.

Make sure you try the LOGOUT feature in the diagnostics menu, then try again. I have seen a similar issue due to the browser thinking it is still logged into the diagnostics menu.

Thanks, I just discovered that. I did another full reset, now it shows blue but I can no longer get to the diagnostics menu. Should I leave it for a couple hours? Unplug again?

Did you follow the steps I documented above?

It worked yesterday for me to capture those screen shots and eventually @jckrieger got through it too.

One additional hint I'll give is that the menu item that only appears when there is no Platform OS:

Download Latest Version

Only triggers a download. The hub shows the menu in a second or two. All it's done is set the "download the OS" flag and done. If the download is already running, I assume that the flag is already set, so clicking it does nothing. IF not, of course, it sets it and some other process is started to do the actual download.

It's purely a guess on my part having run this method twice :smiley: (Lot of experience, right? :smiley: )

Yes, sort of, but what I am seeing is different than what is in the steps you outlined, so I am trying to do equivalent things. I don't have the option to download a new OS, it does show an OS version, and after numerous time unplugging and waiting more than 30 seconds it doesn't seem to make a difference. I've been running the browser debugging tools so I can see the diagnostics UI sending requests and getting responses, it just never gets booted up to where it's happy. At this point I guess I need to wait for support to get back to me.

Thanks for the help!

This means you have a Platform OS on the hub.

If you start at the top, again, the very first step erases the Platform OS, and everything else.

Power cycling causes the hub to discover the 'empty' Platform OS and will automatically start downloading, verifying, and then Installing it.. followed by an automatic reboot.

How do you get to this Factory Recovery screen?

It's been hidden to prevent frustrated clicks. :slight_smile:

The one time it's needed: You're selling the hub to someone else.

The equivalent can be done by menu option that are visible. You can so a Soft Reset (and not restore a backup,) followed by a reset of the two radios.

Screen Shot 2022-01-04 at 12.49.01 PM


In addition, the FULL RESET option removes the hub’s registration from the Hubitat Cloud server, IIRC.

@johnday29 - if you truly believe you need to perform a FULL RESET, I’d suggest you send a private message to @bobbyD from Hubitat Support.