C-7 constantly going offline

Hello everyone,

my C7 hub keeps going offline within the hour it turned on. I can't recall when it started happening, but I know I didn't change any HE settings, only updated firmware (not sure if it was before or after). I recently changed my ISP plan and got Huawei HG8145V5 which the hub is directly connected to. I was thinking, maybe it is something with the router and it's IP assigning, but don't know. The hub has DHCP Static IP set on the router.
To turn the hub on, I have to unplug and replug it from the power. When the hub is offline, it is inaccessible from the pc browser on the same LAN, it's IP doesn't appear when network scanning, in router gui it says device offline, hub's green led is still on.
I have read a couple of older posts, didn't help.
Maybe it is something with the new ISP network device, i didn't have this problem before, but if it is, I don't know how to solve it.

Things I've tried:

  • changing the ethernet cable
  • reboot + rebuild database + load backup
  • can't reach port 8081 when offline
  • nothing in the logs
  • turning DHCP Static IP off
  • Switching to static IP thru Hubitat (no cloud connection)
  • holding the button on the hub does nothing while offline
  • Ethernet speed is set to 100 fixed
  • safe mode
  • soft reset (default settings, no apps, no devices, no rules)

What I haven't tried:

  • add a switch and connect to it (don't have a spare switch)

Platform version:

Help please?

Change speed to auto.

Are you running jumbo frames?

Are you using the OEM power supply?

Since you have a green light you may want to set up a rule to be notified of an IP Address change too. Shouldn’t normally happen if you’re using a DHCP reservation or a Static IP but….

If you are using a Static IP is it out of the DHCP range? If not you may be getting an address conflict from another device.

1 Like

I would try using the rebooter app and hard reset it daily. The issue might be a memory leak that might be locking up the hub.

The last big change is often the best suspect...have you confirmed that the router IP reservation for the hub is outside your DHCP range?

There is a new platform version, - you should update to that version so you're on the latest.

After you update your hub, there is a network reset button on the bottom of the hub...under the one round hole. Press that button for 7-10s and the hubs network settings will be reset to default and the hub will reboot.

Ok, I will change Ethernet speed to auto.

How do i check if I am running jumbo frames? Haven't seen that option anywhere.

Yes, I am using the provided power brick and charging cable.

Check your router and all your hard wired lan devices. Your mtu needs to be 1500 or below.

As noted it's an option on routers, access points (APs), or switches - if you aren't familiar with MTU settings and haven't changed settings on your networking gear it's probably not an issue for you. If you have or can download the user manual for your router you can search in it for MTU settings - if MTU is greater than 1500 on it or other networking devices then that can cause disconnect problems the HE hub.

How can I set up a rule like that? I don't see that option when creating a rule using the default app Basic Rules.

No, the reserved DHCP Static IP address for the hub is not outside the address pool range and there is no address conflict.

@thebearmay has a cool driver that allows you to monitor your hub info, including IP address. Once you install and setup his driver (create a virtual device using his driver) you can then create automations based on the states it tracks...i.e., a rule that says if ip address changes, send notification to me/turn a light red, etc.

It is very cool, and it's available in HPM:

1 Like

OK, after power reset, soft reset and network reset, I installed HPM and Hub Information Driver and just when I wanted to apply the new rule, it went down (lasted 38 min).
Power reset again, created a rule once again and applied. Now waiting.
How can I set up a rule to reboot the hub when it's IP changes? I went through the provided actions but can't find how to reboot or restart the hub.

The hub went down and I didn't receive the notification for the IP change.

Hub Information Driver v3 has a couple of reboot options that can be used, just make sure to turn the Allow Reboot or Shutdown preference on and save.

1 Like

What does your notification rule look like>

1 Like

I just enabled shutdown or rebooted option on the Driver but don't know how to add it as an action in the rule.

The reboot will be under Custom Actions in RM. What sort of device is OnePlus 8 Pro?

1 Like

OnePlus 8 Pro is my phone with Hubitat app installed.

Am I looking at the correct location for the custom action?


1 Like

Is rebootW_Rebuild for rebuilding the database from backup after reboot? Should I use that instead? And what about parameter type?

I would not set that up to run reboot/rebuild every time...I'd have the normal reboot in the rule, and use the reboot w/rebuild option when you do a reboot manually.

1 Like

Doesn't need a parameter; normally don't need to rebuild the database, but there if you want to use it.