Bug? Scenes not listing newly added devices

Since the last update, scenes do not show any newly added devices to add to an already existing scene. Groups show the new devices, but not scenes.

Edit: also renaming a device does not show the new name in the list of devices in a scene.

Doing something wrong or a bug?

Another edit: I rebooted the hub, waited 5-10 minutes and it seems everything works now. Leaving this message here in case others see the same thing. Apparently, it just takes a while for things to trickle through.

Just wanted to say that a manual fix to this issue that also worked for me was suggested in the below post:

What do you mean by "this issue"? Where does the "newly added device" "not show"?

It happens to me also. A new device does not show so that it can be selected in a scene, and in some of the other apps like Alexa. You have to go in and out a few times, or reboot the Hubitat and then it appears.

OK, thanks. I know what the issue is, and will work out a fix for it.

In the meantime, the way around the problem is to open the Scene, and then hit Done. The next time you open it, the new device should show up.

1 Like

A post was split to a new topic: Scene Timing Inconsistent

I'm seeing a similar issue, except that no devices in the scene are selected in the dropdown menu. That is, when i go into a scene to edit it, the dropdown menus have no items selected in them. Not sure what to do with that...Hitting "Done" as suggested here doesn't populate them the next time into the scene.

@bravanel seems like this issue is still occurring, and I am currently on the latest version. Is this on the "to-do list" of bug fixes? Thank you.

Ah, 2 months is an eternity around here. I'll take a look.

1 Like

Four months, but who is counting?

:grin: :nerd_face:

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.