[Broken] MyQ Lite Application

I'm too having the same login credentials issue like some of the people posted previously. Any idea if we have a fix yet? TIA.

Same here no joy. tried changing app code per above but same issue with logging in/ wrong PW...

I'm not sure what that means....Do I need to remove a device driver?

  1. Go to the main hubtat page http://your ip address here

  2. Click Apps Code on left menu (may need to scroll a bit)

  3. Scroll down to MyQ Lite then click on the link

  4. Scroll down to (or around) line 1035. What's in the "User-Agent" parameter

OK. So my User-Agent was "User-Agent": "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:109.0) Gecko/20100101 Firefox/117.0"

I changed it to "null" as suggested in both places, re-ran the app, entered my credentials and got the same error about invalid username/password.




Checking the log, the only thing that came up was the "Cannot invoke method getAt() on null object" again.

The login issue is happening on other platforms and seems to be intentional. Scroll down for the bad news.

It may be time to setup the local MyQ Local Control Options for MyQ Garage Door Openers

1 Like

Thank you for confirming. I just switched out my openers this week to MyQ. I used to use a Zen16 relay to control my old openers and took it out as it won't work with the newer Security+ 2.0 openers. Will need to grab some simple Security+ push buttons like the 883LMW and wire up the Zen16 to them. Should work.

There is a Python logon fix posted at the github link below, but it's beyond my understanding. Anyone here able to translate this into the HE MyQ app?
Scroll down to the post by "drysart" for the code fix

I contacted the Home Assistant developer and was told his most recent fix was just broken by MyQ.

MyQ/Chamberlain seems obsessed with removing all non sanctioned aka non paying apps from their system.

Time for me to get this local.

1 Like

I wish I had more to offer here but wanted to give some major props for keeping this running as long as it has been. Super impressive. Dealing with MyQ is a never-ending battle, but there just aren't many other great alternatives.


Knock on wood mine is still working. No errors never worked any better than it has in the past months. :crossed_fingers:
My biggest complaint about locally run is the notifications of the door closing before it closes is a royal pain. I'm set up locally when this does break and I do have a notification that's somewhat works, but that's my biggest complaint.

1 Like

Typically this is easy to fix by changing the panel that the tilt sensor (or contact sensor) of attached to.

Hard to know whether that’ll work for your installation without photos,

1 Like

Thanks. If you look how the garage door works with my q. It flashes and beeps before the door actually starts moving. The sensor to detects the door open and closed fine. However with the external button push the door starts moving right away. I use an alarm device and flasher application that allows me to flash the lights in the garage and sound to the alarm it works okay. Not as well as the garage door itself.

Garage door local options


I spent some time yesterday deleting the old driver and app and installing this package via the package manager. The device reports the battery and all activity correctly, but I can't perform any activities on the door. I press open or close in the device and nothing happens (I also don't see anything in the log to indicate an attempted activity). Is this to be expected? Or did I misread the previous posts and this package will definitely no longer work?

Did you rename your door in Hubitat? I had that issue when I changed the name in Hubitat (Overhead Garage Door) whereas logging into the MyQ app had it as "Garage Door". When they matched, it worked, when I renamed it, they stopped working. I just changed the name in MyQ app to match Hubitat, and all was good again.

@ lpakula Thanks, that is a good though t - I have since made them the same.

I may have missed an error before after all. I am seeing these in the device logs:

MissingMethodExceptionNoStack: No signature of method: user_driver_brbeaird_MyQ_Garage_Door_Opener_832.parse() is applicable for argument types

What is it saying after "argument types". Looks like something is missing in the parse() code

@lpakula Thanks for the reply! Here is the entire error:

org.codehaus.groovy.runtime.metaclass.MissingMethodExceptionNoStack: No signature of method: user_driver_brbeaird_MyQ_Garage_Door_Opener_832.parse() is applicable for argument types: (java.lang.String) values: [zw device: 11, command: 6603, payload: FD , isMulticast: false]
Possible solutions: close(), push(), main(java.lang.String), use([Ljava.lang.Object;), wait(), run() (method parse)

Looks like a zwave device that cannot be parsed. What are you linking that is zwave to this app? Is that the door sensor?