[Broken] MyQ Lite Application

Ooh, good answer. I always forget about that scenario.


Yeah, I think it’s time I got contact sensors, the two accounts thing is set up correctly but one or the other door is always missing events with the two accounts, whereas it was very reliable when all four applets were under one account. I’m just opposed to buying an extra piece of kit to do what the garage door already does (know when it’s open) — but I’m gonna have to concede this battle for my own sanity.


Over the last 48 hours, my MyQ app has stopped working.
I can no longer open/close the garage through the MyQ Lite application.

I have tried reauthenticating with my username and password, and I get an error stating:

"The username or password you entered is incorrect. Go back and try again. "

I can confirm that my hub has internet access, that the MyQ android app has connected; I can also verify that changing my password for the MyQ app didn't resolve the problem either.

Anyone else running into this problem?

1 Like

It is also happening on the ST platform so MyQ most likely made a change. The developers will probably be able to figure it out and update the app.


For me as well on ST and Hubitat, door say's its opening but doesn't. Works via MyQ app though

MyQ has changed their authentication in v6 of their unofficial API. The HomeBridge MyQ integration was updated about a week ago to accommodate this change, and here's what the release notes say:

"Starting with v6 of the myQ API, myQ now uses OAuth 2.0 + PKCE to authenticate users and provide access tokens for future API calls. In order to successfully use the API, we need to first authenticate to the myQ API using OAuth, get the access token, and use that for future API calls".

This is very different from authentication in v5 of the MyQ API. @dman2306 has many integrations with complex authentication (eg. LG), so I am hopeful he will be able to change his MyQ app to accommodate changes in their API.


Correct. v6 of their unofficial API is now in use.

1 Like

Hoping we can get a speedy fix here, I have zero door control.

1 Like

Well this is the second time this has happened.

Didn’t realize it was broken before reading it on here first.


I am taking this opportunity to (finally) wire in the Zooz Zen17 relay I got to do this. I knew this day was coming where MyQ would stop working. If even only temporarily.

My advice for everyone is to use a Zigbee or Zwave relay and completely bypass MyQ. Keep the control within your hub. @aaiyar posted about some inexpensive Zigbee relays a month or two ago for those who want Zigbee, or are on a budget.


I'm really lovin' my Z17 out in garage - I have 2 hard-wired (dumb) reed sensors on it (one for fully closed, one for fully open), and one of the relays is set up as the opener "button" (I'm not using the 2nd relay). It all works great!

We rarely use the relay opener, but it's definitely a nice emergency backup option. Rules involving both contact sensors give me confidence that the door is always in the desired position (and not stuck in between for any reason). I like hardwired position sensors since it's a detached garage up here in MN, and I avoid battery-powered stuff as much as I can in unconditioned space like that.


27 posts were merged into an existing topic: Local Control Options for MyQ Garage Door Openers

Can you provide the details of HOW you wired everything? (Maybe a pic would be nice ;-)) Was this done at the opener or the controller? Will one Z17 work for 2 doors, or do you need 2 controllers (suspect so).

I have my two dumb reed sensors (full-open & full-closed) wired in at S1/C and S2/C respectively. The wires connecting to the GDO for actuation are at Relay 1's NO slot (red wire) and C slot (white wire). My GDO is super basic - no Security-2.0+ or whatever that stuff is.

I just have one door, so I'm not using Relay 2 for anything. Depending on how you want to integrate door position sensors, you could absolutely use the 2nd relay for a 2nd GDO.

The reason I like Z17 (vs Z16) is that the 2 sensor connections can be used totally independently from the 2 relays - that's not possible with the Z16. Other than being managed from the same Z17 device, my sensors have nothing at all to do with my relay.

My dashboard setup is pretty ghetto due to my own laziness, but it works for me...

I have a dashboard button for the relay that simulates the physical wall switch or remote button. I programmed the door's relay to go auto-off after one second, so although it's not a momentary button per se, it acts just like it in reality.

I have tiles for each of the 2 dumb reed sensors that confirm if each is open or fully closed. If both show open (hasn't happened yet - knock on wood!), then I know I have a problem with the door being stuck.

The main win for me is associated rules - I have rules that monitor the door operation - when one contact sensor opens, it waits 18" to confirm that the other sensor closes. If not, I get an alert. If the closed-door sensor is not closed when mode goes to "away" I get an alert. Etc etc... Not all of that is unique to my setup, but I really like having confirmation that the door position is exactly correct. For most folks, a simple tilt sensor does fine for monitoring position, but I wanted more robustness than that.

ETA - a bit more on the GDO connection... I used 18-2 t-stat wire for all of my LV connections (reed sensors and Z17->GDO relay) since I had a bunch laying around from a diff project. Using a 3-port Wago lever nut, I connected the wall switch's (exising) red wire to my (new) red wire from the Z17 relay and then pigtailed a single (new) red wire down the the proper connection point on the GDO itself. Same thing with all the corresponding white wires. That just made for cleaner & saner-to-deal-with connections at the GDO unit.


Just noticed it was down today myself. Darn. Such a hassle. Here's to hoping it's fixed soon!

you know, on the note of the MyQ not working with HE right now due to API changes (I hope that it gets fixed and updated soon) I noticed that my MyQ app has on several occasions asked me for a new Password several times over the last week or so.

not only did they mess up the HE , they messed up their own app.

Well I went and got a remote on order from Amazon for my 3 8500W. I'm hoping that I can do the solder trick with those. I have a feeling this is not going to be fixed anytime soon. Such a bummer

wow, i was wondering why my quit working. Hope we have a fix soon..

Until a coule of days ago, MyQ Lite worked perfectly. All of a sudden, it no longer does. Anybody have a clue? Thanks.

Read up about 5-6 posts?