Bond Integration

Installed the bond integration app. It found my two bond devices no problem. I’m using the bond devices to control ceiling fans and lights. The integration app found the devices controlled by the bond devices and set them up as child devices. However, nothing works. A look at the logs shows lots of errors and warnings. Tried reinstalling with same results. Any idea what’s wrong?

@jim.seago I'd read and post in this thread and tag bcopeland

1 Like

Can you post the errors?

1 Like

My installed the fan as a Device but I'm getting below in the logs and nothing is working.
java.lang.NullPointerException: Cannot invoke method getAt() on null object on line 323 (method gotDeviceState)

Hit configure on the bond bridge device .. Looks like it missed something..

I have Bond with Allen and Roth shades. All is somewhat ok. The bond hub is seen, the shades are seen. The open and closed work and go to the respective stop points as programmed by the shade remotes.
In Hubitat - under the devices we only have OPEN and CLOSED working. I get full open and full closes as my only 2 states. Entering ( 25 ) doesn’t get anything and when I add a button to a dashboard, it shows a shade slider but that again does nothing ( it moves, but shade doesn’t ) and pressing the button gets me full open or full closed with no ability to stop.
Ultimately I would like closed at sunrise and open to a % later during summer and opposite during winter, but got to get the % open / closed working first.

I’ll check into that.. Do you get any error logs when this happens?

Bond Bridge (working fine with community integration) installed with new integration, and "Configure" gives me this:

Screenshot 2022-06-10 at 12-48-47 Logs

The integration app "Bond Device to Add" dropdown is empty.

That looks like you are missing the local token @jwjr

I have a fan with 6 speeds that gives me this exact error. If I remove speed 4, 5 and 6 from the bond app for this fan then it 'works' as expected....without those extra speeds of course.

I see the problem.. will fix that

1 Like

6-speed control will work properly in the next hotfix..


Is there any guidance on how or if to switch from the drivers and devices installed with the "BOND Home Integration by Dominick Meglio" user app? I have a whole bunch of automations, rules, etc. linked to the devices installed with this user app. Not sure if installing the now native "BOND Integration" app will be worth the headache of reprograming all of those.

That is totally up to you.. You are under no obligation to switch to built-in if you are happy with what you have..

Now you can try it out, no risk, as both can be operational at the same time..


New integration working great with one odd exception on my older 3-speed Minka fan with a built-in light.

3 speeds work great, and light turns on/off fine from Device page, but I've long used a Pico button to "Toggle" the light -- one Pico press turns the light on fine, but the next press does nothing...

I also tried turning light on via Bond app and then using the Pico "toggle" to attempt turning off, but light stayed on...

It appears the Toggle's Off command never actually gets sent (but On always does -- see logs below)... Any ideas? Thanks!!

This Pico was previously working fine with the community integration (and I just swapped backed to it to check again - worked fine), so I know the Pico and Toggle Button Rule aren't whacko.

ETA -- No idea if this is somehow related, but how would I add the light as a dashboard tile (just as a basic on/off switch)?

I can add the fan-control tile and that works great, but when I try to add a second tile for the light status, nothing works - I'v etried switch, relay, bulb, dimmer. Thoughts?

I can confirm that all 6 speeds (plus off) and light on and off all work now.

Any chance of getting support for the reverse direction button? Lots of newer DC ceiling fans have that button on the remote instead of a switch on the fan motor.


1 Like

I am looking at this as it had been requested by many people..


I'm looking at other ways to control the fan light and am striking out...

The only way to control the light is from the fan's child device page - the On & Off buttons circled below work great to turn the light on/off.

But nothing else works to control the light - dashboard, RM or Button Controller...

I tried to create a "if on then off, else if off then on" rule as a makeshift toggle command, but this is what my conditions box looks like, so obviously the rule can't work.

Am I just missing something ridiculously obvious about how to control the light or is there something amiss with how the integration opens up & communicates the light status with other HE tools? Thanks again!

Are you able to select all 6 speeds in the set speed attribute as mine does not include “very-low”?
@bcopeland - I noted this in my post on the other thread also, but here is a screen shot of what I am seeing if that helps. Thanks.

Apparently I can't count. Very-Low is missing in the dropdown for me too, even though it says it's supported...

1 Like