[Beta] [Release] Ikea Styrbar

I got this remote working with a driver I previously used for another button device.
It seems pretty responsive and works as expected. I have only had it for a few days, so I don't know anything about battery yet.

I got the bare minimum working.
Push works on all buttons.
Hold and release works reliably with Dim up and down buttons, but left and right spews a lot of stuff out I need to comb through.
That and battery isn't working as expected. I really want to get this working properly but time isn't on my side.
Feel free to use this driver any way you like, but if you modify, please share with the rest of us :).


I like IKEA’s buttons for their design, their quality and their price, but their battery life is simply unreliable.

My last try was with the shortcut button, which has really great design, size and form factor, but eats batteries every month and a half, !!!???

Their Sonos volume remote works great as a dimmer, but I have substituted every one I had, once their battery was consumed. Curiously enough I have the last one still running with the battery lasting almost a year. I do not understand a thing there.

I hope you have a good experience with this one and it’s battery consumption. And if it is the case, I will again try.

Thanks for developing this driver!

One Ikea button I really like is the 5 button remote. That just feels so nice and, with 5 buttons, whats not to like.

This seemed like a nice replacement to the 5 button, but it just feels way cheaper and clicky compared to the 5 button.

I have it connected to hubitat, but not in use yet. But I will see how long the battery works, and report back.

1 Like

Thank you for putting together the driver. I have a few Styrbars and I am excited at the possibility of using them with Hubitat. I have installed and run the driver, but I am having trouble getting it work. I can see the 4 buttons and configuration seems ok on devices but unable to add it to dashboard. I am running also home bridge v2 and I can expose it ok, but it looks like the device is not updating.

Any help much appreciated,

Hey everyone,

just a short question. How good is the battery life of these devices, The shortcut button for example caused me a lot of problems with battery drain. How is your experience so far?

Hi All,

I brought one of these home today on speculation that I might be able to get it working. I've loaded the driver but haven't been able to get it to pair yet. I put in fresh AAAs and put the hub in Zigbee pairing mode, then held the pairing button behind the battery cover for 10-15 seconds. I'm not seeing any lights on the device and the hub does not report seeing any devices before the end of the pairing cycle.

Any tips? Should I be seeing the LED on the device blink or change colors? Wondering if maybe my stash of fresh AAAs has gone stale...

Appreciate any thoughts!

Resolved this part of my issue on my own. Thought I'd report back here in case it helps anyone else in the future. I eventually paired the device with my Hubitat by pushing the pairing button four times in rapid succession, rather than by holding the button down for 10 seconds as indicated in the manual. What worked for me was to begin device discovery on the hub and then complete the four presses. At that time the red light on the device blinks twice slowly and then three times quickly. The Hubitat discovers a device and correctly identifies it by fingerprint as an IKEA Styrbar with capacity for four buttons.

Still though, I cannot get the button presses on the device to show up in the logs. I tried a few things but it just seems to be dead-stick. I'm going to take one of the two devices (I bought a 2nd one to rule-out hardware failure) with me to work this morning, where I have a Home Assistant installation, to play a little further.

@akafester @ruicvloureiro @Vincent_The_Staat @BiGs - Has anyone on this thread successfully used this device - either by pairing directly with Hubitat or through some other kind of integration?


Not me, but it sounds as if the device has gone into sleep mode, the batteries consumed or it is out of Zigbee range.

I would re-discover it.

I've got three of those now, paired directly to Hubitat. All events are shown in my logs (see picture). Did you enable logging?

I swear I did have...

...but now it just works:

dev:17302022-08-15 18:01:53.315 infoButton 3 pushed - Right button
dev:17302022-08-15 18:01:53.311 debugCatchall: 1, 5, 7, [0, 1, 13, 0]
dev:17302022-08-15 18:01:53.308 debugcatchall: 0104 0005 01 01 0040 00 9DEE 01 01 117C 07 00 00010D00
dev:17302022-08-15 18:01:53.305 debugParse returned [:]
dev:17302022-08-15 18:01:53.302 debugParse description catchall: 0104 0005 01 01 0040 00 9DEE 01 01 117C 07 00 00010D00
dev:17302022-08-15 18:01:51.615 infoButton 2 pushed - Left button
dev:17302022-08-15 18:01:51.611 debugCatchall: 1, 5, 7, [1, 1, 13, 0]
dev:17302022-08-15 18:01:51.608 debugcatchall: 0104 0005 01 01 0040 00 9DEE 01 01 117C 07 00 01010D00
dev:17302022-08-15 18:01:51.605 debugParse returned [:]
dev:17302022-08-15 18:01:51.602 debugParse description catchall: 0104 0005 01 01 0040 00 9DEE 01 01 117C 07 00 01010D00
dev:17302022-08-15 18:01:50.063 infoButton 4 pushed - Bottom button
dev:17302022-08-15 18:01:50.060 debugCatchall: 1, 6, 0, []
dev:17302022-08-15 18:01:50.057 debugcatchall: 0104 0006 01 01 0040 00 9DEE 01 00 0000 00 00 
dev:17302022-08-15 18:01:50.053 debugParse returned [:]
dev:17302022-08-15 18:01:50.050 debugParse description catchall: 0104 0006 01 01 0040 00 9DEE 01 00 0000 00 00 
dev:17302022-08-15 18:01:47.158 infoButton 1 pushed - Top button
dev:17302022-08-15 18:01:47.155 debugCatchall: 1, 6, 1, []
dev:17302022-08-15 18:01:47.138 debugcatchall: 0104 0006 01 01 0040 00 9DEE 01 00 0000 01 00 
dev:17302022-08-15 18:01:47.134 debugParse returned [:]
dev:17302022-08-15 18:01:47.131 debugParse description catchall: 0104 0006 01 01 0040 00 9DEE 01 00 0000 01 00 

Happens sometimes. Glad it works now. :slightly_smiling_face:

1 Like

In case that can help someone: I had a similar issue to @dewhite04, no problem registering the device, but no events were sent pressing the buttons. After quite a few fruitless resets/reconnects, what finally worked for me was to pair the device while being close to the hub. So thanks @Vincent_The_Staat , another happy user of your driver :slight_smile:

1 Like

Button 1 and 4 press, held, release are working perfectly. For 2 and 3, only press is working, when holding 2 or 3, it register as button 1 presses instead. anyone having the same issue?

I found the problem. For some reason my device is sending a different message when holding the buttons. Here is my revised hold script, i've added msg.data for button 1 & 4 hold. And changed the clusterId for button 2 & 3.

For some reason, the catchall strings for button 2 & button 3 hold are identical, any idea how to distinguish them?

Model number on the back of the device is E2002, not sure if that helps.

		//-------------------------------Hold commands--------------------------------//
        } else if (msg.clusterId == 8 && msg.command == 05 && msg.data == [0, 83]) {
            def button = 1
            atomicState.releaseButton = 1
			if (txtEnable) log.info "Button $button held - Top button"
            map.name = "Button $button held"
	    } else if (msg.clusterId == 5 && msg.command == 9 && msg.data == [0, 0]) {
            def button = 2
            atomicState.releaseButton = 2
			if (txtEnable) log.info "Button $button held - Left button"
            map.name = "Button $button held"
        } else if (msg.clusterId == 5 && msg.command == 9 && msg.data == [0, 0]) {
            def button = 3
            atomicState.releaseButton = 3
			if (txtEnable) log.info "Button $button held - Right button"
            map.name = "Button $button held"
	    } else if (msg.clusterId == 8 && msg.command == 01 && msg.data == [1, 83, 0, 0]) {
            def button = 4
            atomicState.releaseButton = 4
			if (txtEnable) log.info "Button $button held - Bottom button"
            map.name = "Button $button held"

It appears the new styrbar firmware version breaks this driver. I posted about it here. IKEA STYRBAR pairing issues

I'm not expereinced enough to make a revised driver, but I'm going to give it a go slowly, unless someonce can point me to the issues?

The new fingerprint info is

infofingerprint profileId:"0104", endpointId:"01", inClusters:"0000,0001,0003,0020,1000,FC57,FC7C", outClusters:"0003,0005,0006,0008,0019,1000", model:"Remote Control N2", manufacturer:"IKEA of Sweden"

Any thoughts or similar experiences?

1 Like

I just bought one and updated akafester code to resolve left and right buttons not reporting properly.

Code can be found on:


There was a further FW update for Stryvar which broke the fix for the side buttons. I'm back to the OG driver for now.

Do you know what firmware you;re on now/broke the driver code fix?

I'm curious if your driver is still working for you. When I switch the driver from the OPs original driver to your driver, I'm unable to get the buttons to register any pushes. To confirm, I did click the configure button in the settings to initialize it. Could I be missing another step?

My firmware appears to be the older one, 117C-11CB-00010024, so I was hoping it would work.

I just saw your comment and tested my devices and they all work (I tested all buttons).

Here is my driver information (which is same as yours):
endpointId: 01
application: 01
firmwareMT: 117C-11CB-00010024
manufacturer: IKEA of Sweden
model: Remote Control N2
softwareBuild: 00010024

The driver is type User, Name: Ikea Styrbar

You might want to put the device in "Enable debug logging" to see what is happening as you press buttons. When you are using my driver and having debug on, you will see various "parse" and "cluster" messages.

Good Luck.