[BETA] ratgdo driver (w/ MQTT firmware)

I did publish commands from the explorer. nothing happened.

I would think if it was a wiring issue the physical buttons and obstruction sensor wouldn't work since they go through the ratdgo now.

Your wiring looks ok. Mine has two obstruction sensors cables and the button, but that shouldn't prevent the door from opening via the soft button in Hubitat. Try restarting your MQTT node, then the ratdgo and finally the Hubitat. Your Current States looks like it might be missing some detail compared to mine (but it could be what your opener supports).

that didnt change anything. i do see those states changing in the explorer

would it be safe to assume that if the physical button and the obstruction sensor work correctly that it is wired correctly.

does it make a difference that the missing states are located under homeassistant?

Details from my MQTT Explorer sesssion:

The lower half of my ratgdo page:

Config looks good, guessing it’s a device or wiring issue. If the mqtt commands don’t work, the problem isn’t with the driver.

I have a second device. I just plugged it in and configured it and i get the same results. this one is not wired to a door yet.

im using this process to flash


Not sure what you mean by the same results since your problem is that MQTT commands are not triggering the door to open. How can you tell with the second one since it’s not wired?

To be clear, you have to do this on a wired ratgdo and confirm your door opens:

publish in MQTT Explorer

topic: ratgdo/ratgdo-8229/command/door the message open (RAW)

Replace ratgdo-8229`` with your device name (Device Name & Web Config Username``` in the ratgdo web UI)

Verify that the MQTT Topic Prefix is set to ratgdo/

Then send the command open. Does the door open?

I connected the second device and i stlll get the same results. i doubt its a bad board.

Does your garage opener have a yellow button?

1 Like

Looks red from his photo.

This is the statement I keep coming back to. Was there anything you changed after it worked the one time?

What are you running your MQTT server on?
What does your ratgdo server page look like?

There is no screenshot of the full server page but isn’t red , security 1.0? I wonder if that’s set correctly.

Here it is. It is red, which means Security 1.

To me, it looks like it may be missing a 2nd pair of obstruction sensor wires.

nothing changed. for example this morning for the heck of it i just pushed the HE open button and it opened. it did not close and none of the other buttons worked. i closed it with the garage door closer and it would not open again from HE.

i know the board is getting the command because the blue light blinks instantly everytime i press any HE buttons.

there are only 4 wires coming out of the wall. 2 (red,white) for the wall button and 2(red,white) for the obstruction sensor. what other sensors are you referring to?

should i be using the dry contact connecctions instead of the ones on the right side?

Most obstruction sensors are attached to the opener in pairs. I guess they are likely wired together somewhere in your system. I've got a security 2 opener, so I can't really say much about a 1 opener.

What are you using for your MQTT server?