[BETA] IKEA TRADFRI Shortcut Button

Happy to report the first two are still working fine, so of course had to add another one.

After discovery it was doing the "three event" thing, multiple reset/re-pairings later it's working properly (1 push = 1 log entry) as well.
Unfortunately I didn't really keep track of the process (if there is one) to get it paired correctly.
From what I remember:

It was more than five but less than thirty times I pushed the "link" button four times to reset the button.

Deleted and re-discovered the button once. Initially the "Device Data: Details" section had no in/out clusters information until after the device was deleted and re-discovered from HE.

Device Data: Details

I switched to the Aqara button to control my Ikea blinds manually. One tap opens them 55%. A double tap opens them 100%. A single push closes the blinds.

Might be worth investing less than $20 for a button that works using the driver on guthub.

Just reporting that I bought 4 of those Tradfri Shortcut Button (203.563.82) and they work flawlessly with this driver.

I installed the driver first, went into pairing mode at 3-4' from the hub, pressed the battery button 4 times and they were recognized immediately.
Now, I just hope the battery will last more than 1 month.
Thank you very much for the work!

1 Like

Just wanted to say thanks - I did get this to work! The driver worked perfect for me, plan to get more buttons.

I'd gotten the button connected before without the driver, but hadn't had time to fuss with it to put it to use. Once I saw this, I reset the button, "forgot" it as a device, loaded the driver... it only took me about two hours to realize I coudn't get the button to be re-recognized by Hubitat... because the battery was now dead. New battery, and everything is beautiful. We'll see how long that lasts.

For now it's a doorbell button, sends an alert to my phone, until I get a smarter doorbell...

This driver doesn't seem to be working for me. My device says it has two buttons, But I only see one button that has a push and hold.
I am on my 4th driver. Yes, I tried the generic driver. I have no debug logs or error logs to show you.

Can somebody point me in the right direction?

Have you tried this one?
It's on my "someday" list. :smiley:

I tried the one with presents and I couldn't get it to work. it wouldn't configure.
My battery says it's at 30, so I'll get some batteries. I also have an Aeotec Walmote on order. :grinning:

Got it working! The problem was not the button or the fantastic driver by Ranchitat! it was the Zooz zen15 I wanted to turn on/off my espresso machine.

I couldn't set it to toggle for some reason. I used two actions. One to turn it on and one to turn it off. no biggie.
Also, the driver tells me there are two buttons. I only see one button with two actions. Push and hold.
Does this shortcut button actually have two buttons?

Does this shortcut button actually have two buttons?

There are only one physical button (button 1) but it some times sends an event for a button 2. I can't remember when. Perhaps when it is done initializing.

When you say it wouldn't configure, what did it do? Just interested, as switching driver can be a little tricksy at times and I might be able to tweak the driver to make it more intuitive.

If the device was already joined then it was likely in sleep mode and wouldn't have responded. The best way to reconfigure these buttons is to press them and then send the configure command within a couple of seconds, while it's still awake.

I was finally able to pick up a Shortcut Button.

Paired it to Hubitat without issue.

Trying to create an automation with the built-in Button Controller app and I get the following error:

app:96 2021-09-05 01:26:52.297 pm
error org.codehaus.groovy.runtime.InvokerInvocationException: hubitat.exception.NotFoundException: Child app not found for namespace: hubitat and name: Button Rule-5.0a (mainPage)

First off, am I using the correct Hubitat app to automate the Button?

Edit: rebooting the hub resolved the problem.

1 Like

Any solution to the battery consumption issue?

I'm on battery #3 in 2 days.
Great button, but super hungry.

Connected it to the Tradfri hub to see if there was a firmware update, but it was up to date.

1 Like

I soldered a usb wire on mine and plugged it in.
It runs fine on 5v. It’s in my workshop so it’s no big deal for me. I’m glad I only bought one.

1 Like

That is how all my tradfri buttons look like now:

20211030a

I use a 3v ac/dc adaptor to power it.

Interestingly, after doing this I notice the device send a "button 2 push" event every time the power comes back. So I use that to trigger needed tasks after recovering from a power outage (turning off some bulbs, restarting appliances, resetting states)

4 Likes

Three batteries in two days? Wowsers.

I think I'm getting about a month at the moment, but that's still ridiculous. I've got one here I replaced the battery in on 19/11/21. It still reports 3V, but whether that can be believed...

I was also going to pull out the Tradfri hub and peek for firmware updates, but you've saved me a job for now, thank you!

I connected mine, as well as the on/off button and the motion sensor, to the Tradfri hub and there weren't any firmware updates for any of them in my region.

I connected the on/off button to my pi running zigbee2mqtt and z2m found a firmware update.

I'm going to toss another battery into the shortcut button and see if z2m finds an update.

This battery drain problem is happening on all the major non-ikea hubs, so it's something ikea needs to address.

Perhaps they'll fix it as Matter gets closer.

1 Like

Not sure what this successful "pairing" relates to, but, it's still on the same battery from July...

My other 2 died so tried @birdslikewires Trådfri Driver and their batteries lasted 4 days and 8 days.

Good thing Ikea has a 1 year return policy. :wink:

I was wrong, I am now seeing that there is a firmware update for the shortcut button.

Mine is currently on 2.3.105 and being updated as I type.

Firmware was released about a week after I had connected everything to the Ikea hub.

Interesting, thank you - I'll see if I've improved matters with this test one and then try updating it.

Where did you get the firmware and how to you upgrade it?

Download the Hubitat app